Raspberry pi Zero W does not get IP from Archer MR600

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Raspberry pi Zero W does not get IP from Archer MR600

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Raspberry pi Zero W does not get IP from Archer MR600
Raspberry pi Zero W does not get IP from Archer MR600
2023-02-11 11:08:11 - last edited 2023-03-09 06:26:16
Model: Archer MR600  
Hardware Version: V2
Firmware Version: 1.3.0 0.9.1

This issue is similar to this: https://community.tp-link.com/us/home/forum/topic/543082

 

My Archer MR600 is setup to reserve an address for my Raspberry Pi Zero W.

 

This works fine, but it works only once. If I restart the the Pi, the DHCP server does not give it the IP again.

 

Restarting the router does not help.

 

I tried removing the address reservation on the router, no difference.

 

It looks as though the router gives an IP address once, then remembers it and won't give it again. It also worked only once last week-end, and now 6 days later it worked only once again. Some kind of lease time maybe?

 

How can I make sure that my Archer MR600 router's DHCP server always gives an IP address to my Raspberry Pi Zero W?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Raspberry pi Zero W does not get IP from Archer MR600-Solution
2023-02-15 18:38:32 - last edited 2023-03-09 06:26:16

  @Sunshine 

 

Yes, it was solved for the Pi Zero W by selecting channel 11 on the router. 

 

I couldn't find a setting in the Pi, where I would have hard-coded it to only listen on a single channel, but if anyone has an idea where to look, I'd be happy to. I did select Sweden (SE) as a country in the wpa_supplicant, and that might affect channels.

 

All other devices seem to connect without issues, on channel 11 and on Auto.

 

I retried Auto, and could not connect to the Pi anymore. The router status said "Auto(1)". Maybe the raspbian version I use bans channel 1 for country SE?

Recommended Solution
  0  
  0  
#4
Options
3 Reply
Re:Raspberry pi Zero W does not get IP from Archer MR600
2023-02-11 11:29:53

More info: scanning wlan0 from the pi discovered no Wifi (sudo iwlist wlan0 scan).

 

I changed the Wifi channel on the router from Auto to 11, and scanning from the Pi started working.

 

What is going on? Why wouldn't the Pi be able to scan the router's Wifi if it's in Auto?

  0  
  0  
#2
Options
Re:Raspberry pi Zero W does not get IP from Archer MR600
2023-02-15 04:44:22

  @Gauthier 

 

Hi, may I know if the IP address issue has been solved after you changing the WiFi channel from Auto to 11?

 

Besides, when the channel was set on Auto, all the other client devices can see and connect the WiFi properly, right? and which channel it was working when it was set on Auto? (You could check the Wireless part on Advanced->Status page to find the channel even when it is set on Auto.)

If you found the post or response helpful, please click Helpful. If an answer solves your problem, click "Recommended Solution" so that others can benefit from it.
  0  
  0  
#3
Options
Re:Raspberry pi Zero W does not get IP from Archer MR600-Solution
2023-02-15 18:38:32 - last edited 2023-03-09 06:26:16

  @Sunshine 

 

Yes, it was solved for the Pi Zero W by selecting channel 11 on the router. 

 

I couldn't find a setting in the Pi, where I would have hard-coded it to only listen on a single channel, but if anyone has an idea where to look, I'd be happy to. I did select Sweden (SE) as a country in the wpa_supplicant, and that might affect channels.

 

All other devices seem to connect without issues, on channel 11 and on Auto.

 

I retried Auto, and could not connect to the Pi anymore. The router status said "Auto(1)". Maybe the raspbian version I use bans channel 1 for country SE?

Recommended Solution
  0  
  0  
#4
Options

Information

Helpful: 0

Views: 372

Replies: 3

Related Articles