Problem with some sim card

Problem with some sim card

Problem with some sim card
Problem with some sim card
2023-03-21 16:01:12
Model: TL-MR6400  
Hardware Version: V5
Firmware Version: 1.1.0 0.9.1 v0001.0 Build 210803 Rel.55933n

 

I have Indonesian Tri Sim Card but it doesn't work if i try it with the router. I have tried other sim card and it work. Only this Tri Sim Card has this problem.

It says "No Service. Please go to Advanced > Network > Internet to select the suitable Network Mode and try again. If you are unsure of which network you have, select 4G Preferred."

The card doesn't have any problem if i use it on my phone.

Any fix for this?

 

  0      
  0      
#1
Options
7 Reply
Re:Problem with some sim card
2023-03-22 08:34:31

  @silencerz23 

 

Hi, could you please check which 4G band your phone is using with the same SIM card at same location?

https://www.tp-link.com/support/faq/3488/

 

In addition, when you test the same SIM card on the phone, please also enable phone hotspot to see if it allows sharing internet to multiple clients, some special SIM plan might only allow the SIM to work on smartphones or ISP-supplied devices.

  0  
  0  
#2
Options
Re:Problem with some sim card
2023-03-22 11:38:55

  @Sunshine 

i believe its on band 3 (1800Mhz)

 

yes, i tested it on the phone and enabled the hotspot. No problem about it, other devices connected to the hotspot can access the internet

 

 

  0  
  0  
#3
Options
Re:Problem with some sim card
2023-03-23 02:52:44 - last edited 2023-03-23 02:53:44

  @silencerz23 

 

Hi, is the Tri signal quite weak here? It seems that your phone only receives 1 bar signal.

On the MR6400, please make sure the network type is on 4G preferred and band is on Auto, if it still shows No Service with Tri SIM card, please try to move the router where the signal might be better such as near the windows at different sides of your home. 

You could also try to adjust the direction of the antennas on MR6400 to see if it makes any difference.

  0  
  0  
#4
Options
Re:Problem with some sim card
2023-03-25 07:35:44

  @Sunshine 

 

hello,

i believe its not about the signal that's weak since my phone can just connect fine.

However with the modem case, the network isn't even registered, let alone connect it to the internet.

Here is some screenshot of system log if you need it

 

 

  0  
  0  
#5
Options
Re:Problem with some sim card
2023-03-25 07:57:31 - last edited 2023-03-25 07:58:03

i have tried selecting manually network, setting APN, or even let it all auto, it all have the same problem as stated above.

also, i wanna argue that even other modem can connect with this sim card. so i cant imagine this is a signal problem

  0  
  0  
#6
Options
Re:Problem with some sim card
2023-03-28 11:14:55

@Sunshine 

any update for this?

  0  
  0  
#7
Options
Re:Problem with some sim card
2023-03-28 12:01:54

  @silencerz23 

 

Hi, please email support.forum@tp-link.com with subject "Forum 603552 Tri SIM doesn't work on MR6400", further debugging will be needed to locate the issue.

  0  
  0  
#8
Options

Information

Helpful: 0

Views: 212

Replies: 7

Related Articles