No way to disable DHCP for good?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

No way to disable DHCP for good?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
No way to disable DHCP for good?
No way to disable DHCP for good?
2023-10-04 19:14:13 - last edited 2023-10-08 11:33:28
Tags: #Feature Request #DHCP-OFF
Model: TL-WR802N  
Hardware Version: V4
Firmware Version:

How does one completely disable the DHCP server on TL-WR802N? You would think with LAN Setting->SmartIP(DHCP). Though you don't. Here is why: when you set it to DHCP, and it gets an address offer, all is fine. If it doesn't get one, or no renewal, it automatically starts its own DHCP. I don't want this. I don't want it starting its own DHCP when it is without IP. Consider this 'smart' or not. 

 

Here is the full backgound: we run one TL-WR802N in Operation Mode 'Client' and with 'SmartIP(DHCP)' to hook an RJ45-only-box to an AP. This AP is connected to the main, and unique, DHCP server through a WiFi link. Once this link goes down, the clients won't obtain/renew DHCP. Bad luck, and we are aware of that. 

However, when this TL-WR802N doesn't get/renew an IP due to the missing WiFi link, it does - so it seems - inevitably start its own DHCP, dishing out its own IPs. Inevitably, the other clients then accept the IPs dished out through this rogue behaviour. Meaning, they won't reach beyond that access point, because the TL-WR802N considers itself as gateway in case of dishing out IPs.

 

The DHCP Settings are grayed out, and it is written in red: "Note: The DHCP Settings function cannot be configured if you have chosen Smart IP (DHCP) in Network->LAN (in this situation the device will help you configure the DHCP automaticaly as you need)." So, this is intended, and there seems to be no way to completely disable the DHCP server.

It made me quite angry when I finally understood this reason for regular network outages of the clients connected to this AP. It could have never imagined when I configured it, that it would either have an IP - or respond to DHCP REQUESTS. 

Is it asked too much to want to be able to just configure it to be a mere DHCP client; and never turn into a DHCP server?

Would anyone have a solution to avoid this not-too-smart behaviour, please?

 

Btw. This is intended behaviour, as can be seen from this log entry:

DHCPD Notice Disable AP's DHCP server because remote DHCP server is online.

 

I consider this a bug, yes, because it is run as CLIENT and not as AP.

  0      
  0      
#1
Options
1 Accepted Solution
Re:No way to disable DHCP for good?-Solution
2023-10-08 07:32:36 - last edited 2023-10-08 11:33:28

  @Digard Maybe you can change the LAN type from Smart IP to static IP

Recommended Solution
  0  
  0  
#2
Options
2 Reply
Re:No way to disable DHCP for good?-Solution
2023-10-08 07:32:36 - last edited 2023-10-08 11:33:28

  @Digard Maybe you can change the LAN type from Smart IP to static IP

Recommended Solution
  0  
  0  
#2
Options
Re:No way to disable DHCP for good?
2023-10-08 10:02:42

  @Byron1234 

Yes, that's what I was thinking of, naturally. The problem is, that we change the gateway IP from time to time. Then this client wouldn't have access.

Actually, I still hope that tp-link considers this to be a bug: clients inevitably dishing out dhcp addresses. I didn't find a bug reporting utility. If there is one, I will gladly file a bug report.

  0  
  0  
#3
Options

Information

Helpful: 0

Views: 462

Replies: 2

Tags

Related Articles