Getting Wan ip but no internet in XC220-G3V

Getting Wan ip but no internet in XC220-G3V

Getting Wan ip but no internet in XC220-G3V
Getting Wan ip but no internet in XC220-G3V
2024-04-04 17:38:26
Model: General Product  
Hardware Version: V2
Firmware Version: 1.8.0.0.8.0 v6062 Build 230720 Rel 48094n

Hello guys, 

I recently purchased XC 220-G3V  v2.0 for replacing my ISP provided modem. I got through the initial setup and used mac clone to clone the mac of my isp provided modem to tplink. I also added GPON serial number and gpon password in xpon settings menu. After doing all this and connecting via PPPoE i was able to establish connection. But i couldn't get internet access to devices connected. The modem was able to get wan ip and gpon was in registered state O5. I have tried manually adding DNS but still no internet connectivity. I can ping websites via diagnostic menu. 

Sometimes i get internet access for like 5 sec and then it stops

Kindly help me with can be the issue and how to resolve it. Tried calling customer support but they have not reverted to my calls

Adding some pictures for reference.

 

Thanks 

 

 

 

 

 

 

 

 

  0      
  0      
#1
Options
18 Reply
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 00:56:00

  @Drdiamond 

 

In general your settings seem fine.

Get rid of these optional settings:

 

Restart XC220-G3V, then your mobile and test again.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#2
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 02:54:55
Removing these settings had no influence on the connection. Tried it still no internet
  0  
  0  
#3
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 03:20:27 - last edited 2024-04-05 11:34:48

  @Drdiamond 

 

You wrote " I can ping websites via diagnostic menu.  "

That means the router has internet access itself but not your client devices - is that correct ?

This router model is usually distributed by ISPs - it's probably best to check this thread.

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#4
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 04:56:39
Thanks for the info brother but i have checked the post and its not possible for my ISP to configure as he wants me to buy his own modem. I am able to rung ping test via modem and i am getting reply with 0% packet loss. So its safe to safe my modem is connected
  0  
  0  
#5
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 12:49:08

  @Drdiamond 

 

Your settings are fine but it's not clear why your client devices don't have an internet access.

Connect a computer to the router and execute the following commands in command prompt then post the screenshots here:

 

 

 

 

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#6
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 14:11:13

  @terziyski i made these changes and it made no difference at all. No able to get internet access 

  0  
  0  
#7
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 14:14:54

 @terziyski hey thanks for taking time to reply. I did run thise commands and have attached here. I can ping IPs but not domain's. Cant seem to understand the cause of this behaviour.

 

 

 

Seems weird to understand 

  0  
  0  
#8
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 15:55:08

  @Drdiamond 

 

That's clearly a DNS issue with your router for some reason.

Form you router System Tools=>Diagnostics if you ping google.com is there any replies ?

Did you try using the ISP DNS servers (disabling this checkbox):

 

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#9
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 15:57:20
When i run ping from diagnostic in setting, i am getting response with 0% packet loss. The issue remains same even when using ISP dns i.e when u checked the option.
  0  
  0  
#10
Options
Re:Getting Wan ip but no internet in XC220-G3V
2024-04-05 16:06:33 - last edited 2024-04-05 16:07:44

  @Drdiamond 

 

So, bottom line whatever DNS you use (ISP's or Google's) the router has internet access itself but not your client devices.

That's a weird issue and I don't think I could help with something else - probably you should contact your ISP to be advised.

As I wrote earlier this model is for ISPs and is not supported by the community.

 

If this was helpful click once on the arrow pointing upward. If this solves your issue, click once the star to mark it as a "Recommended Solution".
  0  
  0  
#11
Options

Information

Helpful: 0

Views: 997

Replies: 18

Related Articles