Wireless Connection Constantly Drops and Reconnects in WISP Mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Wireless Connection Constantly Drops and Reconnects in WISP Mode
Wireless Connection Constantly Drops and Reconnects in WISP Mode
2014-06-21 00:12:43
Region : Canada

Model : TL-MR3020

Hardware Version :

Firmware Version : TL-MR3020_V1_140408

ISP :


When I operate this router in WISP mode (I don't seem to see the issue in 3G Mode) my mobile phone (Nexus 5) is constantly disconnecting and reconnecting (every 30-60 seconds). The wireless connection to my laptop appears to be fairly stable however. My phone hasn't had any issues connecting to any other wireless routers/access points so I don't think it's a phone issue.

So far I've tried:
1) Setting the encryption mode to WPA2_Personal (not mixed mode)
2) Setting the wireless mode to 11n Only
3) Disabling WMM (that prevented my phone from connecting at all)
4) Setting my phone to request a static IP address

Anyone have any other ideas that I could try?
0
0
#1
Options
5 Reply
same issues here
2014-06-22 20:23:17
I got the same problem here.

My brand new MR3020 running with latest FW drops WIFI, but only for my Macintosh computers !!!!!

I configured it to WISP client with WPA2. WMM is disabled.
What is really annoying : you cannot change bandwidth or channel number in WISP mode: you have to switch to AP mode first then change region from USA to any other :mad:

Anyway: all my android devices are working fine, all my Macs (on Mavericks) are disconnecting after 30 seconds :confused:

What is going on here ? Is the MR3020 not compatible with MacOS ????

I do not have windows.

Thank for any help !!!!!!!!!
0
0
#2
Options
Re:Wireless Connection Constantly Drops and Reconnects in WISP Mode
2014-06-23 03:10:30
WPA2/AES, 20MHz bandwidth size, and DNS addresses in DHCP Settings next step Save and reboot.
0
0
#3
Options
Re:Wireless Connection Constantly Drops and Reconnects in WISP Mode
2014-06-23 04:23:33
thanks for the fast reply. Already had that config, though.

My Wifi settings are

Wireless
Name (SSID): qwertz
Channel: 3
Mode: 11bgn mixed
Channel Width: 20MHz
MAC Address: xx-xx-xx-xx-xx

WPA2 personal with AES
WMM disabled

DHCP:
DHCP Server: Enable
Start IP Address: 192.168.0.100
End IP Address: 192.168.0.199
Address Lease Time: 120 minutes
Default Gateway: 192.168.0.254
Default Domain:
Primary DNS: 0.0.0.0
Secondary DNS: 0.0.0.0
0
0
#4
Options
Re:Wireless Connection Constantly Drops and Reconnects in WISP Mode
2014-06-23 23:00:33

jimasek wrote

WPA2/AES, 20MHz bandwidth size, and DNS addresses in DHCP Settings next step Save and reboot.


Thanks for the ideas. I was already running WPA2/AES with the channel size set to 20MHz. I went ahead and added google public DNS - 8.8.8.8 as primary and 8.8.4.4 as secondary. Unfortunately that didn't help. My phone is still seeing the same dropping and reconnecting of the wireless connection. Any other ideas that I could try?

Tonight I may try the previous firmware just to see if it's a little bit more stable.
0
0
#5
Options
Re:Wireless Connection Constantly Drops and Reconnects in WISP Mode
2014-06-24 16:18:33

geooffy wrote

Thanks for the ideas. I was already running WPA2/AES with the channel size set to 20MHz. I went ahead and added google public DNS - 8.8.8.8 as primary and 8.8.4.4 as secondary. Unfortunately that didn't help. My phone is still seeing the same dropping and reconnecting of the wireless connection. Any other ideas that I could try?

Tonight I may try the previous firmware just to see if it's a little bit more stable.


Tried the new and previous FW: no success.
Tried AP-mode with different channels: no success.
Tried all combinations of bandwidth: no success.
Spent 4 days with this device: will return it.
0
0
#6
Options