asking for password all the time

asking for password all the time
asking for password all the time
2015-01-22 18:44:31
Region : Denmark

Model : TL-WA850RE

Hardware Version : Not Clear

Firmware Version :

ISP :


Hello,

I bought the Range Extender yesterday. Connecting was easy (at least I thought so). Used the WPA button on the router. Afterwards on my cellphones (Samsung Galaxy S4 and iPhone 6) it keeps asking for the password again and again and will not connect throug wifi. The RE has good signal.

on the RE there are the following info:

S/N TL-WA850RE (EU) Ver: 1.25
S/N 2148762003227

best regards
0
0
#1
Options
3 Replies
Re:asking for password all the time
2015-01-23 10:16:00
Login web interface of WA850RE. Check its firmware version. If it is not the latest version, upgrade it.
http://www.tp-link.com/en/article/?faqid=605
After upgrade, go to quick setup to configure it with Method Two.
http://www.tp-link.com/resources/document/TL-WA850RE_V1_QIG_7106504652.pdf
0
0
#2
Options
Re:asking for password all the time
2015-01-28 18:58:07
thanks for the answer.
updated the firmware and did thie configuration. At the end, the process stoppes and with information that the process expired. In portuguese "tempo limite da operação foi atingido." does it have to be this hard to install just because you are not a tech nerd.
0
0
#3
Options
Re:asking for password all the time
2015-01-30 11:07:00
It is not difficult to install it but it seems not quite smooth in your end.
Is it stopped in Finish page?
Are you connecting to the extender by a cable to install it? Try a different web browser or PC.
Beside, what's the firmware version now? Check it on Status page.
0
0
#4
Options