Archer T8E Keeps Disconnecting

Archer T8E Keeps Disconnecting
Archer T8E Keeps Disconnecting
2015-04-23 00:19:20
Region : Brazil

Model : TL-WDN4800

Hardware Version : V1

Firmware Version :

ISP :


I just bought an Archer T8E with an AC1750 router. Every couple of hours or so, my internet keeps disconnecting and magically reconnects, and sometimes, i have to reconnect it myself, i open my network tab and it's there, not connected, but it's there. And wierdly enough, i cant connect to my 2.4 network, i have other devices connected to it so i know its working, i dont know what else to do, anyone can shed some light to it?
0
0
#1
Options
3 Replies
Re:Archer T8E Keeps Disconnecting
2015-04-23 16:21:34
Operating system of your PC?
Provide model number and its firmware version of your AC1750 router here.
How about signal strength? Does it affect network stability?
0
0
#2
Options
Similar issues
2015-07-24 10:43:13
I'm having similar issues in windows 8.1 with an Archer C7 V2 with Firmware version 3.13.34 Build 131217 Rel.60903n. It's gotten rather annoying, but I've learned to "fix" it pretty quickly by switching from the 5Ghz band to the 2.4Ghz band, then back to the 5Ghz band. No idea why that works, but it does. Phones and tablets in the house don't drop connections like this, so I can only assume it has to do with the wifi adapter/something in my particular computer making it do this. I've run virus scans and installed the latest drivers for the card from TP-Link's site, and the signal is almost full strength (one bar missing from the windows 8.1 display). Any help or advice is appreciated, as I'm just sitting here scratching my head.
0
0
#3
Options
Re:Archer T8E Keeps Disconnecting
2015-07-27 16:09:02
Upgrade firmware of your C7 to be the latest version. Reset and reconfigure it.
http://www.tp-link.com/en/download/Archer-C7_V2.html#Firmware
0
0
#4
Options