TL-WA901ND wont assign ip in wifi repeater mode

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
TL-WA901ND wont assign ip in wifi repeater mode
TL-WA901ND wont assign ip in wifi repeater mode
2015-10-15 03:09:24
Model : TL-WA901ND

Hardware Version : V2

Firmware Version : 120224

ISP :

This is my current network setup.
I have TD-W8980 as my mainrouter. Internet connection, wifi on and dhcp on. The W8980 is connected via ethernet cable to a W8901N static ip for router, wifi on, dhcp off. With this setup everything works very well.

The next thing is I just wanted to extend the wifi range of the W8901N without draging more lan cables. I put up the WA901ND in repeater mode put in the mac address of the W8901N. In the setup page of the WA901ND I can see it display the connected wifi. The password and security between the 8901N and 901ND is the same. On the widi analyzer I can see 2 wifi with the same ssid on the same channel. This is where the problem is. If I connect to 8901N I can connect normally. I can roam around the wifi area of both the 8901N and 901ND. If I am in the area of the 901ND the internet is abit slower but it is expected with wifi repeaters. Now if I am near the 901ND and try to connect wifi. I cannot get assigned ip from the network. If I am closer to the 8901N I get assigned ip normally. What is going on here?

This is what I tried so far. I tried putting the mac address of the 901ND in the 8901N WDS setting. Same result, no assigned ip. I tried universal repeater and bridge with ap, no assigned ip. I even tried setting the 901ND to dynamic ip. The 901ND can connect to the network with the 8901N and get assigned ip from the 8980 but anything that is connected to the 901ND cannot get ip.

The only thing I can get to work properly is if I connect the 901ND via ethernet and set it as access point. The 901ND can assign ip normally. But this is not the solution i am looking for.

Am I missing something setting up the 901ND as a wifi repeater?
0
0
#1
Options
4 Reply
Re:TL-WA901ND wont assign ip in wifi repeater mode
2015-10-15 09:51:09
You just need to enable DHCP for the W8901N.
0
0
#2
Options
Re:TL-WA901ND wont assign ip in wifi repeater mode
2015-10-15 11:04:03
Try universal repeater mode.
0
0
#3
Options
Re:TL-WA901ND wont assign ip in wifi repeater mode
2015-10-15 14:59:11
Thanks for the replies. I have sorted out the problem.

@Johnson, I was thinking of trying that but I needed to disable the main router dhcp and enable dhcp on the 8901N otherwise it might conflict between the 2 dhcp on both routers. But you did give me an idea to look for the dhcp relay on the 8901N which is what sorted out the problem.

The 901ND is currently on universal repeater.
0
0
#4
Options
Re:TL-WA901ND wont assign ip in wifi repeater mode
2015-10-15 19:31:01
I don't think it will conflict between the 2 routers. You need to open two of them the DHCP. And you can try it by yourself. If you have solved, it will be better.
0
0
#5
Options