TL-WPA8630 KIT: no IPv6 communication

TL-WPA8630 KIT: no IPv6 communication
TL-WPA8630 KIT: no IPv6 communication
2017-02-02 19:11:47
Model :

Hardware Version :

Firmware Version :

ISP :

Hello, I recently bought a TL-WPA8630 KIT (V1, EU).
The Powerline connects my fiber router in the living room to the PC in my room and it also works as an 802.11ac access point.

My problem is that the Powerline devices are blocking all IPv6 packets. This happens when I connect to the TL-WPA8630 both via Ethernet and Wi-Fi. The issue is weird because the PC and the mobile devices manage to get an IPv6 address, but all IPv6 traffic is blocked and IPv6 pings also fail.
IPv6 works fine if I'm connected directly to the fiber router either via Ethernet of via Wi-Fi, so I think that this is a problem of the TP-Link Powerline.

Do you have any suggestion?
0
0
#1
Options
5 Reply
Re:TL-WPA8630 KIT: no IPv6 communication
2017-02-10 18:30:20
Same here.

Sometimes IPv6 works for a while after a reboot of TL-WPA8630. Sometimes it works only via wifi, but not via ethernet ports. Sometimes it even works on one (random) ethernet port, but not on any other. Anyway, it always stops working after a few hours. Symptoms are the same, computers somehow get an IPv6 address from router, dns query returns IPv6 address, but ping and everything else is blocked.

I have some other tp-link powerline devices, IPv6 works ok when connected to TL-PA8010 (the non-wifi part of the KIT). So problem seems to be only in TL-WPA8630.

Firmware version: TL-WPA8630(EU)_V1_160529
0
0
#2
Options
Re:TL-WPA8630 KIT: no IPv6 communication
2017-02-12 01:52:36
Same here, with the US variant of this product.

I have IPv6 connectivity if I'm connected to:
- my home router (wired or WiFi)
- a pair of TL-PA8010 (one connected to my machine, the other one to the router)

I do not have IPV6 connectivity if I'm connected to:
- the TL-WPA8630 (any of the 3 ethernet ports)
- the TL-WPA8630 over WiFi

I still get an IPv6 address, though.

I have tested with OSX and Linux devices, the behavior is the same.


Model: TL-WPA8630 KIT
Hardware Version:
TL-WPA8630 v1 00000000
Firmware Version:
1.0.1 Build 160512 Rel.41793n
0
0
#3
Options
Re:TL-WPA8630 KIT: no IPv6 communication
2017-02-13 02:12:35
Weird, right now I can ping via IPv6 and all IPv6 features work (at least according to IPv6 tests on the Internet). Never happened before, and I didn't change any configuration.
0
0
#4
Options
Re:TL-WPA8630 KIT: no IPv6 communication
2017-02-14 00:39:02
When looking for related issues, I found this one:

http://forum.tp-link.com/showthread.php?93420-TL-WA801ND-3.16.9-Build-151217-blocking-Multicast-MultiSSID&highlight=ipv6

It mentions problems about multicast, and indeed, when doing extra testing, I was able to get some unicast packets through (e.g. direct pings between the gateway and a host connected to the TL-WPA8630) but multicast packets did not seem to go through. I will try to craft specific packets to see what does and doesn't work.
0
0
#5
Options
Re:TL-WPA8630 KIT: no IPv6 communication
2017-03-25 19:22:23
I succeeded in enabling IPv6 by installing a beta firmware upgrade. Quote from here:

I just tried and installed a beta firmware from this site.
I chose the "TL-WPA8630v1_170314.EU.beta.Entertain.zip" file because I have the "v1" hardware version (be careful!).
Then I went through the firmware upgrade process on the web administration panel, and now IPv6 works :)

Obviously I can't guarantee anything about this process, so if you decide to do this, this is at your risk!
0
0
#6
Options