TL-PA511KIT not giving anywhere near the speed it is supposed to.

TL-PA511KIT not giving anywhere near the speed it is supposed to.
TL-PA511KIT not giving anywhere near the speed it is supposed to.
2017-06-16 02:47:29
Model :

Hardware Version :

Firmware Version :

ISP :

I am using the TL-PA511KIT which is supposed to work at a speed up to 500 mbps (I know the difference between mbps and MBps) while our internet subscription is 200 so eventho I know it's normal to lose some of that 500 speed it should work find with the 200 mbps subscription right? My pc is brandnew with good parts, the cable used is utp cat 5e so that's fine (even went out for those specifically because the kit came with utp cat 5), put my pc settings to 1 gbit because the powerline has a gbit port. With this all I still only manage to get around 40 mbps (tested it many times with speedtest.net). What can I do to at the very least double my speed? This is really annoying to have such slow internet especially as all my friends (we're gamers so speed is pretty important) have a speed 5 times faster. On the same circuit as the receiving part (the one going into my pc) only has my pc, a lamp, my phone charger (tried pulling this last one out and only helped for like 3 mbps) and a babyphone, nothing I can really leave out. Thanks in advance for any potential advise.
0
0
#1
Options
3 Reply
Re:TL-PA511KIT not giving anywhere near the speed it is supposed to.
2017-09-18 17:51:00
AV500/500Mbps refers to the powerline rate that the 2 PLC units communicate to each other within the power lines. 500Mbps is the max they can acheive in ideal, but the actaul rate is mainly decided by the quality of power line environment they're operating in. Another thing is, the actaul internet speed on the PC can only reach up tp around 40%of the powerline rate.

Test in some other powerline sockets around the house and also install the powerline utility to check the current powerline rate between the 2 units, then you will know if they are perform normal or not.
0
0
#2
Options
Re:TL-PA511KIT not giving anywhere near the speed it is supposed to.
2017-09-18 21:22:16
"work at" does not equal usable bandwidth. According to SmalNetBuilder tests, typical best case throughput for AV500 devices is 40-50mbits

See https://www.smallnetbuilder.com/tools/charts/powerline/bar/90-down/11?see=AVG
0
0
#3
Options
Re:TL-PA511KIT not giving anywhere near the speed it is supposed to.
2017-09-18 21:44:52

The Vogon wrote

"work at" does not equal usable bandwidth. According to SmalNetBuilder tests, typical best case throughput for AV500 devices is 40-50mbits

See https://www.smallnetbuilder.com/tools/charts/powerline/bar/90-down/11?see=AVG

I have at my home AV500 too. Transfer of internet is up to 60Mb/s.
0
0
#4
Options