How to let my USB adapter works on the Mac OS big sur

Used Products:

Hi guys,

I found a method that can let my TP-Link adapter work on the Mac OS Big Sur!

I had a Mac book pro (2017) and Archer T2U Nano. And I found the method on the below Git hub link then I download the driver Wireless USB OC Big Sur Adapter-V5 and follow the instructions to install it.

Github link:

In order to let this adapter installed and work, I have to disable the SIP and give the authority of this App to be installed.

Note that Apple doesn't recommend disabling the SIP, but for me, I have to use the adapter to work so I use this method.

So if you have to use the USB adapter on your Mac maybe you can have a try.


Below are the steps I took to make it work properly.

1. Reboot into recovery mode.  For my Mac book pro, hold “command + R” at power on until the display says loading options.

2. Disable the SIP. Go to the utility menu and choose Terminal. Type “csrutil disable” and press enter, then reboot the mac to let this take effect.

3. Give the APP authority in order to installed on Mac.

Open terminal and type this command “sudo spctl --master-disable”

Then you can find the “anywhere” option on the Security & Privacy page.


4. Download and install the driver. For me the latest version 5 works!

Download link:

During the installation, it may ask you for authority. Then go to the system preference, Security & Privacy and click the “details” to give the APP permission to be installed.

After the driver installed successfully, then the Archer adapter can work properly.  



Sir i followed ur method on hackintosh machine bt didnt success after restart mac no wifi so sir can u check it again n updatw us more hope dnt mind

Thanks! Works with V5. V7 however gave an error when extracting the archive. So I think I'll stick with V5 for now :)

(sorry image in danish)

excelente, me sirvio, gracias!

But is it possible to then switch SIP on again and have it work? I couldn't do it ... 

Excellent read, Positive site, where did u come up with the information on this posting? I have read a few of the articles on your website now, and I really like your style. Thanks a million and please keep up the effective work.



Thanks for sharing the @Marinekkkk for sharing the steps. I have a TP-Link T2U V3. Unfortunate, the above steps didn't work for me - after this I tried this version V7 ( also no success. I want to uninstall this driver but that also don't work.


Can someone please advice on which steps?

I have tried the Uninstall.command and TRL+ALT pressed together and select the USB icon in the taskbar and pressed "Uninstall USB-WiFi" also nothing happens after pressing the Yes button during the "Are you sure to do uninstallation?".


Thanks in advance



The instructions by Marinekkk worked my my Macbook Air with a T2U Nano.  Thanks!!!

excellent information for nice work for USB adapter works on the mac

Thank you!! Worked great

Thank you

Hello, World ! Wi-Fi