PiHole - Omada-SDN does not use the IP of the Raspberry

PiHole - Omada-SDN does not use the IP of the Raspberry

PiHole - Omada-SDN does not use the IP of the Raspberry
PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-29 16:36:45
Model: OC200  
Hardware Version: V1
Firmware Version:

Hello,

Would like to add a Raspberry Pi with PiHole to my Omada SDN.

I have now entered the IP of the Raspberry as the primary DNS and the cloudflare DNS server as secondary.

 


 

If I remove the Cloudflare DNS server everything works fine.

However, if the Cloudflare DNS is entered as secondary, this DNS server is always used and not the IP of the Raspberry

 

What can I do so that the IP of the Raspberry is preferred?
Thanks :)
 

  0      
  0      
#1
Options
22 Reply
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-30 19:45:46

Hi,
no one here who uses Omada SDN with PiHole?
This is a pity :(

  0  
  0  
#2
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-30 21:22:59

Hi :)

What information is needed?

The hardware?

Use the Follow
Controller - OC200 Controller Version 
5.12.9
Router - ER7206
Switch - SG2218 2x
AP - ERP245 2x

Raspberry Pi 3b with PiHole 5.17.3

Thanks :)

  0  
  0  
#4
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 01:13:14

Hi @lukass2000 

Thanks for posting in our business forum.

lukass2000 wrote

Hi :)

What information is needed?

The hardware?

Use the Follow
Controller - OC200 Controller Version 
5.12.9
Router - ER7206
Switch - SG2218 2x
AP - ERP245 2x

Raspberry Pi 3b with PiHole 5.17.3

Thanks :)

So how do you test this out? How do you draw this conclusion? Do you Wireshark and see how everything works behind the scenes?

We don't need your models as they don't matter in this case.

 

And, if you want to point to the DNS server, what would be the point in assigning 1.1.1.1? Are you worried about your server being down?

I set up both pi-hole and adg at home and they are located in different IPs so I don't use a public one. I can understand why you would do this. But the pi-hole would request the upstream so there is no point in getting a second one if your goal is to get the ad block.

Failsafe is OK. But I am more into the way/method you get the conclusion it only goes to the second DNS server.

 

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#6
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 04:38:07

Yes, the secondary DNS entry (i.e. 1.1.1.1) should step in if, e.g. the Raspberry fails.

That's how it's supposed to be, or not?

It would be bad if the whole family no longer had internet because PiHole no longer works ;)

 

I use Ubuntu and there I can use "$ resolvectl status" to find out which DNS server is in use.

 

But I can also call this website in the browser, or any other website with lots of advertising then you'll notice right away whether the advertising is blocked or not.

If this is blocked, everything runs via the primary DNS, is nothing blocked, 1.1.1.1 is in use ;)

  0  
  0  
#7
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 12:22:47

I have setup pihole this exact way and it works fine for me. Try going to Settings > Services > DNS Proxy and input the pihole IP there. My guess is that maybe pihole is taking too long to respond so a device fails over to the cloudflare ip? 

  0  
  0  
#8
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 14:59:13

  @BLTplays 
Is there any way to speed up access?

Which Raspberry model do you use?
I've read that even a Raspberry Pi 1 should be enough for PiHole.
Surely a 3b should be enough?

  0  
  0  
#9
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 16:43:11

  @lukass2000 

I run it as both a pi3b (primary dns) and proxmox container (secondary dns). Does your pihole have caching enabled? Responses from the pi should be much quicker once the pi grabs the result for the first time and caches it.

 

When you use the browser and go to website you previously mentioned, do you see that the pihole is receiving the queries in the first place? Also, does resolv.conf have the ip of the pihole? 

 

As a nuclear option, you could use the router as a dns server and have the router use the pihole as the upstream dns. If you go this route, pihole will only see the router as its only client, and would therefor loose a lot of the granularity of pihole.

  0  
  0  
#10
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 16:56:30

  @BLTplays 
yes, resolv.conf have the ip of the pihole.

 

Didn't change anything with caching.
If that's not enabled by default, surely that's disabled?

Where can i enable the PiHole caching?
 

Thanks :)

  0  
  0  
#11
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 17:06:22
On your lan, you can go to http://pi.hole/admin/api.php?getCacheInfo This will show a string of the cache info, at the start of it, there will be something around the lines of ...{"cache-size":10000,... As long as the number is greater than 0, then the cache is enabled. It appears to be enabled by default. Run 'dig 192.168.10.200 google.com' and send the result.
  0  
  0  
#12
Options
Re:PiHole - Omada-SDN does not use the IP of the Raspberry
2024-01-31 17:16:12 - last edited 2024-01-31 17:16:42

  @BLTplays 

okay, think it is enabled

 

First run 'dig 192.168.10.200 google.com'

 

second run

 

  0  
  0  
#13
Options

Information

Helpful: 0

Views: 1519

Replies: 22

Related Articles