Cpe210 Lag spikes

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Cpe210 Lag spikes

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Cpe210 Lag spikes
Cpe210 Lag spikes
2017-12-16 21:35:18
Model :

Hardware Version :

Firmware Version :

ISP :

[/SIZE][SIZE=2]Hi,
[SIZE=2]
I have a cpe210, Latest firmware (tried all the firmwares) set up as a client on a long stretch of ethernet cable to get internet over to an annex.
Connecting to a sky q hub.
But it has a strange issue where if I select 802.11n or 802.11b/g/n it has lag spikes of 3ms ever 2-3 seconds.
as soon as i drop it down to any thing lower it works perfectly. I have tried two cpe210's and they both have the same issue.
I have tried changing the transmit power with no change.
I have not yet tested using both either side and seeing if it is their problem or the routers problem.
I was just wondering if there was anything else I may be missing?
I'm thinking its an issue with the router as I read this back to be fair.

Many thanks.
[/SIZE]
  0      
  0      
#1
Options
25 Reply
Re:Cpe210 Lag spikes
2017-12-16 22:56:21
What do you mean with "lag spikes"? Do you mean the fallback to 1 Mbps in 802.11b/g/n mixed mode or 6 Mbps in 802.11n mode?
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#2
Options
Re:Cpe210 Lag spikes
2017-12-17 00:16:09
If you ping the router from a pc It jumps from 0-1ms to 3-6ms every 2-3 seconds. For normal usage it's not noticeable however if I'm playing a game it will rubber band and you can see the latency in game. As soon as I change it back to anything other than n it will be consistently >1ms.I will get some screen shots from tests once I'm home and show the config from the unit.
  0  
  0  
#3
Options
Re:Cpe210 Lag spikes
2017-12-17 00:21:37
My connection is only 30Mbs anyway so 54Mbs on b/g is fine at the moment I was just trying to find the problem. I will test it with another router later on and also try using one wired to the router to try and isolate the problem.
  0  
  0  
#4
Options
Re:Cpe210 Lag spikes
2017-12-17 05:36:21
Pinging the router over a radio link gives latency for all devices in between, not only CPEs, but also your PC's and the router's network layers. Latency depends on many factors such as load of the systems, uplink speed, saturation of the link etc. and in case of WiFi links most important: the AirTIme your devices can get.

For example, this is usual latency of a VPN tunnel from an edge router over a WiFi link using CPE510 through a gateway router to a VPN endpoint over a 500 Mbps Internet uplink. Those measurements were made on a heavily loaded link. WiFi speed is full 300 Mbps in 802.11n-only mode:






What's more, the 300 Mbps on this link is wireless speed, not data speed. Data speed is about 70% of wireless speed in 802.11n mode, thus yielding 210 Mbps over the wireless link, which is half-duplex. Therefore, if using full-duplex communication you have to cut this in half to get real data throughput (105 Mbps in both directions). That's BTW the reason why CPEs have a 100 Mbps Ethernet interface only, despite the fact that they can achieve 300 Mbps on the radio link.

In 802.11b/g mode the 54 Mbps is also max. wireless speed. But in b/g mode, data speed is only about 50% of wireless speed due to the modulation scheme used in this mode. Therefore, maximum throughput over b/g will be around 22 to 24 Mbps data speed at maximum in practice, not 30 Mbps.

So you should use n-only mode to reach 30 Mbps data speed, which would need ~ 45 to 54 Mbps wireless speed. b/g is limited to max. 54 Mbps wireless speed and gives you 24 Mbps data speed at maximum.

Now for the AirTIme: if your area is overcrowded with 2.4 GHz APs, don't expect to reach this figures using CPE210, since limited AirTime (the amount of time your CPE210 can allocate the radio channel for sending data) will considerably reduce the overall throughput and therefore increase the latency. This is not so problematic on short distances, but increases with larger distances (above measurements have been made over a distance of 600 meters, but in 5 GHz band).
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#5
Options
Re:Cpe210 Lag spikes
2017-12-18 00:18:24
Okay that makes sense, I wouldn't class it as over crowded there is another router close by that's on a different channel with an average household worth of equipment using mostly the 2.4gz band and the cpe210 is the only wifi connection to the router I am using. I will upload some pictures of ping stats later on. Every setting that uses N seems to produce the same problem. The router is only located 20m or so from the unit. Apart from showing the config of my unit and the ping stats is there any other information that would be useful?
  0  
  0  
#6
Options
Re:Cpe210 Lag spikes
2017-12-18 01:48:37
20m is a very short distance for a CPE210. Those devices are designed for long-range outdoor links. What is the exact topology for using a CPE over only 20m?
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#7
Options
Re:Cpe210 Lag spikes
2017-12-18 06:45:28

MathiasSexton wrote

to get internet over to an annex.
Connecting to a sky q hub.

??????
I do not understand that part .... connecting to the sky ... ???


As R1D2 said, you must expose your network topology ...


to what I understand it seems to me that it tries to connect the CPE210 from the remote place directly to the router in the main site, not using 2 CPE ..., if it is doing that, it is also cause of loss of Ping packets ...


expose details please


Regards...
  0  
  0  
#8
Options
Re:Cpe210 Lag spikes
2017-12-18 08:05:23
Victor, »Sky« is the brand name of a telco in Europe. AFAIK its headquarter is in the UK.
But lowercase »sky« is sill the opposite of hell I guess. ;)
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#9
Options
Re:Cpe210 Lag spikes
2018-01-23 18:16:02
Got the same problem. Two CPE210 1.1 (one is AP and one is Client) are connected (distance is 20meter). Cableline is at AP with 400Mbit/s. Airconnection shows 300Mbit/s. Making internet speedtests at the client, gives me always max. 65Mbit/s in downstream.
The bigger problem is the "lag or ping spikes". That drop you from online games time to time or result in extreme lags during the game.

Ping to google.com (you can see two spikes):





Client Settings:





AP Settings:


  0  
  0  
#10
Options
Re:Cpe210 Lag spikes
2018-01-26 00:29:07
Did you read post #5?

Lags come from interference. Interference comes from neighboring APs, obstructions and consumer devices allocating AirTime especially if using channel 9. 802.11b/g/n mode is useless in a PtP scenario (set to 802.11n), 20/40 MHz channel width too in 2.4 GHz band (set to auto). Distance should be set to auto, too.
༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
  0  
  0  
#11
Options

Information

Helpful: 0

Views: 6569

Replies: 25