Adding second pair of CPE210s to network; clients can't get IP address

Adding second pair of CPE210s to network; clients can't get IP address
Adding second pair of CPE210s to network; clients can't get IP address
2021-07-16 02:53:57
Model: CPE210
Hardware Version: V2
Firmware Version: 2.2.2 Build 20200612 Rel. 53582 (5553)

I setup a pair of CPE210s -- one in Bridge mode and the other in Client mode. Works beautifully. Let's call this Beam1A (the one in Bridge mode) and Beam1B (the client).

 

I actually tested a second pair of CPE210s, to transmit internet to another building in a different direction. It initially worked (first pair was not connected at the time; I was testing both out before doing permanent installation on outside of building). This second pair also has one in Bridge mode and the other in Client mode. Let's call them Beam2A and Beam2B

 

The two in Bridge mode (Beam1A and Beam2A) are connected to the same source/remote AP. It's actually a mesh network, and I selected "lock AP" to two different nodes/MAC addrs in the mesh, so they are locked to the nearest node, based on where they will be installed.

So... I'm now trying the second pair again, and it's not working. The issue is that no device connected to Beam2A can get an IP address (they end up with 169.254...) and thus no internet connectivity. At first, it would work intermittently. I'd connect a device, it would get an IP address and then it would reset in less than a minute and have no IP address. I'd try changing networks/SSIDs and back from the client device, and it would work! For a while anyway...

 

I then noticed that both units in Bridge mode had mostly factory default settings and they were sharing the same IP address. I realized when I was trying to access the builtin admin page, and even though I was connected via ethernet cable to Beam1A at the time, the admin page for Beam2A came up in the browser!

 

After I fixed that so they have different IP addresses, the second one now never works. No clients connected to Beam2A ever get an IP address. I then changed the device name on the second one (they were both the same: "CPE210"). I don't think this matters, but I changed it just in case. And sure enough, no change in behavior.

 

I have also tried a totally different unit, to make sure it wasn't something wrong with the hardware of the one unit.

So... I know Beam2A does have connectivity to the main/remote network because when my laptop is connected to Beam2A via ethernet cable, I can access the admin page for Beam1A wirelessly! (The two are not physically connected at all -- the only way one could route to the other is via the common remote AP.)

 

I've read plenty of replies on the lines of "don't use bridge/repeater mode", which seems mostly due to the directional nature. But that is definitely not the problem. Both devices report strong signal to the remote AP. The functioning unit allows download speeds that saturate my ISP speed (AT&T DSL), despite being in Bridge mode. And the fact that I can wireless access both devices' admin pages from an ethernet connection to one demonstrates that the connection to the remote AP is fine, despite the units not being pointed that direction. IN FACT, I just did another test: I connected wirelessly to Beam2A but configured my laptop to use manual IP settings, and configured a valid IP/mask for the wireless network (192.168.1.0/24) and manually entered the main AP router's IP address as the gateway -- and the internet works fine!

 

Neither Beam1A nor Beam2A are using DHCP (it wasn't necessary when I was initially testing), so I assume that means they should be getting their IP address from the remote AP's DHCP server. So why can't clients connecting to Beam2A get an IP address?

 

Any ideas?

0
0
#1
Options
1 Reply
Re:Adding second pair of CPE210s to network; clients can't get IP address
2021-07-16 03:01:46

For a little more data: they are both using all factory default settings other than me going through the "Bridge mode" wizard. The IPs are 192.168.0.254 for one and 192.168.0.253 for the other. They both connect to the same remote AP with all of the same settings and they expose two totally different SSIDs (we'll call them Beam1 and Beam2). And I also changed the "device name" on the system tab for one of them, so one is "CPE210" and the other is "CPE210B".

 

I've gone through all tabs of the admin page on both looking to see if somehow there is a difference in settings between the two. The only other difference (aside from the SSID/password for the network they provide) is that the distance on Beam1 is 0.15km and 0.1km on Beam2 (since the second building isn't as far as the first).

Yet somehow all clients that connect to Beam1 seamlessly get an IP address and functioning internet, whereas it only works through Beam2 if I manually configure the IP settings.

0
0
#2
Options