Two CPE210s can't connect well

Two CPE210s can't connect well
Two CPE210s can't connect well
2020-08-11 17:11:14 - last edited 2020-11-02 08:39:51
Model: CPE210
Hardware Version:
Firmware Version: latest

While waiting for Comcast to connect our house, I'm trying to piggy-back off our neighbor's wi-fi.  He kindly let me install a CPE210 configured as an access point on his garage, and I've installed a second one at our house with good line of sight back to the first, configured as a client.

 

The problem is, when I connect to the other CPE210's SSID, it's very glitchy, with ~1-2Mbps and then disappears.  However, if I connect from my house CPE210 to his wifi router, which I can see with the anntenna, it is much higher bandwidth (20-25Mbps).  Unfortunately this periodically drops signal as well, so it's not as stable as I'd like.

 

The two CPEs pointing right at each other over about 0.1km should have excellent connection, so I'm guessing that there's something misconfigured that's preventing that.  I've enabled Maxtream on the AP device.

 

Anything I should try when I pull the CPE from his house back to work on configuration before redeploying?

 

Thanks!

1
1
#1
Options
2 Accepted Solutions
Re:Two CPE210s can't connect well-Solution
2020-08-12 14:28:44 - last edited 2020-08-13 16:19:00

Hi Kirk,

 

you're welcome.

 

Some remarks:

 

88inall wrote

The AP antenna is unfortunately only 7 feet off the ground (that's what I can get on the neighbor's side), and mine is 20 feet in the air.

[...]

The AP antenna is in the neighbor's garage

 

Ehm, in the garage?

 

If it's really in the garage, this might be the cause for signal flapping.

 

7 feet is ~2m, 20 feet is ~7m, right? There is nothing wrong to mount CPEs at different heights as long as you tilt them accordingly.

 

However, the most important point for a reliable directional link even over 100m is a fresnel zone clearance of at least 40%, better 20%.

No tree, no wall, no car, no metal structure allowed inside the fresnel zone. Even no rain nor snow, but this is hard to achieve, so expect a drop of the signal by ~3dBm when it's raining or snowing. The remaining signal attenuation is caused by the air.

 

Here you have the interfences: the direct wave (path senderAreceiverB) being reflected from an obstacle inside the 2nd fresnel zone to the receiver (path CB):

 

 

 

Imagine the EM wave chaos if one CPE is inside a building or a garage and direct waves get reflected multiple times.

 

I'll try playing with the POE (can you really use the antenna directly plugged into Ethernet without going through a POE adapter?

 

No, this does not work. The CPE needs power; it's not just an antenna, but contains a lot of active components, too.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
Recommended Solution
1
1
#7
Options
Re:Two CPE210s can't connect well-Solution
2020-08-13 16:41:07 - last edited 2020-08-13 17:22:11

@88inall, you're welcome.

 

I suggest to set up the two CPEs in your home. Just reset the CPEs to factory defaults, place them a few meters apart, align them to each other, connect to the CPEs by cable with a laptop (change the laptop IP to 192.168.0.10 for initial setup, change the CPE's IP according to your needs, remember ro change the laptop's IP later on, log into he CPE's web UI again, save settings on the CPE). Don't change anything from the default your'e not 100% sure with.

 

CPE #1: AP mode

CPE #2: Client mode

 

It doesn't matter which CPE is running in AP or Client mode.

 

  • MAXtream: off
  • WiFi mode: 802.11n only
  • Channel: Auto (or select one according to the 1-6-11 scheme).
  • Channel width: 20 MHz
  • Security settings: WPA2/AES, encryption key
  • Distance: Auto (or real distance + 0.1km)

 

On the client perform a WiFi survey, select the CPE in AP mode, click »Lock to AP«, remember to »Apply« and »Save«.

Once the CPEs are linked wirelessly, you can access both CPE's web UIs without having to change the cable connection.

 

Now you can run a test to determine the wireless throughput using the built-in iperf test from the Tools menu.

Start one test on CPE #2 as the server, the other on CPE #1 as the client.

Play with antenna alignment to find the best signal quality and measure throughput again.

 

If this works, deploy them at the final position. Connect the CPE to the PoE adapter, but not to the network/PowerLAN. Connect a laptop to the LAN port of the PoE injector and test whether antennas are properly aligned. Adjust if necessary. The CPE's Antenna Alignment tool is most helpful for this task.

 

Then connect one part after another (PowerLAN, test again, switch, test again, router, test again).

 

Always test IP connectivity with ping. Don't even try to surf the web unless you checked IP connectivity, DHCP gateway/DNS server settings, routing and domain name resolution (commands ping, traceroute, nslookup or host).

 

Finally, test at the client side. It should work now much like it did when you had been setting it up in the office.

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
Recommended Solution
2
2
#11
Options
22 Reply
Re:Two CPE210s can't connect well
2020-08-11 20:54:30 - last edited 2020-08-11 20:56:18

@88inall,

 

MAXtream on PtP links doesn't make any sense. Turn it off.

 

Select 802.11n-only WiFi mode, 20 MHz channel width, set Distance setting to 0.2 km for an actual distance of 0.1 km and use the antenna alignment tool to properly align the CPE's antennas. Check signal quality, SNR etc.

 

If you still experience bad throughput, perform a WiFi search to see whether your area is overcrowded. If so, a CPE510 would probably perform better (I use CPE210 only in rural areas).

 

BTW: the disconnects of the CPE if directed to your neighbors WiFi router are caused by the weak signal back from the WiFi router to the CPE. Sure you can »see« this WiFi router's SSID on a CPE, but question is: can the WiFi router send a stable signal back to the CPE, too? Almost certainly it has much weaker omnidirectional antennas, so the link will never perform reliably over such a distance, which is too large for an omnidirectional AP mounted indoors.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
1
1
#2
Options
Re:Two CPE210s can't connect well
2020-08-11 22:27:16

@R1D2 Got it, thanks!  I changed all the settings as you suggested and unfortunately no difference.

 

The signal between the two antennas starts good - SNR 62db but I can watch it cycle from that to low to broken connection -- like clockwork, every 3 seconds.  The connection appears to be cycling or looping somehow.  I have just today swapped out the ethernet cables on both anntenas with grounded Cat 7 in case that was a problem before, but that doesn't seem to have made any difference.

 

We're in a rural area at the end of a cul de sac -- there are numerous other SSIDs I can see on the site survey, depending where I aim the antenna, but they are all low SNR, 20s and below.  When I run the antenna setup, I can see the same cycling occur: very strong signal, then it drops and disconnects before going back to strong signal.

 

Only other detail to mention is that the antenna on the neighbor's end is plugged into the ethernet port on a power line extender device, not directly to his router.  (I'm taking what I can get here...)  His network seems pretty stable, though that's a wrinkle that I suppose could be affecting things.  Both the powerline extender and the POE adapter for my anntena are plugged into the same outlet and therefore have the same ground.

 

Last thing I'll mention: I did update the firmware to the latest on both devices, although one is hardware v2 and the other v2.8 I believe.

 

Any other ideas for me to try?  Seems like there's some glitch that's just getting in the way -- or is it a firmware bug or something?

 

 

1
1
#3
Options
Re:Two CPE210s can't connect well
2020-08-12 03:04:36

Hello @88inall 

 

The signal between the two antennas starts good - SNR 62db but I can watch it cycle from that to low to broken connection -- like clockwork, every 3 seconds. The connection appears to be cycling or looping somehow. 

 

 

For the distance of 0.1km without any obstacles, SNR 62dB is not good enough. What's more, there might be some interference between the two antennas if the SNR appears unstable. Could you please verify whether there are any obstacles like hills/trees/winds between the two CPE210s?

 

Generally speaking, there is no need to configure the Distance settings if the real distance between the CPE_AP and CPE_Client is less than 300 meters.

On the CPE_AP, it's suggested to configure a different SSID from your neighbor's WiFi in case the CPE_Client confuses it.

On the CPE_Client, survey the SSID from the CPE_AP and connect it with the WPA/PSK password, change the LAN IP address to a different one to avoid IP conflict between the two CPEs, then no more settings needed.

 

If the CPE_Client is correctly connected to the CPE_AP, you will see the MAC address and SSID name of the CPE_AP and the Tx/Rx Rate, as shown in the following figure.

CPE_Client’s Radio Status:

 

 

Besides, you could refer to this instruction to adjust the orientation of outdoor AP for better signal coverage

 

Hope this information is helpful. Best regards!

Best Regards!
1
1
#4
Options
Re:Two CPE210s can't connect well
2020-08-12 04:43:59 - last edited 2020-08-12 05:16:29

 

Fae wrote

For the distance of 0.1km without any obstacles, SNR 62dB is not good enough.

 

Just to clarify:

 

A SNR (Signal to Noise Ratio) of 62dB is indeed pretty good, but can be better (70dB is not unusual with CPEs over 100m).

Since SNR (in dB) equals RSSI (in dBm) – noise level (in dBm), the rule is: the higher the SNR, the better.

 

A RSSI (Received Signal Strength Indicator or just: signal level) of -62dBm would be bad.

Since RSSI (in dBm) equals SNR (in dB) + noise level (in dBm), the rule is: the higher the RSSI (nearer to zero), the better.

 

Assumed the noise level is -99dBm, a SNR of 62dB would equal a RSSI of -37dBm, this is a very good signal.

 

But if it's the RSSI which is -62dBm (note the unit), the SNR would equal 37dB, which is a not so good signal-to-noise ratio.

 

BTW: the quality of the signal in percent is computed as follows (note that it leaves out the noise level completely):

  • For RSSI values higher than -50dBm, signal quality is always 100%.
  • For RSSI values lower than -50dBm the formula is: signal quality ~= 2 × (RSSI + 100).

 

For example, if the RSSI value is -62dBm, signal quality is 2 × (-62dBm + 100) = 76%.

That's not good for a CPE, it can reach easily 100% over 100m.

 

 

@88inall, please post the Status page with all four values, RSSi, SNR, Noise level and Tx CCQ.

Also number of nearby APs and their channels woud be considerable.

 

You should easily reach an RSSI of -30 to -40dBm over 100 meters.

 

If the signal really »cycles« (never saw such an effect), there might be heavy interfernces caused probably by a non-WLAN device operating in the 2.4 GHz band. Check whether there are any remote controls, microwave ovens, A/V transmitters, DECT phones, Zigbee, Bluetooth etc.

 

Or maybe the PowerLAN adapters are defective and cause a cross-talk on the cable. Just try to connect the CPEs wirelessly w/o connection to the PowerLAN adapters, but on your site connected to your laptop directly.

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
1
1
#5
Options
Re:Two CPE210s can't connect well
2020-08-12 12:53:44

@R1D2 and @Fae, thank you both for your assistance on this!

 

Some clarifications as requested:

The terrain is flat between AP and Client.  The AP antenna is unfortunately only 7 feet off the ground (that's what I can get on the neighbor's side), and mine is 20 feet in the air.  Antenna test looks like this, but I can watch it cycle on this screen and it drops to nothing with 3-4 second regularity:

 

 

Here are the values reported on the "Status" tab of Pharos:

Signal Strength: -51/-51dBm

Noise Strength: -106dBm

SNR: 59dB

Transmit CCQ: 100

Again, this cycles, so this is what I see when it (re)connects, then it drops back:

 

So it does connect to the AP SSID (yes, it is named differently than the neighbor's SSID), but I do note the TX Rate and RX Rate are lousy even for those moments when it does connect.

 

As far as possible interference: it's rather unlikely there's interference of the kinds that @R1D2 mentions, although on our end, we did have a DECT phone in use far from the antenna that I have unplugged, but that made no difference.  The AP antenna is in the neighbor's garage and I don't see any electrical equipment in it or nearby that are likely culprits.

 

I'll try playing with the POE (can you really use the antenna directly plugged into Ethernet without going through a POE adapter?  I'll try it) and let you know the results.

 

Thanks again for your help!

 

Kirk

 

 

0
0
#6
Options
Re:Two CPE210s can't connect well-Solution
2020-08-12 14:28:44 - last edited 2020-08-13 16:19:00

Hi Kirk,

 

you're welcome.

 

Some remarks:

 

88inall wrote

The AP antenna is unfortunately only 7 feet off the ground (that's what I can get on the neighbor's side), and mine is 20 feet in the air.

[...]

The AP antenna is in the neighbor's garage

 

Ehm, in the garage?

 

If it's really in the garage, this might be the cause for signal flapping.

 

7 feet is ~2m, 20 feet is ~7m, right? There is nothing wrong to mount CPEs at different heights as long as you tilt them accordingly.

 

However, the most important point for a reliable directional link even over 100m is a fresnel zone clearance of at least 40%, better 20%.

No tree, no wall, no car, no metal structure allowed inside the fresnel zone. Even no rain nor snow, but this is hard to achieve, so expect a drop of the signal by ~3dBm when it's raining or snowing. The remaining signal attenuation is caused by the air.

 

Here you have the interfences: the direct wave (path senderAreceiverB) being reflected from an obstacle inside the 2nd fresnel zone to the receiver (path CB):

 

 

 

Imagine the EM wave chaos if one CPE is inside a building or a garage and direct waves get reflected multiple times.

 

I'll try playing with the POE (can you really use the antenna directly plugged into Ethernet without going through a POE adapter?

 

No, this does not work. The CPE needs power; it's not just an antenna, but contains a lot of active components, too.

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
Recommended Solution
1
1
#7
Options
Re:Two CPE210s can't connect well
2020-08-12 14:44:13

@R1D2 The antenna is just over 2m elevation, outside the garage, not inside the garage.  The radius of the first Fresnel zone appears to be 1.76m, which appears to be completely clear as the elevation of the LoS elevates from his outside garage wall up to our antenna (approx. 7m high).  I guess if that geometry isn't correct, there's really nothing I can do to correct it in this particular situation.  I probably don't fully understand how this works, but what seems strange is that my client CPE is able to establish a ~20Mbps link to his regular WiFi router, which is inside his house, and it can do so without cycling like I see between the two antennae (this works until he parks a car outside his house and blocks our access). I guess the method of transmission just functions differently that way?

 

I may have misunderstood your comment: "Or maybe the PowerLAN adapters are defective and cause a cross-talk on the cable. Just try to connect the CPEs wirelessly w/o connection to the PowerLAN adapters, but on your site connected to your laptop directly."  I'm not certain how to connect CPEs wirelessly w/o connection to the PowerLAN adapters if that's how the anntenae get power?

 

It's sounding like there's not much more within my control I can do to get a more robust connection, but if anything else occurs, please do let me know.  We have to limp by on this until Comcast can manage to extend their plant to our telephone pole!

Kirk

 

 

0
0
#8
Options
Re:Two CPE210s can't connect well
2020-08-12 15:08:21 - last edited 2020-08-12 15:38:35

@88inall,

 

Imagine two water hoses. One of them has a 360º shower at the end and the other one has a thin spotlight at the end. With the same water pressure, the spotlight reaches further than the shower, while the shower supplies everything all around with water, right?

 

The 360º shower is the WiFi router, the spotlight is the CPE.

 

Now, the CPE's strong signal can be received by the WiFi router, but its receiver sensitivity is very poor. Interferences happen, sometimes also overriding the radio caused by the strong signal.

 

In the other direction, the WiFi router's weak signal can be received by the CPE because its receiver sensitivity is very high.

 

So, yes, this are two different methods for communication (directional vs. omnidirectional). However, as you wrote, this does not work reliably either. It would work a bit better if the WiFi router is mounted outdoors (and the direct line has fresnel zone clearance), but then it works only on a very limited range.

 

Regarding PowerLAN (or also called Powerline after a vendor who produces PowerLAN devices): you did mention it in post #3 »power line extender device«. Do you mean the PoE injector which comes as a power supply with the CPE or do you mean a PowerLAN device connecting the CPE's/PoE's LAN port over mains power with the LAN port of a router standing elsewhere?

 


 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
0
0
#9
Options
Re:Two CPE210s can't connect well
2020-08-13 16:18:53

 

R1D2 wrote

Regarding PowerLAN (or also called Powerline after a vendor who produces PowerLAN devices): you did mention it in post #3 »power line extender device«. Do you mean the PoE injector which comes as a power supply with the CPE or do you mean a PowerLAN device connecting the CPE's/PoE's LAN port over mains power with the LAN port of a router standing elsewhere?

 

@R1D2 Ah, I understand.  I thought you were talking about trying it without POE connection, but I see what you mean.  I do believe the powerline network device could be part of the interference, and I'll see what I can do at my neighbor's location to reconfigure without it.  Thanks for your help!

Kirk

0
0
#10
Options
Re:Two CPE210s can't connect well-Solution
2020-08-13 16:41:07 - last edited 2020-08-13 17:22:11

@88inall, you're welcome.

 

I suggest to set up the two CPEs in your home. Just reset the CPEs to factory defaults, place them a few meters apart, align them to each other, connect to the CPEs by cable with a laptop (change the laptop IP to 192.168.0.10 for initial setup, change the CPE's IP according to your needs, remember ro change the laptop's IP later on, log into he CPE's web UI again, save settings on the CPE). Don't change anything from the default your'e not 100% sure with.

 

CPE #1: AP mode

CPE #2: Client mode

 

It doesn't matter which CPE is running in AP or Client mode.

 

  • MAXtream: off
  • WiFi mode: 802.11n only
  • Channel: Auto (or select one according to the 1-6-11 scheme).
  • Channel width: 20 MHz
  • Security settings: WPA2/AES, encryption key
  • Distance: Auto (or real distance + 0.1km)

 

On the client perform a WiFi survey, select the CPE in AP mode, click »Lock to AP«, remember to »Apply« and »Save«.

Once the CPEs are linked wirelessly, you can access both CPE's web UIs without having to change the cable connection.

 

Now you can run a test to determine the wireless throughput using the built-in iperf test from the Tools menu.

Start one test on CPE #2 as the server, the other on CPE #1 as the client.

Play with antenna alignment to find the best signal quality and measure throughput again.

 

If this works, deploy them at the final position. Connect the CPE to the PoE adapter, but not to the network/PowerLAN. Connect a laptop to the LAN port of the PoE injector and test whether antennas are properly aligned. Adjust if necessary. The CPE's Antenna Alignment tool is most helpful for this task.

 

Then connect one part after another (PowerLAN, test again, switch, test again, router, test again).

 

Always test IP connectivity with ping. Don't even try to surf the web unless you checked IP connectivity, DHCP gateway/DNS server settings, routing and domain name resolution (commands ping, traceroute, nslookup or host).

 

Finally, test at the client side. It should work now much like it did when you had been setting it up in the office.

 

༺ 0100 1101 0010 10ཏ1 0010 0110 1010 1110 ༻
Recommended Solution
2
2
#11
Options