"Failed to adopt this gateway because a gateway already exists in this site" adopting router

"Failed to adopt this gateway because a gateway already exists in this site" adopting router

"Failed to adopt this gateway because a gateway already exists in this site" adopting router
"Failed to adopt this gateway because a gateway already exists in this site" adopting router
2022-06-08 00:43:41 - last edited 2022-06-09 01:01:27
Model: OC200  
Hardware Version: V1
Firmware Version: 1.15.2 Build 20220323 Rel.60717

I have an existing Omada site configured on one site. This site has the OC200 and the router whcih is an ER605. I am trying to add another ER605 from a remote site. I am able to get the device to show in the Omada devices list with a "Pending" status. When I try to adopt it, I get a message, "Failed to adopt this gateway because a gateway already exists in this site." 

 

I am forwarding the proper ports to my OC200 located in the first site. That is how the OC200 is able to see the remote router with a Pending status once I've set that router's Controller setting to the first site's public IP address. Everything looks right on the second router Controller Settings screen. The Connection Status shows as Online.

 

I tried setting the IP address range of the second site to a different range initially. Thinking this was a problem, I reset it to use the default of 192.168.0.0/24. The issue persisted. i tried going through threads showing similar issues, but I have not seen anything that actually addresses this problem. This seems pretty straightforward so not sure why I am getting this error. I have not seen anything that states I can't have more than two routers managed by a single controller. In fact, upon reading the site-to-site VPN documentation, it refers to two routers managed by the same controller.

  0      
  0      
#1
Options
1 Accepted Solution
Re:"Failed to adopt this gateway because a gateway already exists in this site" adopting router-Solution
2022-06-08 12:38:22 - last edited 2022-06-09 01:00:36

  @Fae Success! Thanks for the last suggestion and you're overall guidance. I had to open up the ports you noted. I retried adopting, but I got an authentication error. I went into the site manager and re-input the username and password under the Device Account setting of the new site (even though that has not changed). I retry once more, this time, I got a pop-up to enter the credentials of the device. I entered the credentials and this time adoption was successful.

 

To recap for others who don't RTFM like me smiley and may run into this issue:

 

  • Ignore the "Connection Status" under Controller Settings of the router that is being added. It's not relevant since an OC200 controller is being used.
  • Ensure that a new site is created for the new router. Choose this site when adopting the new router in the Omada web frontend.
  • Open additional ports UDP29810, TCP29814 and TCP443 are also open to the OC200 (see https://community.tp-link.com/en/business/kb/detail/362 for reference) For simplicity, open up ports 29810-29814 (All protocol), TCP 443 to the OC200

 

 

Recommended Solution
  2  
  2  
#6
Options
5 Reply
Re:"Failed to adopt this gateway because a gateway already exists in this site" adopting router
2022-06-08 02:01:10

  @t3knoid 

a gateway a site. 

you have another gateway? put it to another site. 

  2  
  2  
#2
Options
Re:"Failed to adopt this gateway because a gateway already exists in this site" adopting router
2022-06-08 02:20:22

Dear @t3knoid,

 

t3knoid wrote

I have an existing Omada site configured on one site. This site has the OC200 and the router whcih is an ER605. I am trying to add another ER605 from a remote site. I am able to get the device to show in the Omada devices list with a "Pending" status. When I try to adopt it, I get a message, "Failed to adopt this gateway because a gateway already exists in this site." 

 

I am forwarding the proper ports to my OC200 located in the first site. That is how the OC200 is able to see the remote router with a Pending status once I've set that router's Controller setting to the first site's public IP address. Everything looks right on the second router Controller Settings screen. The Connection Status shows as Online.

 

I tried setting the IP address range of the second site to a different range initially. Thinking this was a problem, I reset it to use the default of 192.168.0.0/24. The issue persisted.

 

From the error message that "Failed to adopt this gateway because a gateway already exists in this site.", it seems that you are trying to adopt the second ER605 in the same site with the first one.

 

In fact, one single Omada Controller can manage two or more Omada Routers, but just ensure they are on different sites.

For your case, you may add a new site and ensure you are in the new site to adopt the second ER605.

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  2  
  2  
#3
Options
Re:"Failed to adopt this gateway because a gateway already exists in this site" adopting router
2022-06-08 03:20:19
Thanks for that Fae. That is the one step I neglected to do. I created a new site. I've gotten a little further, but still have not successfully adopted. I tried adopting the router using the discovery utility from the same network where the new router is located. The Discovery utility showed success. In fact, when I open the web front end of the second site, it shows as being "Note: This Gateway is being managed by Omada Controller 192.168.0.101." This is odd because this is the IP address of where I ran the Discovery utility. However, when I go into the Omada website, it still shows the router as "Pending." If I try to adopt, the UI sits there for a while with the status of "ADOPTING." Finally, an error will show "Device adoption failed because the device does not respond to adopt commands." I then go back to the second router web UI, the Controller setting Connection Status has been set to Disabled. I re-enable it. And this time, I retry to adopt from the Omada web front end. Again, it sits for a while with the "ADOPTING" status. Finally, it comes back with an error "Device adoption failed because the device does not respond to adopt commands."
  0  
  0  
#4
Options
Re:"Failed to adopt this gateway because a gateway already exists in this site" adopting router
2022-06-08 06:49:55

Dear @t3knoid,

 

t3knoid wrote

I then go back to the second router web UI, the Controller setting Connection Status has been set to Disabled. I re-enable it. And this time, I retry to adopt from the Omada web front end. Again, it sits for a while with the "ADOPTING" status. Finally, it comes back with an error "Device adoption failed because the device does not respond to adopt commands."

 

The Connection Status under Controller Settings is for Cloud-Based Controller Management, you can ignore this part since you are using the OC200 instead of the Omada Cloud-Based Controller (it's purely on the cloud). Besides, whether it's disabled or enabled doesn't make sense for your case.

 

 

From your description, it seems that the second router is showing up as "Pending" on the new site now.

To successfully adopt and manage the gateway, please ensure that the ports UDP29810, TCP29814 and TCP443 are also open to your OC200.

In addition, you may retry the adoption, input the login username and password of the router you created for web UI to adopt the second router.

 

Related articles for your reference.

Which ports do Omada Controller and EAP Discovery Utility use?

2022 TP-Link Wi-Fi 7 Product Launch Event | Watch the Replay at https://www.tp-link.com/us/wifi7/event/.
  0  
  0  
#5
Options
Re:"Failed to adopt this gateway because a gateway already exists in this site" adopting router-Solution
2022-06-08 12:38:22 - last edited 2022-06-09 01:00:36

  @Fae Success! Thanks for the last suggestion and you're overall guidance. I had to open up the ports you noted. I retried adopting, but I got an authentication error. I went into the site manager and re-input the username and password under the Device Account setting of the new site (even though that has not changed). I retry once more, this time, I got a pop-up to enter the credentials of the device. I entered the credentials and this time adoption was successful.

 

To recap for others who don't RTFM like me smiley and may run into this issue:

 

  • Ignore the "Connection Status" under Controller Settings of the router that is being added. It's not relevant since an OC200 controller is being used.
  • Ensure that a new site is created for the new router. Choose this site when adopting the new router in the Omada web frontend.
  • Open additional ports UDP29810, TCP29814 and TCP443 are also open to the OC200 (see https://community.tp-link.com/en/business/kb/detail/362 for reference) For simplicity, open up ports 29810-29814 (All protocol), TCP 443 to the OC200

 

 

Recommended Solution
  2  
  2  
#6
Options