ER605 DHCP doesn't work out of the box

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

ER605 DHCP doesn't work out of the box

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
ER605 DHCP doesn't work out of the box
ER605 DHCP doesn't work out of the box
2022-11-28 11:37:51 - last edited 2023-02-24 02:16:11
Model: ER605 (TL-R605)  
Hardware Version: V1
Firmware Version: 1.2.1 Build 20220512 Rel.76748

DHCP doesn't work on this device. I've tried upgrading to the latest software and it still doesn't work.  My unifi wifi controller can't assign devices to the network since DHCP doesn't work. When I try going to the DHCP list I just get a turning circle indefinitely.

 

It seems amazing that someone would be successfully selling equipment of such poor quality.  Is there a firmware version or some other fix that anyone knows of?

 

 

 

  2      
  2      
#1
Options
1 Accepted Solution
Re:ER605 DHCP doesn't work out of the box-Solution
2023-02-24 02:16:06 - last edited 2023-02-24 02:16:11

Dear @dsj@berridge and other community members,

 

I'd like to update the post with a solution here.

 

TP-Link has updated the firmware to fix the DHCP issues, please follow the solution post below for details.

Solution to DHCP Issues of Routers (ER605 | ER7206 | ER8411 | ER7212PC) [Updated on Feb 21st 2023]

 

You may take your time to upgrade the new firmware and confirm the DHCP issue you encountered has been resolved.

>> Omada EAP Firmware Trial Available Here << *Try filtering posts on each forum by Label of [Early Access]*
Recommended Solution
  0  
  0  
#9
Options
8 Reply
Re:ER605 DHCP doesn't work out of the box
2022-11-28 22:03:14

  @berridge 

 

Are you sure you have a hardware version v1?

 

for the v2 Hardwareversion you can have here the beta 2 https://community.tp-link.com/en/business/forum/topic/587702

 

 

  0  
  0  
#2
Options
Re:ER605 DHCP doesn't work out of the box
2022-11-29 00:17:00

  @nurix 

Yes, here's why I think it is V1:

  0  
  0  
#3
Options
Re:ER605 DHCP doesn't work out of the box
2022-11-30 05:51:08
Just striving to develop myself while helping others.
  0  
  0  
#4
Options
Re:ER605 DHCP doesn't work out of the box
2022-11-30 17:06:28

  @Virgo Thanks for this.  I did find this subsequently. 

 

I tried all 3 firmware versions and settled on 1.1.1. 

DHCP seems to have started working but there's still no way to access the DHCP list, I just get the wheel of frustration.

I've ordered a replacement Netgear alternative and will be returning this one.  Seems like TP Link is to networking equipment what GE is to washers.  Good luck...

  0  
  0  
#5
Options
Re:ER605 DHCP doesn't work out of the box
2022-11-30 20:39:14

  @berridge 

 

1.

maybe, you have in your network two devices with same ip? 
did you have assigned for any device a static ip in there configurations menu?

unplug the access points and restart your router an have a look in the dhcp menu


 

2.

Do you have an unifi Hardware controller or do you have installed the software controller?

when it's a software controller than look at the computer firewall if the controller can scan your network.

 

3.

try to reset the unifi Access Points (15sec reset button) 

 

4.
when the access points are assigned to another controller than you have to remove it before you can add to another

 

 

  0  
  0  
#6
Options
Re:ER605 DHCP doesn't work out of the box
2022-12-01 00:01:03

  @nurix 

Thanks, I investigated further and found that somehow the unifi wifi controller was also possibly operating as a DHCP server.  But I was still unable to get to the DHCP list screen.  

Then, on a whim, I tried logging in in INCOGNITO mode.  And voila it worked.  I can't explain it but I'm posting it here in case it helps someone else.  Even after disabling all chrome extensions, something about regular mode in Chrome causes a problem with the DHCP page, and it will only work from incognito mode.

  0  
  0  
#7
Options
Re:ER605 DHCP doesn't work out of the box
2022-12-01 04:27:31

  @berridge I think you are running into this bug when you are using firmware 1.1. It was fixed in 1.2 per the release notes. Most posts I saw were being stuck on the login page but I wouldn't be surprised if it affected config pages too since they didn't specify in the release notes message.

2. Fix the bug that the web page refresh is prone to lag in Standalone mode.

 

Unfortunately, firmware 1.2.x have been plagued by DHCP issues and many on the forum are eagerly awaiting the next version and hoping for some relief.
I have been on 1.2.1 for a few months but am growing tired of resetting the WAN connection and rebooting the router to fix issues. I am very close to going back to 1.1 as well and just using incognito like you.

  0  
  0  
#8
Options
Re:ER605 DHCP doesn't work out of the box-Solution
2023-02-24 02:16:06 - last edited 2023-02-24 02:16:11

Dear @dsj@berridge and other community members,

 

I'd like to update the post with a solution here.

 

TP-Link has updated the firmware to fix the DHCP issues, please follow the solution post below for details.

Solution to DHCP Issues of Routers (ER605 | ER7206 | ER8411 | ER7212PC) [Updated on Feb 21st 2023]

 

You may take your time to upgrade the new firmware and confirm the DHCP issue you encountered has been resolved.

>> Omada EAP Firmware Trial Available Here << *Try filtering posts on each forum by Label of [Early Access]*
Recommended Solution
  0  
  0  
#9
Options

Information

Helpful: 2

Views: 573

Replies: 8

Related Articles