Cannot adopt mesh ap

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Cannot adopt mesh ap

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Cannot adopt mesh ap
Cannot adopt mesh ap
2023-12-09 22:19:18 - last edited 2023-12-25 09:37:45
Model: EAP225  
Hardware Version:
Firmware Version:

I'm struggling to adopt an eap 225 into my network.

 

Here's the setup:

Modem > OpenWRT router > Netgear managed switch 

Off of the switch I have the OC200 controller, and an Eap245 ap.

 

I have the network split into several vlans, which run from the router through the ap so I can have a different vlan for each ssid (home, guest, work etc).

 

The port on the switch the eap245 connects to is set to trunk(uplink)

 

All this works fine so far.

 

I've only just got my hands on the OC200 and an eap225 I want to add. The OC200 connects to another port on the switch, but I can only seem to connect to it when the port is set to vlan 10 (my home vlan), it seems to be able to communicate with the eap245 fine though.

 

However, when trying to add the eap225 as wireless mesh device, the controller can see it and it says pending, but when trying to adopt it it sits there for a while and then says failed. 

 

I've updated the firmware on all the devices to the latest version, but I'm not sure what else the problem could be. Firewall or vlan configuration perhaps?

 

  0      
  0      
#1
Options
1 Accepted Solution
Re:Cannot adopt mesh ap-Solution
2023-12-12 15:35:08 - last edited 2023-12-25 09:37:45

  @NetworkN00b 

 

If you can adopt it when the AP is connected directly to the OC200 and powered via a POE injector, then the switch config (VLAN) is the issue. By default the management VLAN is VLAN1 for Omada devices.  There are FAQs on how to change the management VLAN, but it's not trivial.

 

If you cannot, then it's likely a firmware issue, one of them is too old to play nice with the other.

<< Paying it forward, one juicy problem at a time... >>
Recommended Solution
  1  
  1  
#3
Options
3 Reply
Re:Cannot adopt mesh ap
2023-12-12 09:05:54

Hello @NetworkN00b,

 

May I know the hardware and firmware versions of your EAP225 and the OC200?

Could you change the Root AP channel to Band1 like 36/5180MHz for testing?

 

However, when trying to add the eap225 as wireless mesh device, the controller can see it and it says pending, but when trying to adopt it it sits there for a while and then says failed.

 

What is the error message when it says failed?

Best Regards! >> Omada EAP Firmware Trial Available Here << >> Get the Latest Omada SDN Controller Releases Here << *Try filtering posts on each forum by Label of [Early Access]*
  0  
  0  
#2
Options
Re:Cannot adopt mesh ap-Solution
2023-12-12 15:35:08 - last edited 2023-12-25 09:37:45

  @NetworkN00b 

 

If you can adopt it when the AP is connected directly to the OC200 and powered via a POE injector, then the switch config (VLAN) is the issue. By default the management VLAN is VLAN1 for Omada devices.  There are FAQs on how to change the management VLAN, but it's not trivial.

 

If you cannot, then it's likely a firmware issue, one of them is too old to play nice with the other.

<< Paying it forward, one juicy problem at a time... >>
Recommended Solution
  1  
  1  
#3
Options
Re:Cannot adopt mesh ap
2023-12-12 16:23:54

  @d0ugmac1 

 

Thanks that makes sense. Sounds like I need to adjust the VLAN settings. There is a more advanced configuration option on the switch where I can control each of the vlan ids allowed on each port, so I'll have a play with that

 

  0  
  0  
#4
Options

Information

Helpful: 0

Views: 237

Replies: 3

Related Articles