Internet down after upgrading ER707-M2 (v1) to version 1.2.0

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12

Internet down after upgrading ER707-M2 (v1) to version 1.2.0

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Internet down after upgrading ER707-M2 (v1) to version 1.2.0
Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-08 18:00:38 - last edited 2024-01-12 07:17:01
Model: ER707-M2  
Hardware Version: V1
Firmware Version: 1.2.0

I am running the Software Controller on Linux, version 5.13.22.

 

After upgrading my ER707-M2 v1 router from version 1.0.2 to version 1.2.0 I am no longer able to reach the internet.

 

From any device within my network I can ping any other LAN IP address, but I am unable to ping the Gateway / WAN address of my ISP modem. Any device I connect to the ISP modem directly is having no issues.

 

So to me, it looks like there is something wrong with the internal routing table or something? Downgrading back to 1.1.1, 1.02, or any of the beta versions does not resolve the issue.

 

See screenshot:

 

 

I found another topic with a similar issue where the person ended up removing all VPN profiles. I did that as well. Rebooted the controller, rebooted every device, rebooted the ISP modem,... Nothing.

 

Any ideas or other suggestions would be very great. Thanks!

  0      
  0      
#1
Options
1 Accepted Solution
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0-Solution
2024-01-12 07:16:58 - last edited 2024-01-12 07:17:01

Anyone who's reading this,

This issue should be resolved by the firmware update released.

ER707-M2 V1_1.2.1 Build 20240109 Official Firmware (Released on Jan 11th, 2024)

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
Recommended Solution
  1  
  1  
#12
Options
12 Reply
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-08 18:21:25

  @Matva 

 

that person was me smiley 

 

not exact same, my roter go completly offline and disconnected from controller, but contoller was on a remote site so WAN interface problaly go down, no internett at all.

but i think this is a case for @Clive_A to looka at this, I have resolved this but I dont know whats the problem is.. 

 

 

 

 

  1  
  1  
#2
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-08 18:52:20 - last edited 2024-01-08 20:30:12

I also tried configuring another port as WAN port but that didn't fixed. Even put the ISP modem in Bridged mode so I get the WAN IP directly but again, same issue. Can't ping past the WAN IP. There are no ACLs active, nor is IDS/IPS.

 

Edit: Ok, since I was dealing with the family breathing down my neck for not having Netflix I went ahead and factory reset the Router and re-adopted it. This fixed the issue. But it makes me nervous of doing upgrades again though.

  0  
  0  
#3
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 01:20:32

Hi @Matva 

Thanks for posting in our business forum.

Matva wrote

I am running the Software Controller on Linux, version 5.13.22.

 

After upgrading my ER707-M2 v1 router from version 1.0.2 to version 1.2.0 I am no longer able to reach the internet.

 

From any device within my network I can ping any other LAN IP address, but I am unable to ping the Gateway / WAN address of my ISP modem. Any device I connect to the ISP modem directly is having no issues.

 

So to me, it looks like there is something wrong with the internal routing table or something? Downgrading back to 1.1.1, 1.02, or any of the beta versions does not resolve the issue.

 

See screenshot:

 

 

I found another topic with a similar issue where the person ended up removing all VPN profiles. I did that as well. Rebooted the controller, rebooted every device, rebooted the ISP modem,... Nothing.

 

Any ideas or other suggestions would be very great. Thanks!

 

1. The issue is not the same as the @MR.S . It is not the same and has nothing in common at all.

2. What you pinged is the IP address of the gateway of your router on the WAN, which is a double-NAT scenario.

Let me ask you this, can you ping this IP address 192.168.0.1 in the past?

What is the result if you ping 8.8.8.8 or 1.1.1.1 at this time stamp? It is ping-able, right? Your WAN status is Online which means it gets Internet. This contradicts what you said.

This explains how the Online status works. Common Questions About the Load Balancing & Link Backup(Failover)

 

3. Downgrading to any previous firmware does not resolve this issue, so it seems to be the case where your first NAT issue. Nothing to do with the Omada router.

Like the comment in 2.

 

4. In your last reply, you mean after resetting the router, you can ping the IP address of 192.168.0.1 or your actual public IP now?

 

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#4
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 06:48:09

  @Clive_A 

 

Thanks for checking. I do not believe it to be a NAT issue. As mentioned, when I put my ISP modem in Bridge mode I get a public IP address directly on my ER707. Furthermore, this has always worked before the upgrade. I was able to ping the router on both LAN and WAN interface, as well as any public IP (1.1.1.1, 8.8.8.8,...) It is only after upgrading the ER707 to version 1.2.0 that these issues started occurring. No settings were changed prior to, or after, the upgrade.

 

By resetting the router and re-adopting it, the issue is now resolved. Again without changing any settings on the controller or ISP Modem.

 

Which does lead me to believe that *some* (hidden) setting was changed on the router during the upgrade (NAT, Routing,...?). Inter-VLAN routing kept working fine during the issue. All static routes to all VLANS were indeed present in the routing table.

 

I just checked the routing table and noticed something interesting: Yesterday, during the issue, I only had static routes for all VLANS. Now, I suddenly have additional static routes towards the internet with entry 0.0.0.0/0 pointing to the next-hop, being my ISP gateway IP.

 

So this seems to confirm that the upgrade to 1.2.0 messed up the internal routing tables somehow, clearing the static default route towards internet.

  0  
  0  
#5
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 06:53:50

Hi @Matva 

Thanks for posting in our business forum.

Matva wrote

  @Clive_A 

 

Thanks for checking. I do not believe it to be a NAT issue. As mentioned, when I put my ISP modem in Bridge mode I get a public IP address directly on my ER707. Furthermore, this has always worked before the upgrade. I was able to ping the router on both LAN and WAN interface, as well as any public IP (1.1.1.1, 8.8.8.8,...) It is only after upgrading the ER707 to version 1.2.0 that these issues started occurring. No settings were changed prior to, or after, the upgrade.

 

By resetting the router and re-adopting it, the issue is now resolved. Again without changing any settings on the controller or ISP Modem.

 

Which does lead me to believe that *some* (hidden) setting was changed on the router during the upgrade (NAT, Routing,...?). Inter-VLAN routing kept working fine during the issue. All static routes to all VLANS were indeed present in the routing table.

 

I just checked the routing table and noticed something interesting: Yesterday, during the issue, I only had static routes for all VLANS. Now, I suddenly have additional static routes towards the internet with entry 0.0.0.0/0 pointing to the next-hop, being my ISP gateway IP.

 

So this seems to confirm that the upgrade to 1.2.0 messed up the internal routing tables somehow, clearing the static default route towards internet.

Can you export your backup for me? Let me know if you agree to share your backup or not.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#6
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 07:32:35

  @Clive_A 

 

I can do that. Do you need the autobackup .cfg files or Export For Support logs?

  0  
  0  
#7
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 09:05:38

Hi @Matva 

Matva wrote

  @Clive_A 

 

I can do that. Do you need the autobackup .cfg files or Export For Support logs?

Thank you so much for taking the time to post the issue on TP-Link community!

To better assist you, I've created a support ticket via your registered email address, and escalated it to our support engineer to look into the issue. The ticket ID is TKID240116513, please check your email box and ensure the support email is well received. Thanks!

Once the issue is addressed or resolved, welcome to update this topic thread with your solution to help others who may encounter the same issue as you did.

Many thanks for your great cooperation and patience!

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#8
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 09:22:41

  @Clive_A 

 

Thank you. E-mail well received. I have sent the current backup via e-mail.

 

Please note that everything is currently fully operational for me again. If needed, I can also provide a backup from before the upgrade to 1.2.0.

  0  
  0  
#9
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 09:57:23

Hi @Matva 

Thanks for posting in our business forum.

Matva wrote

  @Clive_A 

 

Thank you. E-mail well received. I have sent the current backup via e-mail.

 

Please note that everything is currently fully operational for me again. If needed, I can also provide a backup from before the upgrade to 1.2.0.

Is everything the same just different firmware? I may downgrade to the previous firmware and adopt then upgrade.

If something's different, please resend the backup to me. I'll check again. If possible, provide the non-support and support version at the same time. Thanks.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  0  
  0  
#10
Options
Re:Internet down after upgrading ER707-M2 (v1) to version 1.2.0
2024-01-09 10:02:12

  @Clive_A 

 

Some settings have changed in the meantime now that everything is stable again.

When I'm able to, I'll grab the backup of 2 days ago and send that one as well. (However I won't be able to get the support version I guess?)

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 1052

Replies: 12

Related Articles