EAP 245 Can't update firmware

EAP 245 Can't update firmware

EAP 245 Can't update firmware
EAP 245 Can't update firmware
2024-05-05 15:51:49
Model: EAP245  
Hardware Version: V3
Firmware Version: 5.0.1 Build 20210113 Rel. 63140(4a50)

*Posting this info in the hope that it helps others*

 

I have 2x TP-Link EAP245 Ver. 3 with firmware [5.0.1 Build 20210113 Rel. 63140(4a50)]

 

Whenever I attempted to update the firmware, I got the message "Bad file" or "Failed to check for new update".

 

Reading other posts on here/the web, I tried the UK (EU), US and CA firmware downloads, but get the same messages.

 

After a few days of banging my head against a virtual brick wall, I was finally able to identify the issue:

 

Although my hardware stated (EU) region, and all material (including the box) was all in English language. A small sticker on the retail/external packaging/box, stated "support.jp@tp-link.com" - identifying the unit as "Region = Japan", although everything was in English, I tried, and successfully updated both of my EAP245 v3 with firmware [EAP245(JP)_V3_5.0.5 Build 20220323]

 

Upon inspection of the JP firmware site for V3, I also found the matching [5.0.1 Build 20210113 Rel. 63140(4a50)]

 

Link to the JP firmware download page (use Google Translate to translate the entire page): https://www.tp-link.com/jp/support/download/eap245/v3/#Firmware

 

Thought I'd share this in the hope that'll help others

  1      
  1      
#1
Options
1 Reply
Re:EAP 245 Can't update firmware
2024-06-19 07:52:12 - last edited 2024-06-19 07:54:30

  @Park1nsR 

I appreciate your sharing. It is crucial for us to understand that we should obtain the correct firmware for your TP-Link equipment from the official local website of the place of purchase. If not, the upgrade would not succeed or would possibly harm the device.

 

Best Regards! >> Omada EAP Firmware Trial Available Here << >> Get the Latest Omada SDN Controller Releases Here << *Try filtering posts on each forum by Label of [Early Access]*
  0  
  0  
#2
Options

Information

Helpful: 1

Views: 172

Replies: 1

Related Articles