ER605 Port Forwarding will not work under Omada Software Controller

ER605 Port Forwarding will not work under Omada Software Controller

ER605 Port Forwarding will not work under Omada Software Controller
ER605 Port Forwarding will not work under Omada Software Controller
2024-06-12 05:17:40 - last edited 3 weeks ago
Tags: #NAT
Model: ER605 (TL-R605)  
Hardware Version: V1
Firmware Version: 1.3.1

This is a continuation of my previous thread, as seen here:

https://community.tp-link.com/en/business/forum/topic/622434?replyId=1254500

 

Some personal issues that meant I had just lived with this not working, but I am now back to trying to solve the issue.

 

The Router works perfectly in standalone mode only.

As soon as it is adopted, I am unable to open any ports.

 

I have confirmed the server in question does not change IPs when the router is adopted, the server has been manually configured to take the ip 192.168.0.30 and not to use DHCP.

 

I have since updated my controller to the latest software (v5.13.30.8) with no change in the situation.

Multiple factory resets of the router have been tried.

I have tried opening ports to other machines on the network, which again works perfectly in standalone mode but fails utterly post adoption.

 

I have also noted that when adopted despite configuring it the router also fails to update its No-ip DDNS, while this works perfectly in standalone. From this I suspect that the controller is somehow failing communicate the settings to the router, but that's just a conjecture.

 

All the issues are reproducable 100% of the time on my network, I can restore everything to full functionality simply by having the router in standalone mode and it will all fail every time as soon as the router is adopted. Happy to provide any screenshots or logs that could help diagnose these issues.

 

Please help.

 

All the best,

Tom

  0      
  0      
#1
Options
1 Accepted Solution
Re:ER605 Port Forwarding will not work under Omada Software Controller-Solution
3 weeks ago - last edited 3 weeks ago

Hi @Clive_A (and others),

 

Further update, I have uninstalled and reinstalled the cloud controller, following the same procedure as I have done previously.

Currently, things appear to now be working.

 

I will keep an eye on this and see if anything goes sizeways, but for the moment this seems to have resolved the issue. I'm not sure what about this particular delete and reinstall made any differences over the last two, but I will remain thankful as long as it remains functioning.

 

If I don't come back, please take my thanks, and if I do return we can pick things up then!

Recommended Solution
  1  
  1  
#6
Options
13 Reply
Re:ER605 Port Forwarding will not work under Omada Software Controller
2024-06-12 05:27:48

Hoping I can tag @Clive_A who was helping me out with this before, I apologise for letting it lie for so long.

 

While the system works in standalone mode, it does defeat the entire point of having invested in an Omada system to centrally manage my devices.

  0  
  0  
#2
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
2024-06-13 01:15:52

Hi @Tyra 

Thanks for posting in our business forum.

Have you tried a clean uninstallation and reinstallation without the old configuration?

Fresh site to adopt the device and test it?

What's the WAN IP address?

Application result after you configured port forwarding.

 

Virtual Services(Port Forwarding) on the Router Doesn't Take Effect

I need screenshots of every step you perform by following this guidance.

 

In the last conversation, you should not use a local DNS on the WAN configuration. That's absolutely incorrect and that might be the reason why you fail to update the DDNS.

 

Please mosaic your sensitive information. Here is a list of information considered sensitive:

1. Public IP address on your WAN if your WAN is.

2. Real MAC address of your device.

3. Your personal information including address, domain name, and credentials.

For troubleshooting purposes, when a WAN IP is needed, please leave some values visible for identification.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  1  
  1  
#3
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

  @Tyra i've seen similar problems and ended up with same compromise - er605 in standalone mode. I've also found the controller regularly loses "management" of er605 - says pending or adopting but never does. Again i have largely given up.  

  0  
  0  
#4
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

Hi  @Clive_A, thank you for picking this up again with me, I appreciate it!

 

I will do another clean refresh now, but while I do here are some results with the current setup:

 

No matter which machine on my network I try to port forward to, there is no result from outside the network. I can connect perfectly inside the network but nothing comes through from outside, this is the case even if I put a machine in the DMZ.

 

The routers WAN window shows as follows:

The local DNS points to a PiHole instance, but there is no change when I switch it to 8.8.8.8 (other than a lot more adverts on the internet) and it works in this configuration when in standalone mode.

 

I'm now going to try deleting the software controller and reinstalling from scratch. Lets see if that gets us anywhere.

  0  
  0  
#5
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller-Solution
3 weeks ago - last edited 3 weeks ago

Hi @Clive_A (and others),

 

Further update, I have uninstalled and reinstalled the cloud controller, following the same procedure as I have done previously.

Currently, things appear to now be working.

 

I will keep an eye on this and see if anything goes sizeways, but for the moment this seems to have resolved the issue. I'm not sure what about this particular delete and reinstall made any differences over the last two, but I will remain thankful as long as it remains functioning.

 

If I don't come back, please take my thanks, and if I do return we can pick things up then!

Recommended Solution
  1  
  1  
#6
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

Hi  @Tyra 

Tyra wrote

Hi @Clive_A (and others),

 

Further update, I have uninstalled and reinstalled the cloud controller, following the same procedure as I have done previously.

Currently, things appear to now be working.

 

I will keep an eye on this and see if anything goes sizeways, but for the moment this seems to have resolved the issue. I'm not sure what about this particular delete and reinstall made any differences over the last two, but I will remain thankful as long as it remains functioning.

 

If I don't come back, please take my thanks, and if I do return we can pick things up then!

Noted. I assume that previously something corrupted the config or the files. A clean reinstallation now seems to fix it. Good to know.

I will keep an eye on your case if you reply and @ me.

 

BTW, your WAN DNS should not be a private IP. That does not work at all due to NAT. Should set up the DNS in the LAN settings, pointing the DNS queries to the local DNS server instead of doing so on WAN.

Best Regards! If you are new to the forum, please read: Howto - A Guide to Use Forum Effectively. Read Before You Post. Look for a model? Search your model NOW Official and Beta firmware. NEW features! Subscribe for the latest update!Download Beta Here☚ ☛ ★ Configuration Guide ★ ☚ ☛ ★ Knowledge Base ★ ☚ ☛ ★ Troubleshooting Manual ★ ☚ (Disclaimer: Short links are used above solely for guidance to TP-Link subdomains and are safe and tracker-free. Exercise caution with short links from non-official members on forums. We are not liable for external content or damage from non-official members' link use.)
  1  
  1  
#7
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

  @Clive_A 

Thanks for the note on the DNS, I didn't understand that and I'll sort that out!

So far things are still working so I think your supposition is very possibly correct!

 

I appreciate the support again, thank you for being here!

  1  
  1  
#8
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

  @Tyra @Clive_A 

 

What were the exact procedures for this fix?

 

I'm having the same issues with a Proxmox LXC containerised Software Controller, where no Firewall settings are working.

 

Was that a fresh install or a fresh install and restore of your current setup?

 

Regards

  0  
  0  
#9
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

  @ThePix 

Hi,

 

I did a complete delete and reinstall, and manually reconfigured everything from scratch.

 

Good luck resolving it.

  1  
  1  
#10
Options
Re:ER605 Port Forwarding will not work under Omada Software Controller
3 weeks ago

  @Tyra I have done the same, which seems to have resolved the port mapping issue. Time will show if it also has resolved the problem I had with the er605  periodically getting stuck in a pending state. 

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 383

Replies: 13

Tags

Related Articles