TL-WN823N Linux drivers don't compile in Ubuntu

TL-WN823N Linux drivers don't compile in Ubuntu
TL-WN823N Linux drivers don't compile in Ubuntu
2019-01-08 16:10:11 - last edited 2019-01-08 16:13:11

Hello

 

There are two Linux drivers on the TL-WN823N product page. My kernel is 4.15, but the beta driver is only recommended up to 4.9.60. The older driver is for kernel versions up to 3.10.10.

 

I am unable to unzip the older driver, and the beta driver gave this error when I ran the make command (see https://pastebin.com/pjMU1SAD):

 

~/rtl8192EU_WiFi_linux_v5.2.19.1_25633.20171222_COEX20171113-0047/include/osdep_service_linux.h:299:8: error: ‘_timer {aka struct timer_list}’ has no member named ‘data’

0
0
#1
Options
1 Reply
Re:TL-WN823N Linux drivers don't compile in Ubuntu
2019-01-09 01:56:10

The driver on the website is not compatible with your linux based on the kernel version.

 

If you want to try, https://www.tp-link.com/en/faq-1076.html

0
0
#2
Options