Archer VR900 wrong IP settings when connected via 2.4 GHz

Archer VR900 wrong IP settings when connected via 2.4 GHz
Archer VR900 wrong IP settings when connected via 2.4 GHz
2019-01-09 11:47:40 - last edited 2019-01-11 09:55:19

I have an Archer VR900 V3 connected to the LAN point in our office (which connects the buildings main router and internet Modem etc.). As such, I want the VR900 to act purely as a wireless access point - with all DHCP assignments etc. deferred to the office buildings main router. To achieve this I setup the box as follows:

 

- Connection Type: Dynamic IP

- Operating Mode: Wireless Access Point

- Network -> LAN Settings -> DHCP Disabled (uncheck the 'Enable' box).

 

The rest of the settings are the factory defaults - FW version is 170303 Rel. 59897n

 

When I connect via LAN or 5GHz Wifi everything works as expected. My devices obtain a valid IP address and are able to access the internet. An example of these IP settings are:

 

   IPv4 Address. . . . . . . . . . . : 192.168.1.102(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 09 January 2019 11:23:56
   Lease Expires . . . . . . . . . . : 10 January 2019 10:57:06
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 192.168.1.1

 

However, when I connect via the 2.4 GHz Wifi - the IP settings are incorrect and of course the device cannot acces the internet etc. Here are the IP settings obtained via 2.4 GHz:

 

   IPv4 Address. . . . . . . . . . . : 169.254.81.173(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . : 
   DNS Servers . . . . . . . . . . . : fec0:0.0.ffff::1%1

 

It seems like a bug in the FW that prevents correct IP settings being assigned when the device is configured as above.

 

Any suggestions for a workaround or fix?

0
0
#1
Options
1 Reply
Re:Archer VR900 wrong IP settings when connected via 2.4 GHz
2019-01-15 07:58:03

Hi,

 

Is there access point mode on VR900? I don't see it. 

 

All devices or just some cannot get valid IP address via 2.4GHz Wi-Fi?

 

This is strange in my opinion. You'd better contact tplink support for this one.

0
0
#2
Options