Firmware downgrade from 1.2.8 to 1.2.4

Firmware downgrade from 1.2.8 to 1.2.4
Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 06:24:05 - last edited 2019-06-14 06:37:19
Model: Deco M5
Hardware Version: V2
Firmware Version: 1.2.8

Hey ya'll,

I am having many issues after latest FW upgrade (1.2.8) that I related in this post

tl;dr: Some of my devices unable to connect to the network: "No internet connection", some of them are required to re-enter password but it won't work.

 

Rebooting the main deco will solve it for the next few hours, but all of these issues came like a few days ago.

 

I want to downgrade the firmware version of both my decos to 1.2.4 as I had when I bought it.

TP-Link is offering the FW version to download but I couldn't find instructions on how to manually install older FW..

 

Hopefully I will find my answer here.

 

Thanks!

0
0
#1
Options
1 Accepted Solution
Re:Re:Re:Firmware downgrade from 1.2.8 to 1.2.4-Solution
2019-06-14 06:37:12 - last edited 2019-06-14 06:37:19

@Splee

Kevin has sent me the latest beta version of 1.3.0, After running it for about 2-3 days I can confirm that the issues of the connection drop outs and the "incorrect password" crap has been resolved.

 

I'd recommend moving to 1.3.0 for now as I did not encounter any problems using this firmware version.

 

To anyone who is doing a firmware installation, here's an important note for you:

When you click the upgrade button, there will be a spinner for about 2-3 minutes before you see ANY indication by the program so don't think it's stuck like I did

 

To me, version 1.3.0 has resolved the terrible 1.2.8 so I'll leave it here as the answer.

 

Thanks again to Kevin for his help!!

 

 

 

Splee wrote

Hi Kevin, 

 

I would like to downgrade from 1.2.8 to 1.2.4 as well.. please email me the instructions and tools and firmware to me.

 

I m suffer drop connection on 1.2.8.

 

Appreciate your help!

 

Best Solution
0
0
#46
Options
46 Replies
Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 06:41:39

Hi, I emailed you the instruction to downgrade the firmware manually, pplease check your inbox. 

 

Just let me know if need further help.

 

 

0
0
#2
Options
Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 06:52:15

Thank you Kevin,

 

Can you please upload the instructions over here in case people will search for it? because I saw some people in old posts try to but dont know how

0
0
#3
Options
Re:Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 07:02:10

Hi,

 

Appreciate your kindness; while we would love to verify the specific symptoms of each case first and then provide specific answer; as you know, sometimes, downgrade is not suitable or there is a better choice/solution; 

 

Meanwhile, if the downgrade is needed, we will email you customer the instruction personally to do so; 

 

Have a nice day. 

0
0
#4
Options
Re:Re:Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 19:30:58

Hi Kevin,

I'm having a hard time downgrading the decos.

On windows: It gives me the error when I run the upgrade_GDPR.exe: "NoValidConnectionsError: [Errno None] Unable to connect to port 22 on 192.168.68.103" (I'm sure this is the deco)

On my mac: When I enter all the fields in upgrade_gdpr program, the button does NOTHING...

 

Honestly, worst user experience while downgrading FW I've ever had :(

0
0
#5
Options
Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 21:25:37

I am experining the same problem, notably with any connected Apple products and my D-Link water sensor.

Very frustrating to have to reboot the system serval times a day.

Any help would be appreciated 

0
0
#6
Options
Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-10 22:44:07

Hi, just received today my 3 pieces P7 Deco system, installed all of them with some issues, after finishing and place each of them on a separate floor I started seeing them both slave units (my configuration is a Star one) disconnecting. One of the units is connected to the main one through Ethernet as backhaul, the other one is using the PowerLine adapter (I guess) or the Wi-Fi. How can I downgrade to see if the latest firmware is the problem or the system needs to be returned to Amazon?

0
0
#7
Options
Re:Re:Re:Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-11 06:37:37

Hi,

 

I confirmed with our engineer, there is another firmware available you can give it a go to fix the current problem, I have emailed you and then you can try to update it manually. 

 

Any updates, just let me know. 

 

Bar wrote

Hi Kevin,

I'm having a hard time downgrading the decos.

On windows: It gives me the error when I run the upgrade_GDPR.exe: "NoValidConnectionsError: [Errno None] Unable to connect to port 22 on 192.168.68.103" (I'm sure this is the deco)

On my mac: When I enter all the fields in upgrade_gdpr program, the button does NOTHING...

 

Honestly, worst user experience while downgrading FW I've ever had :(

 

0
0
#8
Options
Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-11 06:39:03

Hi,

 

What is the model number? Is it Deco M5? What is the current firmware version?

 

Please provide more details about the current problem and then we will give you a specific answer.

 

Thanks in advance, and have a nice day. 

 

Castle1999 wrote

I am experining the same problem, notably with any connected Apple products and my D-Link water sensor.

Very frustrating to have to reboot the system serval times a day.

Any help would be appreciated 

 

0
0
#9
Options
Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-11 06:49:57

Hi,

 

So the current network topology is modem--Main Deco --- 1st slave Deco

                                                                         )))(((/powerline -- 2nd slave Deco?

 

What is the current firmware version of the Deco units? 

 

And what is the light status of the Deco nodes when the connection drops out? Any error message on the Deco app? 

 

How far away between the Deco units? Especially the 2nd slave Deco and the main one. 

 

Did you try to exchange their location or position to do a comparison analysis? What happened then?

 

Besides, here is a guidance you can refer to locate the issue. https://www.tp-link.com/support/faq/1454/ 

 

Good day.

MihaiMihai wrote

Hi, just received today my 3 pieces P7 Deco system, installed all of them with some issues, after finishing and place each of them on a separate floor I started seeing them both slave units (my configuration is a Star one) disconnecting. One of the units is connected to the main one through Ethernet as backhaul, the other one is using the PowerLine adapter (I guess) or the Wi-Fi. How can I downgrade to see if the latest firmware is the problem or the system needs to be returned to Amazon?

 

0
0
#10
Options
Re:Re:Re:Firmware downgrade from 1.2.8 to 1.2.4
2019-06-11 06:56:39 - last edited 2019-06-11 06:57:27

-Yes 1 master 2 slaves (1 slave connected through powerline, one through ethernet)

-1.2.0 Build 30282320 Rel.34913 latest available yesterday when I installed all the units

- sometimes the led is blinking sometimes is not

-in the app it says the faulty deco is disconnected

- I didn't change the initial locations as I need them where I installed

0
0
#11
Options