Windows 10 warning Deco M5

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Windows 10 warning Deco M5

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Windows 10 warning Deco M5
Windows 10 warning Deco M5
2019-08-12 15:49:32 - last edited 2019-09-19 00:39:48
Model: Deco M5  
Hardware Version: V1
Firmware Version:

On Windows 10 1903 I get a warning "This Wifi network uses an older security standard. We recommend connecting to a different network"

Internet suggests that my system uses the WEP key as security, but I see no option to change it to WPA2 (or 3) 

Can anyone help?

  0      
  0      
#1
Options
1 Accepted Solution
Re:Re:Windows 10 warning Deco M5-Solution
2019-08-14 01:13:12 - last edited 2019-09-19 00:39:48

@bliepje 

 

Hi, I have confirmed that the Deco wireless network uses mixed WPA/WPA2-PSK with AES/TKIP encryption type to enhance the security level.

 

Back to your case, we think there may have 2 possibilities:

1. First, the network adapter installed on the Windows 10 computer detect that the TKIP encryption type which is less secured than AES, even if it is still connected to the AES, it indicates that this network is not secured enough.

2. Second, even though the Deco network supports AES, while the network adapter negotiate the TKIP one by default, that is why the warning message pops up.

 

It is suggested to fix the encryption type of the network adapter to AES and verify whether it works. 

 

You can use telnet command to change the encryption type or go to properties page of the network adapter to do so.

 

May it help and have a nice day. 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
Recommended Solution
  2  
  2  
#4
Options
10 Reply
Re:Windows 10 warning Deco M5
2019-08-13 05:48:28 - last edited 2019-08-13 05:51:33

@bliepje 

 

Thanks for your reply.

 

With the error message pops up, are you able to connect to the TP-Link wifi network?

 

Could you please provide a picture of the current issue so that we can do further analysis? 

 

Meanwhile, can other devices connect to the Deco network? 

 

Best regards. 

 

 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#2
Options
Re:Windows 10 warning Deco M5
2019-08-13 07:20:45

This is the warning we get. In fact it is a warning so we can connect. And all other devices connect without issues Only the one using the 1903 update showed this warning.

I did a search on this error and found this:

https://www.howtogeek.com/423708/why-windows-10-says-your-wi-fi-network-isnt-secure/

Funny thing is that a TP-Link router is advised :) Just not the Deco 5 

 

  0  
  0  
#3
Options
Re:Re:Windows 10 warning Deco M5-Solution
2019-08-14 01:13:12 - last edited 2019-09-19 00:39:48

@bliepje 

 

Hi, I have confirmed that the Deco wireless network uses mixed WPA/WPA2-PSK with AES/TKIP encryption type to enhance the security level.

 

Back to your case, we think there may have 2 possibilities:

1. First, the network adapter installed on the Windows 10 computer detect that the TKIP encryption type which is less secured than AES, even if it is still connected to the AES, it indicates that this network is not secured enough.

2. Second, even though the Deco network supports AES, while the network adapter negotiate the TKIP one by default, that is why the warning message pops up.

 

It is suggested to fix the encryption type of the network adapter to AES and verify whether it works. 

 

You can use telnet command to change the encryption type or go to properties page of the network adapter to do so.

 

May it help and have a nice day. 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
Recommended Solution
  2  
  2  
#4
Options
Re:Re:Re:Windows 10 warning Deco M5
2019-08-14 06:14:57

Many thanks Kevin! I will check this. I'll do my best to reply again to confirm but the laptop it concerned is my sons. He will be back in two weeks, so then we can check :-). A small said my reply might take some time.

  0  
  0  
#5
Options
Re:Re:Re:Re:Windows 10 warning Deco M5
2019-08-14 06:22:16

@bliepje 

Thanks for your reply. 

 

Do not worry about that, feel free to take time to test it.

 

Any updates, please let us know. 

 

May it help and have a nice day. 

 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#6
Options
Re:Re:Windows 10 warning Deco M5
2019-09-18 12:01:34 - last edited 2019-09-18 12:04:00

@Kevin_Z 

Hi Kevin, sorry it took so long. Excellent advise! We just couldnt find (at first) where to change the networksetting. But at last: victory! It works like a charm. Thank you so much!

 

For some reason I cannot mark your explanation as "best solution", I guess I dont understand the logic of this system wink

  0  
  0  
#7
Options
Re:Re:Windows 10 warning Deco M5
2019-09-19 02:03:35

@bliepje 

 

Thanks for your reply, glad to hear that you figured it out finally. Congrats.

 

I can mark it as the best solution at our end. 

 

Now you can enjoy the internet with the Deco units.

 

If need more help in the future, do not hesitate to contact us.

 

Best regards. 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  1  
  1  
#8
Options
Re:Re:Windows 10 warning Deco M5
2020-03-29 14:14:16

Hi @Kevin_Z 

I'm having the same issue as bliepje, however I cannot find where I can set encryption type. 

My adapter is made by tp-link as well (it's Archer t4u) so it's a bit strange for me that they do not work well with Deco routers.

 

Do you know where I can change this setting in Archer driver settings or maybe somewhere in command prompt or in Windows registry.

 

Thanks in advance!

  0  
  0  
#9
Options
Re:Re:Windows 10 warning Deco M5
2020-05-20 21:09:46

@Kevin_Z for the record the relevant settings are ...

 

Settings -> Network & Internet -> Status -> Change adapter options

Selected WiFi and then choose View Status of this connection

Then choose Wireless Properties and select Security tab

 

You can then set AES!!!

 

Not one of the easiest settings to find ... took a couple of hours to track down 🤣

 

2 out of 3 of my PCs had this issue.

 

The puzzle is why I didn't have this issue with my old WiFi router. Is this some form of negotiation issue?

 

Cheers

 

Mark Enderby

  1  
  1  
#10
Options
Re:Re:Windows 10 warning Deco M5
2020-06-21 05:39:06 - last edited 2020-06-21 05:40:07

 

 

@MarkE your solution saves my time ................ 

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 5576

Replies: 10

Related Articles