TL-WN781ND(EU) v3 does not have N mode or reaches 150mbps

TL-WN781ND(EU) v3 does not have N mode or reaches 150mbps
TL-WN781ND(EU) v3 does not have N mode or reaches 150mbps
3 weeks ago
Model: TL-WN781ND
Hardware Version: V3
Firmware Version:

Hi guys. I have this pci express card and the box says it is a 150mbps Wireless N device (2.4ghz), but Windows shows me only 72mbps.

 

 

The device properties does not have the N mode, only B and B/G.

 

 

The bandwidth is set as "20_40mhz". There are "20mhz" and "20_40mhz" options. Wireless mode is set as "auto". There are "auto", "IEEE 802.11b" and "IEEE 802.11b/g" options.

 

I tried the default driver and the driver provided by TP-Link website (TL-WN781ND(EU)_V3_180118_Win) but no success.

 

Does anyone know what may be happening? Does this adapter have N mode and can reaches 150mbps?

 

Thanks.

 

0
0
#1
Options
3 Replies
Re:TL-WN781ND(EU) v3 does not have N mode or reaches 150mbps
3 weeks ago

@Yoshio 

 

Hello, the TL-WN781ND supports 80.211n, the reason why you cannot find it is that it works in 802.11n mode already. 

 

Back to your case, what is the bandwidth you paid for your ISP?
 

And what is the operating system of your computer? Windows 8 or 10?

 

Thanks in advance, and have a nice day. 

 

0
0
#2
Options
Re:Re:TL-WN781ND(EU) v3 does not have N mode or reaches 150mbps
3 weeks ago

My bandwidth is 120mbps (2.4ghz/20_40mhz). My OS is Windows 10.

0
0
#3
Options
Re:Re:Re:TL-WN781ND(EU) v3 does not have N mode or reaches 150mbps
3 weeks ago

@Yoshio 

 

Hello, thanks for your reply. 

 

It is suggested to change the channel width of the 2.4GHz to 40MHz on the web UI of the main router.

 

Any updates, please let us know. 

 

Good day. 

0
0
#4
Options