WISP does not reconnect

WISP does not reconnect
WISP does not reconnect
2019-09-01 23:12:27 - last edited 2019-09-01 23:23:23
Model: TL-WR802N
Hardware Version: V4
Firmware Version: 0.9.1 3.17 v0001.0 Build 190428 Rel.63523n

I create a local WiFi spot connecting this Nano router to the residence WiFi.

I need it because there are multiple occasions where devices should be visible to each other on a network, which is obviously disabled on the residence WiFi.

For example, file sharing between devices, development deploying, IoT (like robot cleaner, Amazon Echo) and so on.

So, I set router to the WISP mode, connect it to the WiFi and create an internal wireless network.

 

Each 40-50 minutes router disconnects from the residence WiFi. There is no ethernet cable and I have no idea about a distance to the residence routers/repeaters, but all my devices catch residence WiFi very well, without any disruption (at least, without visible one).

To reconnect, I should reboot router or scan for a SSID anew.

 

I understand that there can be many reasons of disconnection (the signal strength, network is too busy and so on), though all other devices work well.

The question is, why it can not immediately reconnect and what do I have to do? Should I buy some more powerful router (like TL-WR940N) or it is the source network problem?

 

My goal is to obtain a local WiFi network (where devices can be visible to each other) and to have the internet from outer WiFi shared into it.

0
0
#1
Options
2 Reply
Re:WISP does not reconnect
2019-09-02 03:24:31

@smslv 

 

What is the current network diagram? 

 

When the connection cut  off, please click here to check the IP address and gateway with your computer connected to the 802N. 

 

Try to move the 802N closer to the main router and ensure that firmware is up to date. 

 

Besides, you can change some wireless settings to optimize the performance, like wireless channel and channel width.

 

May it help and have a nice day. 

 

0
0
#2
Options
Re:Re:WISP does not reconnect
2019-09-02 23:02:13 - last edited 2019-09-02 23:24:17

@Kevin_Z 

 

By "residence" I mean a hotel-like appartment where WiFi network has a login page. There are no problems with it, it stays logged in, and I can login through the 802N router. My computer does not disconnect from it, but TP-Link does that once an hour.

 

> What is the current network diagram?

Final device (my computer, phone etc) <[local wireless]= TP-Link router <[public wireless]= WiFi network of the residence (I guess, a mesh of switches and repeaters, I don't have access further than a WiFi SSID). The connection marked red is the one that breaks each 40-50 minutes.

 

> When the connection cut  off, please click here to check the IP address and gateway with your computer connected to the 802N.

It gives me a local IP (it is the IP in the local network, like 192.168.0.2). Gateway is the router itself, which is, respectively, 192.168.0.1. Connection between computer and router is OK, it is router that disconnects from the second WiFi.

 

> Try to move the 802N closer to the main router and ensure that firmware is up to date. 

I have no idea where the "main router" is, think of it as of a hotel wifi. Firmware is updated, hardware is intact.

 

> Besides, you can change some wireless settings to optimize the performance, like wireless channel and channel width.

TP-Link console does not let me change something, because router is in WISP mode, which means it should be on the same channel as the second WiFi. When I change something, it immediately reverts. The router is advertised as WISP-capable, so I guess that a "it's too weak to maintain two connections" wuold not be a good answer.

0
0
#3
Options
Related Articles