How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
12
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-08 12:22:01 - last edited 2021-07-27 08:15:11

I recently got an Archer T6E 1300AC and I'm having trouble connecting to my 5GHz network. My router is providing 2.4GHz as well as 5Ghz access. When I disable 2.4GHz, the card connects to the 5GHz network just fine, I'm struggling however to force it to use 5GHz when both 2.4GHz and 5GHz are enable (I cannot permanently disabel 2.4GHz as there are other devices relying on it). I'm using Win 10 64-bit Version 10.0.18362 Build 18362.

 

  0      
  0      
#1
Options
2 Accepted Solutions
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?-Solution
2020-06-19 04:39:46 - last edited 2021-12-28 10:55:59

@djookz 

I was having this same problem recently after upgrading my Mobo/CPU and reinstalling windows 10.

 

I ended up installing the Broadcom 4360 drivers or 43xx for Windows 10 from a 3rd party site, driver-wireless.com. Once installed, look under the Advanced tab in the Device Manager properties for the card, there is an option for "Band Preference".  I set that to 'Prefer 802.11a'  instead of 'None' and it instantly connected to my 5 Ghz network. Thinking they meant 802.11ac... 'a' is very old standard.

 

I also have the channel in my router set to channel 40 instead of Auto.

 

(Bonus: I enabled Beamforming from the Advanced tab as well since I have a TP-Link router with beamforming support, not sure if it really does anything though)

 

Hope this helps someone, because I was pulling my hair out for 2 hours trying to figure this out.

 

Cheers,

Jeff

Recommended Solution
  10  
  10  
#9
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?-Solution
2020-09-22 13:27:24 - last edited 2021-07-27 08:15:11
I switched the band preference to 802.11a as you said and so far that worked perfectly! You have no idea how thrilled I was to find your answer after having so many issues!
Recommended Solution
  3  
  3  
#14
Options
16 Reply
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-09 07:49:12

@djookz 

 

As you know, the Archer T6E supports 2.4GHz and 5GHz both; 

 

If you want to force T6E connect to the 5GHz only, there are 2 options.

1. You can change the wireless mode as 802.11ac only when you go to advanced page of the network adapter.

2. You can use different SSID for the 2.4GHz and 5GHz; just connect the computer to the 5GHz with the password only, and then it won't connect to the 2.4GHz without the password.

 

May it help and have a nice day. 

 

  1  
  1  
#2
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-24 09:08:51

@Kevin_Z 

Just Google "T6E Windows 10 5ghz" and you will see that this card has a serious issue with finding/connecting to 5Ghz band.

In the network adapter advanced settings you will not even find the option to select ac.

Time for TP-Link to publish an updated driver. Or refund.

  0  
  0  
#3
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-25 05:57:12

@Superior3000 

 

Hello, if the T6E cannot detect the 5GHz of the main router, first, you can try to change the wireless channel, like channel 36, 40 or 44. 

 

Besides, there is a public driver released by the chipset manufacturer for Windows 10 64bit, you can give it a go. Download link as below:

http://support.tp-link.com/f/55bcecfe49/?dl=1

 

How to install it manually: https://www.tp-link.com/support/faq/920/

 

May it help and have a good day. 

  0  
  0  
#4
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-25 07:38:11

@Kevin_Z 

I am using the latest driver I can find: Broadcom BCM4352 v7.35.336.0 driver (dated 7 dec 2015), found somewhere on Microsoft Windows Catalog web page. Probably the same as you are referring to. Still, no option in the network adapter driver advanced settings to select 'Preferred Band' and put it on 5Ghz...

 

And about your suggestion on the router settings:

And I have the Deco M9 Plus router. From TP-Link. This router gives NO option to select the channel manually. Also, it does not have an option to create a separate SSID name for 5Ghz.

 

  0  
  0  
#5
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-27 09:01:01

@Superior3000 

 

Can this Archer T6E detect the 5GHz from the Deco? You can tryto disable 2.4GHz and disable fast roamming to give it a go.

 

The Archer T6E does not have this feature available to select preferred band; we need connect to the 5GHz manually to acheive it.

 

Considering you have the Deco M9 plus, the main network has the same wifi name, to ensure the adapter will connect to the 5GHz, you can enable guest network-5GHz as a workd around for now.

 

May it help and have a good day. 

  0  
  0  
#6
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-09-27 09:06:57

@Kevin_Z 

I appreciate your workarounds. But they remain workaraounds unfortunately.

I need both bands (some 2,4GHz only devices such as IP cams) to be on the main network and access other network sources/devices.

Switching on/off Fast roaming doesn't help.

  0  
  0  
#7
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2019-10-07 19:44:34 - last edited 2019-10-07 19:47:38

@Kevin_Z  or anyone else:

Any other suggestions?

Please note: Currently not one of the suggested drivers have the option to select 5GHZ as 'preferred band'.

  0  
  0  
#8
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?-Solution
2020-06-19 04:39:46 - last edited 2021-12-28 10:55:59

@djookz 

I was having this same problem recently after upgrading my Mobo/CPU and reinstalling windows 10.

 

I ended up installing the Broadcom 4360 drivers or 43xx for Windows 10 from a 3rd party site, driver-wireless.com. Once installed, look under the Advanced tab in the Device Manager properties for the card, there is an option for "Band Preference".  I set that to 'Prefer 802.11a'  instead of 'None' and it instantly connected to my 5 Ghz network. Thinking they meant 802.11ac... 'a' is very old standard.

 

I also have the channel in my router set to channel 40 instead of Auto.

 

(Bonus: I enabled Beamforming from the Advanced tab as well since I have a TP-Link router with beamforming support, not sure if it really does anything though)

 

Hope this helps someone, because I was pulling my hair out for 2 hours trying to figure this out.

 

Cheers,

Jeff

Recommended Solution
  10  
  10  
#9
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2020-07-03 20:45:48 - last edited 2020-07-03 21:07:46

I was having issue reaching my 5GHz network. 2.4GHz was working fine. Got to the solution, so I decided to register and post my solution here, this way other people can try it and maybe get it fixed too!

 

I tried so many drivers and so many settings without success. In the end I found out that the Archer T6e on Windows 10 will only work on certain channels for 5GHz connections (at least on my experience).

 

First I tried setting the network channels to 153 and 149 on the router with no success.

 

Then I decided to go to the lower channels (36, 40, 44) on my router settings again. Switched it to channel 36 and my adapter finally began seeing my 5GHz connection and connecting to it without any problem.

 

It worked for me with the Broadcom 43xx driver which I downloaded from driver-wireless.com, but I believe it would also work with the other drivers, and that the problem is actually the channel compatibility. I didn't change the settings at all.

 

So, I'd recommend anyone having the same problem to try setting the router to broadcast the 5GHz network on the 36, 40 or 44 channels before trying installing other drivers.

 

It seems like the same solution as @Birdie21 and @Kevin_Z recommended, but I think that the driver won't make a difference.

 

If this helps you get to the solution, please give it a thumbs up!

 

Good Luck!

 

 

Bonus: I downloaded the "Wifi Analyzer" app on my phone (Android) so I could see a channel that wouldn't be already taken by a neighbor's network, despite knowing that 5GHz networks from my neighbors wouldn't probably go far enough to make any interference.

  5  
  5  
#10
Options
Re:How to force Archer T6E 1300AC to prefer 5GHz over 2.4GHz?
2020-07-05 19:50:37

@Cated It works perfectly many thanks. 

  0  
  0  
#11
Options

Information

Helpful: 0

Views: 44445

Replies: 16

Related Articles