Archer C6 PPPOE problem

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C6 PPPOE problem

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 PPPOE problem
Archer C6 PPPOE problem
2019-10-12 05:24:11 - last edited 2020-07-14 06:05:18
Model: Archer C6  
Hardware Version: V2
Firmware Version: Latest available.

Ok,i got problem with my new Archer C6 1200(EU),using PPPOE connection is bugged,connected as usual from modem(ZTE)to routers wan port,on my old WR740N everything works fine,i've teyed many things,on 740 i can just enter username and password for my isp and it works,but limited at 94/30mb(BUT stable),reason for upgrade was better wifi signal and gigabit ports,but nah,bugged router or incompatibility with modem. And yea,i'm getting ISP's IP adress on C6,i can connect to internet ,but cannot play 4k video,or cannot complete "Speedtest",it jumps immediately to 60-70m and drops to 10mb,upload too,"e" signal lamp gone from green to orange while doing this test or anything harder than opening pages,after 15sec it become green again.Firmware is latest(and cannot be updated anymore or changed). Do not throw me "how to connect to internet" guides please,problem is much bigger. ;) 

 

Archer C6 was tested on other modem with Dynamic IP on wan port and it shows max connection,so just wanna say,theres some bug between router-zte-pppoe-isp. And i'm paying all of you to get these stupid problems :)))

  1      
  1      
#1
Options
2 Accepted Solutions
Re:Archer C6 PPPOE problem-Solution
2020-06-28 13:32:45 - last edited 2020-07-14 06:05:18

@Ganesh_G 

 

Hey there is something that worked for me.

 

I went to the router settings inside my old router, which works fine , so while going through its settings I could get hold of the MAC ID.

 

Now in my Archer C60 in router settings I did a quick settings usings PPPoE and entered the username password given by my service provided. Yet it was not connecting (Guessing you are stuck at this stage).

 

So after this step, I had gone to advance settings and in that there is an option to enter custom MAC, i entered the MAC taken from the old device and typed it in here, and that did my trick( Took me more than 10 hours to get through this workthrough)

 

(Tip: The mac ID which I got was of the format 80:2A:xxxx, in TP Link you have to enter 80-2A-xxxx)

 

 

Recommended Solution
  12  
  12  
#12
Options
Re:Archer C6 PPPOE problem-Solution
2020-09-23 05:41:38 - last edited 2020-12-01 08:34:02

@wbs1 

Dear All,

 

My C6 problem resolved. My ISP cable is RJ45 btw. Guys it's just the MAC ID that you need to copy from your old wifi router as suggested by Ganesh in earlier posts. I was doing the wrong way earlier. But here are below steps that you need to do for PPOE technology ISP.

Connect your ISP in your old wifi which was working fine. Login in your old wifi router and there you will find summary or status page where you will have so info about your lan, isp ip address, mac address etc

For Mac address you will find 2 Mac address one in LaN info Mac address and other in ISP info MAC address.

Please do not copy Lan MAC address. Copy the MAC address that you see in the internet status group and note it down.

Once done connect the new wifi C6 router with your ISP and perform quick setup the isp will still be down. Now go to advanced tab on c6 and click internet settings. There you will find use custom MAC address and insert the MAC address that you noted of old router.perform save and you will see the magic.

Let me know if that helps.

Thanks all for your support as well.

Recommended Solution
  5  
  5  
#19
Options
26 Reply
Re:Archer C6 PPPOE problem
2019-10-14 07:01:48

@Lo0odak 

 

Thanks for your requesting, it is more like that the network connection is unstable.

 

Do you mean the internet led by saying "e" signal? Like a global or saturn? 

 

When it goes to orange from green, please login to the web UI of the Archer C6 and show us a full screenshot of the status page. 

 

In the meantime, please connect your computer to the ZTE modem directly and verify whether you can get internet and check the IP and gateway also. Instruction as below: https://www.tp-link.com/support/faq/838/

 

Besides, if it works well, try to connect the computer to the Archer C6 by wired cable and access the web UI to clone the MAC address. 

 

May it help and have a nice day. 

 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#2
Options
Re:Archer C6 PPPOE problem
2019-10-14 08:13:09

@Kevin_Z  If you read what i wrote,you will see there that network working perfectly with same settings on my OLD Tp Link WR740N,no problems on speedtests and no bugs(i bought archer for gigabit ports and faster wifi speeds),or that was automated answer :) 

 

If you read,I was talking about "pppoe" connection,so I cannot connect modem directly to my pc to get IP adress because router getting ip adress via pppoe protocol,but again why it works normally with WR740N and not with Archer C6? :))

 

Well not sure which it is,but theres power,lan,internet led lamps, that one "saturn" for internet goes orange while speedtest start,or playing 4k video etc. (Again,using PPPOE protocol,and it works on older and cheaper router mentioned in conversation many times) 

 

Status page has so much private stuff,ip adress,mac adresses etc,i will see how i can post that one.

 

Thank you for answers.

  0  
  0  
#3
Options
Re:Archer C6 PPPOE problem
2019-10-16 07:26:01

@Lo0odak 

 

Hello, for the PPPoE connection, with computer connected to the modem directly, we need create the PPPoE connection on the computer to test the performance, instruction as below: https://www.tp-link.com/support/faq/921/

Note: Here we take Windows 10 as example. 

 

And as you mentioned, the sature led goes to orange when you test the speed, orange means that the network is unavailable, at that time, please access the web UI of the main router and show us a screenshot of the status page and go to system tools-system log to save it and export it to us.

Note: For these info, you can send us via message privately. 

 

Besides, if the computer works stablily with it connected to the modem, you can connect it back to the Archer C6 to clone the MAC address and verify the stability. 

 

Good day. 

 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#4
Options
Re:Archer C6 PPPOE problem
2019-11-13 21:44:28

@Lo0odak the same problem with me . with old router no problems ... but with new i have the same problems ... need to be solved 

  1  
  1  
#5
Options
Re:Archer C6 PPPOE problem
2019-11-14 05:59:22

@Nikolay 

 

Have  you ever tried the suggestion mentioned on my last reply? 

 

If still does not work, please provide us with the information needed so that we can do further analysis.

 

Good day. 

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#6
Options
Re:Archer C6 PPPOE problem
2019-11-14 09:49:56

@Nikolay They keep trying to tell me its network connection problem,and it still works on old 740N with same setup,Archer is just weak and thats it,tested few routers some of no name models and they worked just fine,now my ISP gave me new modem/router with pppoe connection inside,this buggy archer is used only like repeater now with dynamic ip protocol. :)

  0  
  0  
#7
Options
Re:Archer C6 PPPOE problem
2020-06-01 19:05:22

@Lo0odak 

 

Hey, Did you get any resolution for this. I bought the same router and my ISP provides PPPOE connection type and I am facing same issue.

  1  
  1  
#8
Options
Re:Archer C6 PPPOE problem
2020-06-01 19:14:20 - last edited 2020-06-01 19:14:48

@Ganesh_G ISP gave me their better router which can accept PPPOE connection and works flawlessly ,and Archer is used more like repeater only to send 5g wifi,didn't checked if there's any good firmware from tp-link,I just gave up from troubleshoting that crap mate. 🙂

  0  
  0  
#9
Options
Re:Archer C6 PPPOE problem
2020-06-16 17:44:01

@Lo0odak 

Same problem. Using the latest firmware for C6 v2 

There must be a bug in the firmware. Sometimes, after many resets, it starts to work at normal speed and it stays that way. Unfortunately if there's a power loss it always goes back to 0-1mbps and the fun starts again. 

 

Absolutely avoid this model if you need pppoe, for wifi is ok. TPLink should put a notification on the firmware page.

  0  
  0  
#10
Options
Re:Archer C6 PPPOE problem-Solution
2020-06-28 13:32:45 - last edited 2020-07-14 06:05:18

@Ganesh_G 

 

Hey there is something that worked for me.

 

I went to the router settings inside my old router, which works fine , so while going through its settings I could get hold of the MAC ID.

 

Now in my Archer C60 in router settings I did a quick settings usings PPPoE and entered the username password given by my service provided. Yet it was not connecting (Guessing you are stuck at this stage).

 

So after this step, I had gone to advance settings and in that there is an option to enter custom MAC, i entered the MAC taken from the old device and typed it in here, and that did my trick( Took me more than 10 hours to get through this workthrough)

 

(Tip: The mac ID which I got was of the format 80:2A:xxxx, in TP Link you have to enter 80-2A-xxxx)

 

 

Recommended Solution
  12  
  12  
#12
Options

Information

Helpful: 1

Views: 14088

Replies: 26

Related Articles