How to connect my Philips Smart tv's to the Deco

How to connect my Philips Smart tv's to the Deco
How to connect my Philips Smart tv's to the Deco
2019-10-21 08:14:53 - last edited 2019-10-26 08:33:52
Hardware Version:
Firmware Version: 1.2.8 Build 20190403 Rel. 43515

For nearly a year now I am using the Deco Mesh system and I love it! Stable connections, fast wifi, coverage in the whole house.

 

Only thing I cannot get fixed, we have two Philips Smart tv's and both of them won't connect with the Deco system.

 

I have tried with the scanning option on the tv's and then connect wireless with password, on the main Deco network and the guest network, both of them with 5Ghz on and off, just maybe because the tv's don't react on 5Ghz (like my old camera did), but that didn't work.

 

Then I have tried on both tv's and on both networks to connect via WPS but also that didn't work.

 

The tv's work on the router provided by the internetprovider but do not want to connect to Deco. Pity because both tv's are closer to a Deco satelite so this would give a mluch better wifi-signal.

 

Does anybody have any tips and tricks I can use to try to connect the tv's?

 

Thank you again for any help!

 

 

1
1
#1
Options
2 Accepted Solutions
Re:How to connect my Philips Smart tv's to the Deco-Solution
2019-10-21 22:12:45 - last edited 2019-10-26 08:33:52

@Helga I had problems too getting our smart TV (Sony Android) via WiFi connected to the network. Only after switching off "fast roaming"  thru the app was I able to get the TV connected.

Recommended Solution
0
0
#4
Options
Re:How to connect my Philips Smart tv's to the Deco-Solution
2019-10-22 01:42:25 - last edited 2019-10-26 08:33:59

@Helga 

 

Try to disable fast roaming on the Deco app. 

 

And you can set QoS application priority as standard and clear all the high priority rules. 

 

May it help and have a nice day. 

 

 

Recommended Solution
0
0
#5
Options
8 Replies
Re:How to connect my Philips Smart tv's to the Deco
2019-10-21 12:22:27

@Helga 

 

I have a philips smart tv, to be honest I just used an ethernet lead and all was well. If you don't have a spare port on the Deco, use a small 4 port hub.

0
0
#2
Options
Re:How to connect my Philips Smart tv's to the Deco
2019-10-21 14:48:58

@tgo actually the one tv is at about 2 meters away from the Deco but in another room (hallway and room 1) and the other one is totally on the other side of room 2 so I would have to cross the whole room to connect a cable. I know that would have been the easiest and fastest but the positions of the two satelites is the best for total coverage in the house.

0
0
#3
Options
Re:How to connect my Philips Smart tv's to the Deco-Solution
2019-10-21 22:12:45 - last edited 2019-10-26 08:33:52

@Helga I had problems too getting our smart TV (Sony Android) via WiFi connected to the network. Only after switching off "fast roaming"  thru the app was I able to get the TV connected.

Recommended Solution
0
0
#4
Options
Re:How to connect my Philips Smart tv's to the Deco-Solution
2019-10-22 01:42:25 - last edited 2019-10-26 08:33:59

@Helga 

 

Try to disable fast roaming on the Deco app. 

 

And you can set QoS application priority as standard and clear all the high priority rules. 

 

May it help and have a nice day. 

 

 

Recommended Solution
0
0
#5
Options
Re:How to connect my Philips Smart tv's to the Deco
2019-10-26 08:36:57

@Kevin_Z @Roberto1

 

Yes, that worked! Thank you!

0
0
#6
Options
Re:How to connect my Philips Smart tv's to the Deco
2019-10-28 03:04:05

@Helga 

 

You are welcome, it is glad to help you. 

 

Now you can enjoy the internet with Deco units, if need any further help, please feel free to tell us. 

 

Best regards. 

0
0
#7
Options
Re:How to connect my Philips Smart tv's to the Deco
2020-01-23 17:25:41

@Kevin_Z 

 

Hi Kevin,

 

I do have the same issue with my Sony TV 75X900F. Neither deactivating fast roaming nor the 5G helps. Any other idea ?

 

Thanks !

0
0
#8
Options
Re:How to connect my Philips Smart tv's to the Deco
2020-02-23 11:31:33

@Roberto1 

 

 

it works when i turn off the fast roaming but i will the fast roaming on is there another option to fix it?

1
1
#9
Options