Deco Mesh system connection issues

Deco Mesh system connection issues
Deco Mesh system connection issues
2020-01-25 17:27:53 - last edited 2020-07-28 06:13:14
Model: Deco E4
Hardware Version: V1
Firmware Version: 1.1.0 Build 20190823 Rel. 43466

A few weeks ago I decided to upgrade our WiFi to a Deco E4 mesh system (2-pack) because we have a lot of coverage issues. Everything was working fine until my dad started to complain that his laptop and tablet randomly lost internet connection, they didn't disconnect from the network, just couldn't access the internet. Turning off and on WiFi on both fixed it, but only for a few minutes/hours, then it happened again. My dad's' laptop supports both 2.4GHz and 5GHz, but his tablet only supports 2.4Ghz. I tried to turn off Beamforming, Fast Roaming and Mesh technology for both of these devices in the TP-Link Deco app, and his laptop no longer had any issues, however, his tablet is still randomly losing internet connection. I have no idea why this is happening, my phone, tablet, laptop, Chromecast, 2 outdoor security cameras and my mom's phone and laptop have absolutely no problems. Only my dad's tablet has issues with my Deco system. I'm not sure what's wrong.

5
5
#1
Options
1 Accepted Solution
Re:Deco Mesh system connection issues-Solution
2020-07-28 06:12:10 - last edited 2020-07-28 06:13:14

@jcsegura.bos @Jay-b  @willywonka  @Indigo3  @Nicolas80  @djgw  @YCMG 

 

Hello all, sorry to respond late.

 

Cause other wireless devices work well with the Deco network, which means the Deco mesh network should be working fine. If only some 2.4G smart devices have this problem, please try some troubleshooting first.

 

1. Do you have this connected but no internet issue on your smartphones since you bought the Deco network or this issue happened recently or issue occurred after the firmware update? Please ensure the firmware of your Deco device as well as the Deco app is up-to-date.

 

2. When connected but no internet, did your smartphones or smart devices obtain valid IP address and gateway from Deco? Can you ping the gateway of Deco from your phone?

 

3. Try to connect the main Deco to the modem/router only and verify whether you have the same issue.

 

4. Besides, you can contact the tech support of smartphones or smart devices to get some help, like upgrade the OS version of the cellphone or so. 

 

5. If none of the above suggested helped, please try to upgrade the beta firmware for the Deco M4 and monitor the performance again:

https://static.tp-link.com/2020/202005/20200529/Deco M4_1.1.8_Beta.zip

Note: there is an instruction in the downloaded file, which will guide you to update the Deco firmware.

 

Let me know if the issue is resolved or not, thanks.

Recommended Solution
0
0
#27
Options
55 Replies
Re:Deco Mesh system connection issues
2020-01-25 18:26:18
Just in the past week, my iPhone periodically loses connection with my deco M9 plus system. If I click the Wi-Fi off then back on on my phone, I am reconnected. Not sure what’s going on. I’ve had the system for a number of months and this only just started happening.
1
1
#2
Options
Re:Deco Mesh system connection issues
2020-01-28 14:17:00 - last edited 2020-01-28 14:17:43

Look for other threads, there are multiple devices with same symptons, mostly tablets and mobile phones: they show the wifi as connected without internet, the device connects but after some time (minutes) looses internet connectivity - different hardware models, android versions, manufacturers. Tp-link just mentions this is probably a compatibility issue between the deco's and the mobile device but, there are so many different devices experiencing this issue with different deco models (M4 for me but you will find issues with M5, P9, etc.), that looks like something common to all the decos firmwares. On all threads, when turning on the former ISP/router wifi and connecting to this one instead, the device with the wifi issues connects and stays connected fine. This cannot be an isolated incident anymore, it has to be a particularity of the tp-link mesh implementation.

4
4
#3
Options
Re:Deco Mesh system connection issues
2020-01-28 15:25:02

A few days ago my dad was "experimenting" with it and unplugged the 2nd Deco (so only the main Deco was powered) and after that, the issue was completely fixed. So it's definitely a problem with TP-Link's mesh implementation. The problem is that I need to have the 2nd Deco powered on because our outdoor security cameras cannot connect to our WiFi.  So I plugged in the 2nd Deco again and a day later the issue came back. Our ISP didn't give us any router, so I can't plug it into an ISP-provided router. TP-Link should definitely fix this (if it's a firmware issue).

5
5
#4
Options
Re:Deco Mesh system connection issues
2020-04-15 13:48:32

@asciiid  Just a quick Question.   Is the Deco system in Router Mode or in Access Point Mode?

1
1
#5
Options
Re:Deco Mesh system connection issues
2020-04-15 13:53:57

@Stefan_A The Deco is in router mode. But I tried to use my old Asus router and connect the Deco to it and change it to AP mode, but that didn't solve the issue either. It definitely seems like the Deco is the problem.

0
0
#6
Options
Re:Deco Mesh system connection issues
2020-04-21 11:06:08

@asciiid I'm having the same connectivity issues. Apps had a difficult time connecting to the internet with the TP Link M4R. I have to disconnect and connect again after a few minutes in order to get back online even though I am connected to the internet, and the internet is working just fine. This is getting really frustrating. I have tried all the possible solutions and configurations but to no avail. 😔😔😔

2
2
#7
Options
Re:Deco Mesh system connection issues
2020-04-21 13:23:27

I have no idea what is going on, the only reason why I'm not going back to my old router is the Deco's awesome range, it's really good (at least in my case). But since most of our devices are experiencing this issue, I'm not really sure what I'm going to do/what should I do, this is so annoying. I even tried to disable 5GHz and just keep 2.4Ghz, but that didn't fix anything either. I'll probably contact the seller, I may be able to get a refund, although it's probably too late to file a refund request. 

2
2
#8
Options
Re:Deco Mesh system connection issues
2020-04-21 21:26:11

@asciiid I'm having similar issue with my Logitech circle camera. It seems good for first couple of days but now for last 4 days it keeps disconnecting. I've turned off "Fast Roaming" and still no luck. I even reset my Camera and I'm still facing issue. 

1
1
#9
Options
Re:Deco Mesh system connection issues
2020-05-25 18:41:26

@Stefan_A  I've this same issue and my Deco5 3 units system is on router mode, conected to the modem by LAN Cable (main Deco only)... is that something to change?

0
0
#10
Options
Re:Deco Mesh system connection issues
2020-06-05 20:57:31

@asciiid Add 1 more M3 system to this issue.

 

I bought the system for my pastors, and it worked fine the first couple of weeks, now they are regularly complaining about their devices being connected but being unable to browse, use apps or even chat over Whatsapp and Telegram.

0
0
#11
Options