HS100 won't connect to my WiFi

HS100 won't connect to my WiFi
HS100 won't connect to my WiFi
2020-03-19 17:01:20 - last edited 2020-03-24 16:40:42
Model: HS100
Hardware Version:
Firmware Version:

Hello, I've previously bought three HS100 smart plugs (ver. 3.0) and the installation went very smoothly with my 2.4 GHz WiFi router. I was so satisfied with them that I've bought two more, which won't connect to my WiFi. They are identical except that these new ones are version 4.0.

 

This is how I try to install them (just followed your guide https://www.tp-link.com/se/support/faq/946/):

- Connect one HS100 device to a power outlet

- Wait until the WiFi indicator starts to illuminate green and orange

- Go to my Kasa app (Android) and click on the + button while I am on my 2.4 GHz Wifi

- Choose Device, Smart Plug, HS100 and click on the next button until my phone connects to HS100's network

- Choose my 2.4 GHz network and type my password and later click on Join

- and here it stops...

 

The phone changes back to my 2.4 GHz WiFi after a while but it gets stuck at the "Connecting Smart Plug to Your Home Network" screen. It is usually stuck here around 20-30 minutes until the "Unable to connect to your WiFi" screen shows up. The WiFi LED on the HS100 device keeps blinking green and orange which should indicate that it never connects with my WiFi.

 

So far, I have tried the following remedies without any success:

- Downloaded the Kasa app on my iPhone and tried to install the device but it gets stuck on the same place.

- Performed a normal and a factory reset on the device.

- Disconnected the three HS100 that I bought earlier from my home network and then tried to connect my new HS100 ver. 4.0 device.

- Restarted the router.

- Double/triple checked my WiFi password (done this about 15 times).

- Inserted the device to an outlet next to the router (10 cm away).

- Exit the app to see if it appears in the Kasa home page anyway (it does not).

- Tried the steps above with the other HS100 ver. 4.0 with no success.

- Checked my router if it is blocking new devices or has a maximum limit of connected devices (which it don't).

 

Do you have any ideas what the problem can be? The only difference that I've found between the three working ones and the two not working ones is the version.

0
0
#1
Options
2 Accepted Solutions
Re:HS100 won't connect to my WiFi-Solution
2020-03-23 03:40:41 - last edited 2020-03-24 16:40:42

@Patrik 

Thanks for the info.

You are right, when the wifi light blinking green, the plug is trying to connect to the router, but failed finally. 

 

Please change your encryption to WPA2 PSK only, don't use WPA+WPA2 PSK. Then factory reset the plug and reinstall it have a try.

Best Solution
2
2
#4
Options
Re:HS100 won't connect to my WiFi-Solution
2020-03-24 16:41:41 - last edited 2020-04-16 03:23:12
That's it! Changing to only "WPA2 PSK" was the solution. Thank you very much for your help!
Best Solution
1
1
#5
Options
7 Replies
Re:HS100 won't connect to my WiFi
2020-03-20 08:04:49

@Patrik 

Hi, you may refer to the steps below to do some troubleshooting.

 

1) Make sure the router’s Wi-Fi signal strength is strong.

 

2) Make sure the Wi-Fi password of the router is correct. The password length cannot exceed 64 characters and does not contain characters such as single and double-quotes.

 

3) Try to change the wireless channel (fix channel to channel 1, 6 or 11) of the router and start over again.

 

4) Check the wireless encryption type, use  WPA2 personal or WPA2 PSK. Turn off the special settings on the router, such as firewall, Mac filtering or access control.

 

What's the model number of your router? What's the plug's MAC address and serial number? Please send us the screenshot of the error message page if it still not working.

 

Good day.

0
0
#2
Options
Re:HS100 won't connect to my WiFi
2020-03-22 11:11:04

Hello @Stella.Q ,

 

Thank you for your quick answer.

 

Here are my comments for your suggested troubleshooting:

1. It is. I have even tried to do this 10 cm from the router.

2. I am _very_ sure that it is the correct password. :)

3. Changed between 1, 6, 11, 12 with no difference.

4. I use WPA+WPA2 PSK as encryption. Mac filtering and access control are already deactivated. It did not help to temporary deactivate the firewall.

 

I am using a Technicolor TG799vac XTREAM (firmware version: 18.1) as router. 

 

An observation: When I connect to the device's network and choose my WiFi in the list, the wireless signal blinks green for a while but then returns to blink in green and orange while the configuration guide is stuck on the "Connecting Smart Plug to Your Home Network" screen. I guess it tries to connect but it cannot establish a connection between the device and my router and after a while it just ping out. Am I correct?

 

This is the menu when I connect:

 

And this is the error message that I get when it cannot connect to the router:

 

Here's additional information about the device that you were asking for:

0
0
#3
Options
Re:HS100 won't connect to my WiFi-Solution
2020-03-23 03:40:41 - last edited 2020-03-24 16:40:42

@Patrik 

Thanks for the info.

You are right, when the wifi light blinking green, the plug is trying to connect to the router, but failed finally. 

 

Please change your encryption to WPA2 PSK only, don't use WPA+WPA2 PSK. Then factory reset the plug and reinstall it have a try.

Best Solution
2
2
#4
Options
Re:HS100 won't connect to my WiFi-Solution
2020-03-24 16:41:41 - last edited 2020-04-16 03:23:12
That's it! Changing to only "WPA2 PSK" was the solution. Thank you very much for your help!
Best Solution
1
1
#5
Options
Re:HS100 won't connect to my WiFi
2020-03-26 06:12:16

@Patrik 

Hi, glad to hear that it works, congrats.^_^

 

If need any further help, just let us know.

 

Good day

0
0
#6
Options
Re:HS100 won't connect to my WiFi
2020-04-15 17:09:01

I had the same problem, by coming here I found out that the encryption type had to be set to only WPA2 PSK. This was not a problem with my older smart plug which is v3.1.

Thanks!

0
0
#7
Options
Re:HS100 won't connect to my WiFi
2 weeks ago

@Patrik 

I have 5 plugs and now all of them can't connect to my wifi
I try to reset to factory setting and set up again but during the setup when you need to chose your network

it cannot find my wifi network, so Im not really sure if it has to do with 2.4 or 5Ghz because it was working properly and I didnt change my network modem or router.
My router is already in WPA2 PSK 2.4GHz still cant find
I really dont know what happened since all of my smart devices is working fine.
So I think its not the wifi problem.

 

Im not sure what to do now since I tried everything from the comments above.

0
0
#8
Options