Regular Ping/Lag Spikes on Deco M9

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Regular Ping/Lag Spikes on Deco M9

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Regular Ping/Lag Spikes on Deco M9
Regular Ping/Lag Spikes on Deco M9
2020-03-31 07:56:05 - last edited 2021-02-25 06:34:20
Model: Deco M9 Plus  
Hardware Version: V2
Firmware Version: 1.2.10 Build 20190809 Rel. 54285

I'm having an issue of a perfectly regular ping spike when using the Deco M9.

 

The chart below shows a ping to the main Deco.  You can see the perfectly regular ping spikes.  This is just a local ping as you can see from the IPs, it has nothing to do with my internet connection, which is a stable 350mbs. So we can discount that.

 

Other points which may help diagnose:

 

  • The speed I achieve is good.  (from the laptop that created the screenshot below - which I imagine is connected to the satellite)
  • Both Decos lights are green. And a distance of about 7m between the master and the only satellite.
  • Latest Firmware
  • Anti Virus is turned off and QOS isn't weighted at all, all I've done is set the conncetion speed via the speed test as without that there was some noticeable throttling.
  • Have tried factory resetting and swapping the 2 Deco master around.  Still same issue.
  • Deco in Router mode
  • Internet (Router in modem mode) --> Master Deco --> 5 port Netgear Switch with a few devices

 

This lag spike occurs every 50s or so, makes gaming impossible, and is a serious regression in performance over my non mesh network.

 

Please advise what might be the source, or if there's anyhting else I can do to diagnose.

  1      
  1      
#1
Options
1 Accepted Solution
[Solution]Regular Ping/Lag Spikes on Deco M9-Solution
2021-02-25 06:34:09 - last edited 2022-01-13 06:49:45
Recommended Solution
  0  
  0  
#19
Options
32 Reply
Re:Regular Ping/Lag Spikes on Deco M9
2020-03-31 10:31:31 - last edited 2020-03-31 10:40:26

I also have the same problem and think it is hardware related to the m9 V2. I see spikes every 10 seconds or so.

I hope someone from TP-Link can react to this problem and give some tips/advice.

  1  
  1  
#2
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-03-31 12:14:03
Interesting thread to follow, I am experiencing a lot of similar problems. Which program are you using to do this analysis?
  0  
  0  
#3
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-03-31 14:43:53 - last edited 2020-03-31 14:46:09

OK, so some significant progress.  That I hope might be of use to someone else.

 

I was using https://www.pingplotter.com/ to chart the pings, it's free for 14 days.  I was doing this ping from a macbook pro connected by WIFI to the Deco mesh.  Now, I stumbled upon this article at one point : https://apple.stackexchange.com/questions/263638/macbook-pro-experiencing-ping-spikes-to-local-router

 

Which cites how OSX's location services by default effectively does a wifi scan regulalry and frequently, this has a detrimental effect across the network.  I followed the steps in : https://apple.stackexchange.com/a/348574 to disable location services on my mac.  I could go back and log to find the culprit, but I just turned the lot off - I've no real cause for them anyway.  And as soon as I did that, the ping spike every 50s or so disappeared. 

 

This issue came about as I was noticing this ping spike on other devices, (i.e. Xbox) which lead me to suspect the Deco as that was the common link, but I suspect the disruptive nature of this wifi scan performed by the laptop was the cause of the issue.

 

I tried enabled fast roaming, but that made the latency issue worse.  So disabled that again.

 

Hope this helps.

  0  
  0  
#4
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-04-01 14:56:43
Thanks for your information. I have run plingplotter and I see the same pattern. Regarding the rest I will wait wat TP-Link comes up with.
  0  
  0  
#5
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-04-02 07:17:10

I have discoverd that the problem is in windows 10 probably.

I installed ubunu linux on my laptop and i have no ping spikes or lag with the wifi.

 

So i ithink there is someting in Windows that is causing this problem. THe question is what.

THere are a lot of people experiencing the problem with the ping spikes and lag but there no solution on the internet that works for me.

 

So is there anybody who can find out what windows is doing on every 10 seconds or so that is causing the lag?

  0  
  0  
#6
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-04-08 08:17:48

My macbooks at home do the same with lag spikes but less high, still not what i expect from the product. 
So not sure if its just W10.

  0  
  0  
#7
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-07-11 11:35:27

HA !.

I lost two days trying to figure out what is going on and i found this topic :P

I also have exactly the same regular spikes :)

Beside that problem i still know that Deco is much better than Orbi and Velop Mesh !

We just need fix TP-Link Team !

 

  0  
  0  
#8
Options
Re:Regular Ping/Lag Spikes on Deco M4
2020-11-22 04:12:29 - last edited 2020-11-22 04:13:44

Having the same issue with deco M4... 

Freaking random spiking issue occuring every 5/6 seconds, even though the speedtest went good but then the spiking issue persist.

  2  
  2  
#10
Options
Re:Regular Ping/Lag Spikes on Deco M4
2020-11-23 01:13:49

@Jzlim same issue here with deco m9.  My Wi-Fi overall is fantastic, with strong speeds, good signal low latency, etc

 

However, if I try to use Google stadia to stream games, or steam link, or other apps for wireless game streaming, it is unplayable because of the pink spikes every five or six seconds. If I hardwire streaming device I'm using, the issue is greatly reduced, but still not perfect.  

 

The last firmware major firmware update that occurred in the summer helped somewhat, but I'm hoping they pay more attention to this issue.  I'm counting the days to the warranty to see if I have to replace this with a new system :/

  0  
  0  
#11
Options
Re:Regular Ping/Lag Spikes on Deco M9
2020-11-23 09:54:04 - last edited 2021-02-25 06:24:09

@oller 

Hi ALL. Good day!

 Thank you very much for all your concern about this case.

We might need your help to get more details:

  1. Please makes sure the firmware is up to date;

---currently, the latest firmware for M9- v2 is Version 1.5.1

  1. Change the DNS server on the M9 to be 8.8.8.8/8.8.4.4;
  2. Connect the main Deco via Ethernet and do the ping test again to see if the issue still here;

 

  After that, please send an email to support@tp-link.com subject [Forum ID 201302] Regular Ping/Lag Spikes on Deco M9/M4 with the following answers:

  1. How long have you had the Deco and when did this issue start?
  2. How many Deco units do you have and how are they connected to each other, wireless, or Ethernet? –it would be highly appreciated that you could draw a simple diagram for that;
  3. Please spare us some screen-shots of the ping spike tests;

Thanks a lot for your cooperation and support.

  0  
  0  
#12
Options

Information

Helpful: 1

Views: 20150

Replies: 32