Just one OneMesh compatible device to build a mesh network.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Just one OneMesh compatible device to build a mesh network.

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Just one OneMesh compatible device to build a mesh network.
Just one OneMesh compatible device to build a mesh network.
2020-05-25 19:49:09 - last edited 2020-05-31 08:47:28
Model: Archer C7  
Hardware Version: V5
Firmware Version: Archer C7(EU)_V5_190726

Hi @Kevinz and TP-Link crew,

It looks like just one OneMesh compatible device is enough to have mesh system. Could you please explain this phenomenon?

 

I have one Archer C7 v5.0 router (supporting OneMesh feature, FW V5_190726) and an old TL-WDR 4300 router (no support of OneMesh, latest firmware from 2015) set up as an Access Point. Both devices connected via LAN cable. The signals partially overlap as I have not big but 2-floors house. In this configuration I can clearly see that when I'm moving my device (mobile phone, tablet, laptop) between the floors, the device smoothly and immediately switches to the stronger signal - exactly as the mesh system works. It happens when I move between the floors in both ways (switching from router to AP and AP to router). Moreover, it also happens when I replace the WDR4300 with an old Access Point (TL-WA801ND, latest firmware from 2015) that also doesn't support OneMesh, but the Mesh feature works here as well with C7.

 
But when I reconfigure my network in an opposite way - use my WDR4300 as a main router and set up Archer C7 as an Access Point (in this mode OneMesh feature is not supported by C7), the smooth switching between the points on my mobile devices is not working anymore (I'm moving to the other floor but my devices still keep connections to the initial point, as long as I completely lose the signal with this point. Only then my devices are connecting to the point with stronger signal).

 

Could you please explain this phenomenon? As i mentioned in the beginning, it looks like the only thing you ned to build a OneMesh network is to have just one OneMesh compatible device as a router. The other access points must not support OneMesh feature. This finding is also opposite to what you advertise on the website: https://www.tp-link.com/en/onemesh/?utm_source=compatibility&utm_medium=local&utm_campaign=all, where you point that the range extenders (APs) must be also OneMesh compatible devices.

 

I was planning to replace my C7 with C80 and set up C7 as an AP but it seems like it doesn't make a sense if I'm going to lose Mesh functionality (C80 doesn't support OneMesh).

Thank you in advance and many greetings.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Just one OneMesh compatible device to build a mesh network.-Solution
2020-05-29 16:33:35 - last edited 2020-05-31 08:47:28

Hello @Solla-topee,

I’m sorry. I have double-checked it and I have found that when the WDR4300 is set as a router, the encryption method was set to AES, while on the AP it was set to automatic. I haven’t noticed this difference before. In this configuration the devices couldn’t roam smoothly. When i changed the encryption from AES to Auto on the 4300, the smooth roaming started to work fine.

Sorry again for the confusion and thank you for your support.

Recommended Solution
  0  
  0  
#5
Options
4 Reply
Re:Just one OneMesh compatible device to build a mesh network.
2020-05-27 07:10:08

@Maciej_K 

Thanks for your testing.

There might be a misunderstanding between Onemesh and traditional wireless roaming. What you have tested by setting up the Archer C7 as the main router and connecting to a WDR4300 access point is roaming network that gives the same wireless network name to both the main router and the access point, so your devices such as phone, tablet, and laptop can connect to the better wireless automatically.

 

However, this is not so-called TP-Link OneMesh. With an equipped TP-Link OneMesh feature router or extender, it will suggest your devices switch to a better signal Wi-Fi considering having a better performance. For more information about TP-Link OneMesh, please refer to OneMesh™-Create a Whole-Home Wi-Fi Network with Your TP-Link Devices or TP-Link OneMesh™ VS Deco Mesh: What's the Difference.

  0  
  0  
#2
Options
Re:Just one OneMesh compatible device to build a mesh network.
2020-05-27 08:52:34

@Solla-topee thank you for your explanations and articles. I have also googled more about the traditional wireless roaming.

However, I'm still not fully convinced... I have added third AP to my setup and still I can see smoth switching of my mobile devices to the other point. All of the points are opearting on a different channels, but having the same BSSID, pass and encryption method. But when I set up the C7 as an AP and use WDR4300 as my main router, the same wireless devices can't smoothly roam anymore. You need to force the switching by turning wifi off and on again to connect to stronger signal. I would expect my mobile devices behave the same with roaming as when C7 is my main router. So this must have something to do with the C7... But I'm not sure what and whether it is indeed related to the OneMesh feature.

  0  
  0  
#3
Options
Re:Just one OneMesh compatible device to build a mesh network.
2020-05-28 06:28:44

@Maciej_K 

Thanks for more tests.

 

From what you've doubted, it seems that the wireless 2.4GHz network of the WDR4300 is pretty good and that might be why your mobile devices will not move to the AP's wireless automatically. You may check and see if you can change the wireless connection's sensitivity to the highest to see if it makes a difference.

 

BTW, you can use the Archer C7 as the main router and the WDR4300 as the AP and the wireless clients will just roam fine, we suggest you can just let it go.

  0  
  0  
#4
Options
Re:Just one OneMesh compatible device to build a mesh network.-Solution
2020-05-29 16:33:35 - last edited 2020-05-31 08:47:28

Hello @Solla-topee,

I’m sorry. I have double-checked it and I have found that when the WDR4300 is set as a router, the encryption method was set to AES, while on the AP it was set to automatic. I haven’t noticed this difference before. In this configuration the devices couldn’t roam smoothly. When i changed the encryption from AES to Auto on the 4300, the smooth roaming started to work fine.

Sorry again for the confusion and thank you for your support.

Recommended Solution
  0  
  0  
#5
Options

Information

Helpful: 0

Views: 2301

Replies: 4

Related Articles