【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem

【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem
【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem
2020-06-05 10:03:34 - last edited 2020-06-05 11:01:10
Model: TL-WA850RE
Hardware Version: V6
Firmware Version: 191206

Maybe you have the same issue as mine. Then I will share my solution on this: Disable Band Steering function on Hitron modem. Now the tplink Range extender is working fine with my Hitron Modem Router.

 

I just got TL-WA850RE several days ago. And tried to configure it via WPS and password, but never succeeded. Very frustrated.

Here is my device information.

TL-WA850RE: Hardware version V6, Firmware Build 191206

Hitron modem: Hitron CGN3ACSMR

 

Then I got help from tplink support. And tplink advised me to disable the Band steering function as below. It worked at once. The RE light is on and the internet is working too. Bravo! Thank Tplink.

 

Then I checked something on the internet and found this.

https://www.rogers.com/customer/support/article/troubleshoot-band-steering-wifi-problems

 

It seems that the band steering is enabled by default. And this function may not work well in some cases. I don't know much about the internet or this function. And I do know that why I can only saw one Wifi name, even my hitron modem supports 2.4G and 5G wifi, just because of the band steering enabled, they just share the same wifi name. I would prefer to leave this disabled as tplink advised. Then I can connect 2.4G or 5G wifi as my wish. Also, tplink 850RE works.

 

I also noticed that the following Hitron modems have a band steering function. If you have similar issues, then just disable it as I do.

https://www.rogers.com/customer/support/article/dual-band-band-steering

 

1) Ignite WiFiTM Gateway (XB6) modem

2) Wall-to-Wall WiFiTM equipment

3) Hitron CGN AC Family WiFi Modems: CGN3-ACR, CGN3-AMR, CGN3ACSMR, and CGNM-3552

4) Hitron CODA-4582 modem

2
2
#1
Options
4 Replies
Re:【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem
2020-08-05 12:11:53

@Paris_lly 

Excellent sharingyes

0
0
#2
Options
Re:【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem
2020-08-12 14:17:37
0
0
#3
Options
Re:【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem
3 weeks ago
Excellent worth sharing https://trafoos.com/best-coffee-in-vancouver/
0
0
#4
Options
Re:【Resolved Solution】TL-WA850RE failed to connect to my Hitron Modem
3 weeks ago
Excellent worth sharing https://trafoos.com/best-coffee-in-vancouver/
0
0
#5
Options