Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??

Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-10 11:16:05 - last edited 2020-07-07 07:46:13
Model: Deco P9
Hardware Version: V1
Firmware Version: 1.1.0 Build 20200513 Rel. 52023

Hi All,

 

Looking for some assistance from other Deco P9 users.

 

I've noticed my P9 is reporting the following error "daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20", approximately 20+ times per minute. I've also noticed the P9 is repeatedly experiencing 100% CPU utilisation (load), and am wondering if the two could be related. I've contacted tp-link support, who've advised they can't see any issue with the device.

 

However, I'd be grateful if other Deco P9 users could check and advise if the same / similar error is being reported by their P9 systems in the (Notice, Error, Warning) logs?

 

Thank for the assistance.

0
0
#1
Options
1 Accepted Solution
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??-Solution
2020-07-07 07:45:59 - last edited 2020-07-07 07:46:13

@FireDZ 

 

Hello all, sorry to respond late.

 

For the daemon.err display issue, we have received your feedback and will ask our developers to speed up analyzing it, please be more patient, thanks.

 

For the CPU shows 100% issue, as far as we can tell it will only appear when you just entered the web UI of the Deco P9 and it will be back normal after a while. This is also forwarded to the engineers and we will update here.

 

However, neither the daemon.err display issue nor the 100% CPU issue will cause the P9 crash or disconnecting from the internet, so if anyone encounters a disconnection issue with the Deco P9 network, please confirm some basic info so that we can speed up the whole process and offer a solution:

1. Refer to the troubleshooting guide to narrow down the issue and confirm if the whole system is unstable or just the satellite P9 is disconnecting from the main P9:

Unstable connection with Deco

2. What is the detailed network diagram and how Deco P9s connected, is the main P9 a Router or an Access Point? What is the LED status on each Deco P9 when the network disconnects?

3. How often does the disconnection issue happen and how do you make it back to work?

4. Are all clients disconnecting from the network or just some of them? Is the wireless still connected but showing no internet access or it got disconnected from the network? 

 

Thanks for your cooperation and look forward to your reply.

Best Solution
0
0
#40
Options
62 Replies
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-10 22:39:49

@FireDZ 

 

Yes, I just updated my P9's firmware and on logging into the new web page portal I see LOTS of errors/warnings in my log.  eg this repeated over and over:

Wed Jun 10 23:30:02 2020 user.warn IMPROXY: WARNING[imp_verify_multicast_addr@206]: Group address ff02::1:ff00:0 is link-local multicast address

 

A few others pop up - but that ones my most common.  Im not seeing any of the errors you have though...

0
0
#2
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-11 12:01:03

@Valver 

 

Thanks for the reply; out of interest are you using the P9 in AP or Router mode?

0
0
#3
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-11 16:47:00

@FireDZ   ...router mode

0
0
#4
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-12 20:33:28

Same problems here, just upgraded firmware.

100% CPU load and same kind of log issues.

Running in router mode.

0
0
#5
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-13 14:41:25

Thanks for the replies; going to advise tp-link support others are having issues, and point them at this thread (Hopefully we'll all get some info / fixes).

 
0
0
#6
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-21 21:29:39

@FireDZ 

Same error logs here:

Sun Jun 21 22:17:55 2020 daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 28

 

Not sure though it was not the same before the firmware update. I am running my deco P9s in Access Point mode.

 

Any fix to be expected soon?

0
0
#7
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-22 10:34:13

@Double_Jay 

 

Errors were definitely present both prior to and after the recent firmware update.

 

I've highlighted this thread, and the fact others are experiencing the same and similar errors to tp-link support. Will update if / when I get a response.

0
0
#8
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-22 14:57:39

 

Some kind of same issue over here. Just updated to the latest firmware (1.1.0 Build 20200513 Rel. 52023), having stability issues (dropping signal, problems with roaming, devices seems to be offline for a while). Find this errors in the system log:

 

Mon Jun 22 16:31:36 2020 daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 24

Mon Jun 22 16:31:39 2020 daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 24

0
0
#9
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-22 22:48:19 - last edited 2020-06-22 22:51:11

@FireDZ Same here

 

I get the following every three seconds in the logs CONSTANTLY.

 

Mon Jun 22 23:45:24 2020 daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 24

Mon Jun 22 23:45:27 2020 daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 24

 

Firmware - 1.1.0 Build 20200513 Rel. 52023

 

Running in AP MODE

0
0
#10
Options
Re:Deco P9 error: daemon.err /usr/bin/apsd: apsd_get_active_ports:214: Error: No such interface 20 ??
2020-06-23 11:24:42

@FireDZ Just to add some more to this.

 

I have plugged the P9 into the ISP Router directly and two other seperate switches just to see if it was related to hardware.

 

Ther problem persists regardless of what switching device I plug it into.

0
0
#11
Options