Deco M5 - wifi very slow

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Deco M5 - wifi very slow
Deco M5 - wifi very slow
2020-06-18 10:29:14 - last edited 2020-09-04 01:43:28
Model: Deco M5
Hardware Version:
Firmware Version: 1.4.4 Build 20200221 Rel. 65392

Hi, I bought a Deco M5 system about a monthy ago and until today it's been great.  We have 3 Deco units and coverage over the house is generally strong.  This morning, speed of the wifi has been poor.

 

I've done the following:

 

1) Run a speedtest from the Deco app - 27Mbps down, 5Mbps up

2) Run a speedtest from several connected devices - 1-2Mbps down, 0.2 - 0.5Mbps up

3) Hardwired direct into my broadband router - 27Mbps down, 5Mbps up

4) Shutdown my broadband router and all of the Deco units

5) Restarted the broadband router

6) When the router was back up I restarted the main Deco

7) When the main deco was back up with a gree light, I restarted the two slave deco's

8) Repeated the speed tests above with the same results

 

So there seems to be an issue with the Decos and not my broadband.  The wifi is turned off on my broadband router and has been since I installed the Deco system.  I've checked firmware is all up to date and I've run the speedtest on 2 different phones and two different laptops.  The wifi is consistently slow.

 

Any ideas?

 

Thanks.

0
0
#1
Options
1 Accepted Solution
Re:Deco M5 - wifi very slow-Solution
2020-09-04 01:43:22 - last edited 2020-09-04 01:43:28

@ewakil12   @MCage   @Big-Dream 

 

Hello all, sorry to respond late.

 

Make sure you are tagging a TP-Link Admin next time if you want a timely response. Unless we are tagged we do not see that new responses have been added. We do not subscribe to every thread so rely on Tagging to ensure responses.

 

As for the speed issue you reported here, it seems that your Deco M5 units are working fine for months and suddenly drops to a very slow speed, we hope you could help confirm the below:

1. Please provide your detailed network diagram, how many Deco M5 do you have in total and how are they connected to each other, the main Deco is working as a router or an Access Point, etc.

2. Who is your internet service provider? And what's the bandwidth you pay for them? Please connect your computer to the ISP modem/router directly and test the speed you can get from it and show us a screenshot of the speed test result.

3. Then connect the ISP modem/router--the main Deco--the same computer,  run the speedtest again and confirm the speed again, show us the test result.

4. Connect a laptop or smartphone to the main Deco wireless network, test the wireless speed again, please verify it is connected to the 2.4GHz or 5GHz network and how about the link speed as below:

https://www.tp-link.com/support/faq/2265/

 

Besides, please uncheck obtain DNS automatically and change the primary DNS to 8.8.8.8 under Advanced>>IPv4>>Internet connection type page and click save, then run the speedtest again and check whether it works.

 

Thanks a lot and let the community know if there is an update.
 

Recommended Solution
0
0
#11
Options
33 Reply
Re:Deco M5 - wifi very slow
2020-06-18 11:48:40 - last edited 2020-06-18 11:50:28

Same issues. Went through all sorts of support options. The system lasted 6 months before performance dropped off dramatically. Nothing has corrected the slow speeds. I will watch this space to see if you get any useful support options.

 

My hardwired speeds were 18 Mbps down and anywhere between 18 and 10 using the Deco app.  However wifi devices were getting between 0 and 2 Mbps down.

2
2
#2
Options
Re:Deco M5 - wifi very slow
2020-06-18 12:05:26

@Diccon  I've tried a few different systems including Google Nest Wifi and the Tenda M6.  Google went back as although the app was very slick and feature rich, it didn't increase the coverage in my house very much.  The Tenda was really good for coverage but the main unit failed and the supplier had no stock, so I went for the M5 system instead.  Coverage has been good but this drop in speed is a problem.  Hopefully someoine will come back with an answer or some things to try!

1
1
#3
Options
Re:Deco M5 - wifi very slow
2020-06-18 15:37:10

@Diccon just done a complete reset of the whole system back to factory defaults and set it up again - speeds are back to normal.  Hope I am not going to have to do this once a month as it's a complete ballache!

1
1
#4
Options
Re:Deco M5 - wifi very slow
2020-08-10 15:06:15
Complete reset sorted my issue for a while but now it's back. I'm going to do another reset tonight but looks like I may be sending another system back :-(
1
1
#5
Options
Re:Deco M5 - wifi very slow
2020-08-29 04:18:09

@rich0056 I also got the same issues, it was really good back then, but for this 1 month, the internet connection is drop dramastically, i called my ISP and they always said that everything is working fine. I think is it because a bug from the latest firmware maybe? But anyway please TP Link team, solve this issue. It's very frustating right now. Thank you.

0
0
#6
Options
Re:Deco M5 - wifi very slow
2020-08-30 19:35:15

@Big-Dream same problem here.. day 1 M5 user.. but the last few months wifi performance is dramatic!!! LAN speeds are ok.. but there is a HUGE delay in getting internet addresses it seems.wired all fine. Resetting everything's makes it ok for a few days.. then it becomes worse and worse again.. This is a real issue... Please conform this TPLink and FIX it!

Big-Dream wrote

@rich0056 I also got the same issues, it was really good back then, but for this 1 month, the internet connection is drop dramastically, i called my ISP and they always said that everything is working fine. I think is it because a bug from the latest firmware maybe? But anyway please TP Link team, solve this issue. It's very frustating right now. Thank you.

 

0
0
#7
Options
Re:Deco M5 - wifi very slow
2020-09-02 12:11:37

@MCage my system has gone slow again.  When I first set it up and then reset the whole system I was getting 100Mbps+ bit it's been getting progressively slower and is now down to around 3-4Mbps.  Checked direct on the router and it's 100Mbps+ so it's deffo a wifi issue.  Thinking i am going to return it as setting up all the parental controls etc is a pain!

0
0
#8
Options
Re:Deco M5 - wifi very slow
2020-09-02 12:30:52

@rich0056 I am facing the same issue, my ISP is telling me that everything is fine, I do tests directly with a wired connection and I have the speed that I contracted but the issue is in the WiFi. I tried restarting everything, turning de the Mesh function off, etc. I am really disappointed, TP-link needs to fix this issue ASAP @Kevin_Z My decos only have 6 months with me and I brought 4 of them. 

1
1
#9
Options
Re:Deco M5 - wifi very slow
2020-09-02 12:32:17 - last edited 2020-09-02 12:32:50
0
0
#10
Options
Re:Deco M5 - wifi very slow-Solution
2020-09-04 01:43:22 - last edited 2020-09-04 01:43:28

@ewakil12   @MCage   @Big-Dream 

 

Hello all, sorry to respond late.

 

Make sure you are tagging a TP-Link Admin next time if you want a timely response. Unless we are tagged we do not see that new responses have been added. We do not subscribe to every thread so rely on Tagging to ensure responses.

 

As for the speed issue you reported here, it seems that your Deco M5 units are working fine for months and suddenly drops to a very slow speed, we hope you could help confirm the below:

1. Please provide your detailed network diagram, how many Deco M5 do you have in total and how are they connected to each other, the main Deco is working as a router or an Access Point, etc.

2. Who is your internet service provider? And what's the bandwidth you pay for them? Please connect your computer to the ISP modem/router directly and test the speed you can get from it and show us a screenshot of the speed test result.

3. Then connect the ISP modem/router--the main Deco--the same computer,  run the speedtest again and confirm the speed again, show us the test result.

4. Connect a laptop or smartphone to the main Deco wireless network, test the wireless speed again, please verify it is connected to the 2.4GHz or 5GHz network and how about the link speed as below:

https://www.tp-link.com/support/faq/2265/

 

Besides, please uncheck obtain DNS automatically and change the primary DNS to 8.8.8.8 under Advanced>>IPv4>>Internet connection type page and click save, then run the speedtest again and check whether it works.

 

Thanks a lot and let the community know if there is an update.
 

Recommended Solution
0
0
#11
Options