KP105 Slim Smart Plug Can't Connect to Local Network (Solved)

KP105 Slim Smart Plug Can't Connect to Local Network (Solved)
KP105 Slim Smart Plug Can't Connect to Local Network (Solved)
2020-07-05 10:36:47 - last edited 2020-07-15 08:31:23

I'm posting here because I spent far too long trying to figure this one out, plus there seems to be a lack of support articles for the new KP105 Slim Smart Plug. Hopefully this will help people out.

 

Upon setting up the smart plugs it would always get stuck after I select my WIFI name and password, it would never connect. I tried many times, tweaks various settings on my router and nothing worked.

 

Turned out after finding this post: https://community.tp-link.com/en/home/forum/topic/199794 it was due to the security settings on my WIFI network.

 

You need to change the WIFI security settings on your 2.4GHz band from WPA2/WPA Mixed Personal to WPA2 Personal.

 

Stragely I have three HS100 plugs and they all worked fine, I even reset one to see if it would connect and it did, it was on the newest firmware too.

 

Anyway I hope this saves someone some time.

 

 

1
1
#1
Options
1 Accepted Solution
Re:KP105 Slim Smart Plug Can't Connect to Local Network (Solved)-Solution
2020-07-15 08:30:40 - last edited 2020-07-15 08:31:23

@joshkrz 

 

Hello, thanks so much for sharing the solutions. We will investigate to see if there is any known issue with the wireless security compatibility issue.

 

Good days.

Best Solution
0
0
#2
Options
1 Reply
Re:KP105 Slim Smart Plug Can't Connect to Local Network (Solved)-Solution
2020-07-15 08:30:40 - last edited 2020-07-15 08:31:23

@joshkrz 

 

Hello, thanks so much for sharing the solutions. We will investigate to see if there is any known issue with the wireless security compatibility issue.

 

Good days.

Best Solution
0
0
#2
Options