Problems with WDS

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Problems with WDS

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Problems with WDS
Problems with WDS
2020-07-11 20:58:38 - last edited 2020-12-11 03:40:31
Model: Archer C6  
Hardware Version: V2
Firmware Version: Archer C6(EU)_V2_200512

Hello,

 

I have the Archer C6 V2.

 

The other day, as my wifi connection was failing, I decided to reset it.

 

Now It is impossible for me to use WDS because they have removed the option to choose the WDS mode: auto, wds1, wds2.

 

I used this firmware:
Archer C6 (EU) _V2_200402

 

Then I found a new firmware: Archer C6 (EU) _V2_200512 on the Portugal website and I was still having the same problem.

I also tried another beta on the forum and it still has the same problem.

 

 

 

 

The only way to use the router is to connect it by lan cable to the operator router, but I need it to work wirelessly by WDS.

Neither have I been able with any firmware, get the network by WDS 5GHz only with WDS 2.4GHz.

 

 

 

With the old firmware the Archer C6 works well, but with the new firmware it is impossible to use it with WDS.

 

 

 

 

 

  1      
  1      
#1
Options
2 Accepted Solutions
Re:Problems with WDS-Solution
2020-07-12 19:17:51 - last edited 2020-12-11 03:40:31

I have got a solution.

 

I changed in the configuration of the main router, the 5GHz band from 80mhz to 40mhz.

 

I have the 2 bands of 2.4ghz and 5ghz at 40mhz. Before, it had 2.4ghz at 40mhz and 5ghz at 80mhz.

In the main router I have the Archer C6 5GHz mac inside the 5GHz band of the main router. And in the Archer C6 I have the WDS 2.4GHz active, taking the signal from the main router to the 2.4GHz network.

 

 

Archer C6:2.4GHz at 40MHz and 5GHz at 80MHz

 

I don't understand why this configuration works, I don't even have the Archer C6 2.4ghz band mac on my main router.

Recommended Solution
  0  
  0  
#2
Options
Re:Problems with WDS-Solution
2020-10-16 08:24:51 - last edited 2021-08-27 09:15:01

@Kevin_Z 

Hello, I tried to make it work all night and finally found the solution.

 

First of all, I do not have the access to the administration of main router. It is just so you know, I could not enable the capability to accept WDS with four address header. If there is any at all.

 

Now let me explain all the details:

 

1. The main router is some dual-band Compal provided by UPC (Now Vodafone in Czech republic)

2. Regardless of the firmware version, WDS Bridge with auto mode works on 2.4GHz but does not on 5GHz

3. WDS Bridge on 5GHz works only and only if wds mode is WDS1.

 

My solution was to use Chrome's DevTools to unhide the element selecting WDS mode and simply select it. Thanks for not removing it completely :)

 

For others: just remove "hidden" and "readonly" and the setting will show up. Please please @Kevin_Z , do not remove it completely. Thanks!

 

Recommended Solution
  5  
  5  
#5
Options
4 Reply
Re:Problems with WDS-Solution
2020-07-12 19:17:51 - last edited 2020-12-11 03:40:31

I have got a solution.

 

I changed in the configuration of the main router, the 5GHz band from 80mhz to 40mhz.

 

I have the 2 bands of 2.4ghz and 5ghz at 40mhz. Before, it had 2.4ghz at 40mhz and 5ghz at 80mhz.

In the main router I have the Archer C6 5GHz mac inside the 5GHz band of the main router. And in the Archer C6 I have the WDS 2.4GHz active, taking the signal from the main router to the 2.4GHz network.

 

 

Archer C6:2.4GHz at 40MHz and 5GHz at 80MHz

 

I don't understand why this configuration works, I don't even have the Archer C6 2.4ghz band mac on my main router.

Recommended Solution
  0  
  0  
#2
Options
Re:Problems with WDS
2020-10-16 03:22:20 - last edited 2020-10-16 03:33:10

@Dog01 

Bump this! 

TP-Link needs to know that we really need the explicit wds mode setting. Please!

 

In my specific conditions, the inability to set the WDS mode explicitly makes my C6 useless after the update. Dog01's solution won't work for me, I will have to downgrade. Thanks! (what is the chance of this being actually visible to some developer?) 

  0  
  0  
#3
Options
Re:Problems with WDS
2020-10-16 08:00:47

@Santomet   @Dog01 

 

Hello all, sorry that we didn't pick up this post.

 

Do you remember which WDS mode did you use on the older 200402 version, WDS1 or WDS2? 

 

What is the model number of your host Wi-Fi router, is it also dual-band? 

 

When you updated the firmware, did you try to reconfigure the WDS and re-associate it with the host router?

VPN Survey for Routers | Allow us to Understand Your VPN Service Requirements.
  0  
  0  
#4
Options
Re:Problems with WDS-Solution
2020-10-16 08:24:51 - last edited 2021-08-27 09:15:01

@Kevin_Z 

Hello, I tried to make it work all night and finally found the solution.

 

First of all, I do not have the access to the administration of main router. It is just so you know, I could not enable the capability to accept WDS with four address header. If there is any at all.

 

Now let me explain all the details:

 

1. The main router is some dual-band Compal provided by UPC (Now Vodafone in Czech republic)

2. Regardless of the firmware version, WDS Bridge with auto mode works on 2.4GHz but does not on 5GHz

3. WDS Bridge on 5GHz works only and only if wds mode is WDS1.

 

My solution was to use Chrome's DevTools to unhide the element selecting WDS mode and simply select it. Thanks for not removing it completely :)

 

For others: just remove "hidden" and "readonly" and the setting will show up. Please please @Kevin_Z , do not remove it completely. Thanks!

 

Recommended Solution
  5  
  5  
#5
Options

Information

Helpful: 1

Views: 1668

Replies: 4

Related Articles