iPad connects to TL-WA854RE but no internet

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
iPad connects to TL-WA854RE but no internet
iPad connects to TL-WA854RE but no internet
2020-07-23 12:46:31 - last edited 2020-07-28 06:58:30
Model:Adapter
Hardware Version:
Firmware Version:

I have configured a TL-WA854RE adapter to support a Smart-TV, as the main router is behind dense walls. It works fine, streaming vieo from the internet works and the link is stable. I wanted to use the same extender to support an iPAD, so configured it with the <SSID>_EXT network name and correct password. The iPAD connects fine, but will not browse the Internet. It has obtained the correct IP address/mask/default gateway from DHCP, and the DNS server configuration looks correct.

 

I've seen a number of mentions in various fora, stating that the DNS configuration needs to be static, rather than DHCP. However, that seems illogical: the DNS specification gained by DHCP is right, setting it as static will not change function.

 

This is being done for a neighbour, so I don't have unlimited access, but if there is further info needed, let me know and I'll get it

 

Thanks

 

Jim

0
0
#1
Options
1 Accepted Solution
Re:iPad connects to TL-WA854RE but no internet-Solution
2020-07-28 06:56:05 - last edited 2020-07-28 06:58:30

Hi Guys,

 

The original situation was that the extender worked OK for a smart TV (Android), windows 10 Laptops, and android phones. The problems only occurrecd when I tried to connect with an iPad. In this event, the iPad apparently connected, but no internet access was possible.

 

This was tested with the only apple device available on site, and that device was rebooted and reconnected several times with the same results...association with the extender's SSID, but no Internet access.

 

Yesterday, I went back, with another apple iPad, and found that the new device connected perfectly.

 

I deduced that the problem was with the original iPad client, so not being as comfortable with iPads as I am with Windows and Android, I first gathered things like the S/W and H/W versions of the extender and its logs. to start my diagnostic efforts. All looked fine, no errors. I then went back to the original iPad, the one that didn't connect to the internet.

 

Something must have changed, though nothing I can specify, because yesterday, it connected and ran fine...there was no error.

 

Thanks for all the interest, and sorry to have sent you all on a wild goose chase :(

 

Jim

Recommended Solution
0
0
#5
Options
4 Reply
Re:iPad connects to TL-WA854RE but no internet
2020-07-24 08:48:09

@Jimbo54 

Hello,

 

May I know how many extenders did you have?

 

If the extender has no internet access after the configuration, please check the RE light or signal Led on the extender. Please according to the light status on the TL-WA854RE, then find the correct case in this article to do the troubleshooting:https://www.tp-link.com/en/support/faq/2234/

 

Note: When checking the router's wifi password, please also confirm that the authentication type and encryption type is Auto on the main router.

 

If still no Internet, please help us confirm some information:


1. What are the Led Staus on RE after setup? Please let us know the troubleshooting steps you have tried in details, thank you!
2. The model number of the main router? 
3. After configuration, please log in to RE's web page and send us a photo of the Status page, wait for 3-5 mins, save the system log and send us the log file.(System tools-> system log)

4. After configuration, please connect a computer to RE, check the IP and gateway address and send us a photo: https://www.tp-link.com/en/support/faq/838/
5. Please connect the same computer to the main router, check the IP and gateway address and send us a photo 
6. The firmware and hardware version of TL-WA854RE: https://www.tp-link.com/en/support/faq/315/

And upgrade the firmware for your range extender referring to FAQ below: https://www.tp-link.com/en/support/faq/1406/

7. May I know how long do you have this TL-WA854RE and when did the issue start? 

 

May it help and have a nice day!

0
0
#2
Options
Re:iPad connects to TL-WA854RE but no internet
2020-07-24 12:08:59

@Solla-topee 

 

Fairly basic diagnostics so far, because of limited access (it's in my friend/neighbour's house).

There is a single BT router on site, providing xDSL access via FTTC. This is working correctly: the iPad and other devices like my PC, and my Android phone connect to the SSID no problems (PSK-WPA2 personal).

 

The extender (one single extender) has been configured as instructed in the "Getting Started" paperwork, and is supporting a smart TV (streaming Amazon Plus), my laptop, and my Android phone. Speedtest works fine on all these, giving speed readings as expected.

 

When the iPad attempts to connect to the extender, it gets a stable connection, but when browsing is attempted, the sites are not accessible.

 

The DHCP configuration of the iPad is the same, whether gained from the main router or the extender (this appears true of all devices).

 

So, in simple terms, everything works as expected but I can't get Internet access on the iPad, despite having a connection.

 

I'll do some more digging, to answer your other questions....bear with me, I've got restricted access

 

Thanks for your help so far

 

Jim

0
0
#3
Options
Re:iPad connects to TL-WA854RE but no internet
2020-07-28 03:40:42

@Jimbo54 

Hi, only this iPad connects the extender but has no internet, right?

All other wireless devices connect the extender, and they can get internet, right?

 

Can your iPad connect the main router's network to get internet? Please connect the main router's network on the iPad and try to open YouTube or Facebook etc to check if the internet is working fine.

Are there any special settings such as parental control you have set up on the router or extender?

 

Can you check the IP address on your iPad when it connects the extender's Wi-Fi?

Can you tell me the model number, system information of the iPad? 

 

BTW, have you tried to contact iPad's support to check if they have some suggestions?

Look forward to your reply.

Have a nice day!

0
0
#4
Options
Re:iPad connects to TL-WA854RE but no internet-Solution
2020-07-28 06:56:05 - last edited 2020-07-28 06:58:30

Hi Guys,

 

The original situation was that the extender worked OK for a smart TV (Android), windows 10 Laptops, and android phones. The problems only occurrecd when I tried to connect with an iPad. In this event, the iPad apparently connected, but no internet access was possible.

 

This was tested with the only apple device available on site, and that device was rebooted and reconnected several times with the same results...association with the extender's SSID, but no Internet access.

 

Yesterday, I went back, with another apple iPad, and found that the new device connected perfectly.

 

I deduced that the problem was with the original iPad client, so not being as comfortable with iPads as I am with Windows and Android, I first gathered things like the S/W and H/W versions of the extender and its logs. to start my diagnostic efforts. All looked fine, no errors. I then went back to the original iPad, the one that didn't connect to the internet.

 

Something must have changed, though nothing I can specify, because yesterday, it connected and ran fine...there was no error.

 

Thanks for all the interest, and sorry to have sent you all on a wild goose chase :(

 

Jim

Recommended Solution
0
0
#5
Options