Archer C80 AC1900 post firmware update issue

Archer C80 AC1900 post firmware update issue
Archer C80 AC1900 post firmware update issue
2020-07-30 16:49:01 - last edited 2020-09-14 07:29:33
Hardware Version: V1
Firmware Version:

Hi all.

 

I received firmware update notification on my tether app and i did the upgrade.

 

One thing i notice from this router, the power LED indicator is blinking. Fast. Other lamps are green and not blinking. User guide mentioned it's indicating the update is on going.

 

I've waited for more than 1 hour but nothing happened. The power lamp is still flashing.

 

Any help me with the issue?

 

Regards

Sam

0
0
#1
Options
1 Accepted Solution
Re:Archer C80 AC1900 post firmware update issue-Solution
2020-09-14 07:27:31 - last edited 2020-09-14 07:29:33

@SriV 

 

Hello,

 

It is suggested to try the firmware recovery to reinstall the latest firmware on your Archer C80:

https://www.tp-link.com/support/faq/1482/

 

May it help.

Best Solution
0
0
#5
Options
4 Replies
Re:Archer C80 AC1900 post firmware update issue
2020-07-31 02:29:09

@Samghong 

Update for this case: i left it over night and when i wake up this mornong, it still flashing and i can not connect to internet.

 

Please help.

0
0
#2
Options
Re:Archer C80 AC1900 post firmware update issue
2020-08-09 11:04:59

@Samghong 

 

I had the same issue with my Archer C80. After a firmware update, the router would not load. All status lights were green but the power button was flashing green.

 

I used this method - https://www.tp-link.com/ca/support/faq/1482/

 

the Archer C80 has built in firmware recovery. I was able to connect the router directly to my PC and reinstall the firmware

0
0
#3
Options
Re:Archer C80 AC1900 post firmware update issue
2020-09-14 07:00:51

@IM23 

Hi,

 

Have you tried this procedue and did it solve ur problem? I too am facing the same issue and search for the ways to fix it. Support is not reachable to ask for direction

0
0
#4
Options
Re:Archer C80 AC1900 post firmware update issue-Solution
2020-09-14 07:27:31 - last edited 2020-09-14 07:29:33

@SriV 

 

Hello,

 

It is suggested to try the firmware recovery to reinstall the latest firmware on your Archer C80:

https://www.tp-link.com/support/faq/1482/

 

May it help.

Best Solution
0
0
#5
Options