Archer C50 - No connection to internet on guest network

Archer C50 - No connection to internet on guest network
Archer C50 - No connection to internet on guest network
2020-08-07 21:52:23 - last edited 2020-08-10 08:28:24
Model: AC50
Hardware Version: V3
Firmware Version: 0.9.1 0.6 v0079.0 Build 180703 Rel.59065n(4555)

Hello,

in my home network I have 2 routers:

  • main router is older TL-WR1043ND  ( Firmware Version: 3.17.38 Build 140613 Rel.55867n   , Hardware Version: WR1043 v2 00000000), using as main due 10/100/1000Mbps LAN ports , has no oportunity to set guest network
  • second router is Archer C50 V3 (Firmware Version:   0.9.1 0.6 v0079.0 Build 180703 Rel.59065n(4555)  , Hardware Version:  Archer C50 v3 00000001).

 

Second router C50 is connected to main router LAN-To-LAN schema, DHCP is OFF, configure by How to configure TP-Link Router

C50 is in operation mode: Wireless router.

 

Whan I set guest network on C50, configurated n picture , i can connect to guest network, but I have no access to internet.

To get internet connection, i have to set " Allow Guests To Access My Local Network " to Enabled.

But by this setting guests can get in my private NAS/file server...And I don't want my guests could do it.

Firmware on my C50 is latest.

 

Can You help me set correct guest network , so my guests not to get in my private network ?

It is a problem, that DHCP on second router (C50) is OFF (read on this forum) , or it is a bug ?

 

Best regards,

DM02

 

 

 

 

 

0
0
#1
Options
1 Accepted Solution
Re:Archer C50 - No connection to internet on guest network-Solution
2020-08-10 06:37:19 - last edited 2020-08-10 08:28:24

@DM02 

 

Hello,

 

In your case, it is suggested to set the C50 as the main router and the WR1043N as the Access Point, then enable the Guest Network on the C50 to give it a go.

 

Below is the guide to configure the WR1043N as an Access Point:

https://www.tp-link.com/support/faq/1384/

 

May it helps.

 

Recommended Solution
0
0
#2
Options
3 Reply
Re:Archer C50 - No connection to internet on guest network-Solution
2020-08-10 06:37:19 - last edited 2020-08-10 08:28:24

@DM02 

 

Hello,

 

In your case, it is suggested to set the C50 as the main router and the WR1043N as the Access Point, then enable the Guest Network on the C50 to give it a go.

 

Below is the guide to configure the WR1043N as an Access Point:

https://www.tp-link.com/support/faq/1384/

 

May it helps.

 

Recommended Solution
0
0
#2
Options
Re:Archer C50 - No connection to internet on guest network
2020-08-10 07:46:00

@Kevin_Z 

Hello,

thx for answer but it is not possible for me...

Reasons:

  • main (older) router WR1043N  has GLAN ports, but C50 only 100M ports for internal LAN
  • routers are placed on different places at house due to the coverage of the whole house. If I changed routers, my wired LAN would be only 100M instead GLAN.

Best regards,

DM02

 

 

0
0
#3
Options
Re:Archer C50 - No connection to internet on guest network
2020-08-10 08:28:11

@DM02 

 

I see. If this is the case, I'm afraid we don't have other workarounds for you, as the Guest Network cannot be separated from the main network.

 

Good days.

0
0
#4
Options