Need advice on Deco E4 Unit

Need advice on Deco E4 Unit
Need advice on Deco E4 Unit
2020-08-08 05:14:30 - last edited 2020-08-11 05:36:33
Model: Deco E4
Hardware Version:
Firmware Version:

Hi TP-Link community! 

I would just like advice on my Deco E4 unit. It was working well as the main deco when I first bought it. But after a few weeks, the LED light began blinking white. It was unable to be detected by the app. It never changes color. It is always blinking white whenever I plug it in. And take note, this is not the same type of blinking that indicates firmware update as I have seen that on my other deco units. The firmware update blinking is like a slow pulse.
My malfunctioning deco unit shows a fast white pulse. 

 

I have tried plugging it again using an ethernet cable as the main deco but since the LED never turns blue, it is never detected by my app. I have tried resetting it many times. I have tried letting it rest overnight and plugging it again the next day. Nothing works. Hopefully, this is something that can still be fixed or someone might have gone through something similar? Please let me know. Thank you in advance!

0
0
#1
Options
1 Accepted Solution
Re:Need advice on Deco E4 Unit-Solution
2020-08-11 05:36:28 - last edited 2020-08-11 05:36:33

@gary12345 

 

Hi,

Do you still use the original power adapter? Was there any power cut or bad weather or firmware upgrading before it starts to behave like that? 

Try one more time to hard reset it by holding the reset button or hole.

When and where did you buy this also? If nothing can make it work correctly, you may need to contact the local tech support to check the warranty cause the device seems faulty:
https://www.tp-link.com/en/support/contact-technical-support/#Hotline-Support 

 

Good day. 

Recommended Solution
0
0
#2
Options
2 Reply
Re:Need advice on Deco E4 Unit-Solution
2020-08-11 05:36:28 - last edited 2020-08-11 05:36:33

@gary12345 

 

Hi,

Do you still use the original power adapter? Was there any power cut or bad weather or firmware upgrading before it starts to behave like that? 

Try one more time to hard reset it by holding the reset button or hole.

When and where did you buy this also? If nothing can make it work correctly, you may need to contact the local tech support to check the warranty cause the device seems faulty:
https://www.tp-link.com/en/support/contact-technical-support/#Hotline-Support 

 

Good day. 

Recommended Solution
0
0
#2
Options
Re:Need advice on Deco E4 Unit
2020-08-11 05:37:06

@gary12345 

 

Hi,

Do you still use the original power adapter? Was there any power cut or bad weather or firmware upgrading before it starts to behave like that? 

Try one more time to hard reset it by holding the reset button or hole.

When and where did you buy this also? If nothing can make it work correctly, you may need to contact the local tech support to check the warranty cause the device seems faulty:
https://www.tp-link.com/en/support/contact-technical-support/#Hotline-Support 

 

Good day. 

0
0
#3
Options