Archer C50 5Ghz network not showing

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C50 5Ghz network not showing

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C50 5Ghz network not showing
Archer C50 5Ghz network not showing
2020-08-12 10:39:05 - last edited 2020-08-14 06:31:56
Model: Archer C50  
Hardware Version: V4
Firmware Version: 0.9.1 0.2 v0093.0

Yesterday i bought Archer C50 Ac1200 wifi router, but it is not showing the 5Ghz channel, but 2.4Ghz is visible and im able to connect in my android smartphone.

I turned on both the 2.4Ghz and 5Ghz bands, but only 2.4Ghz wifi is visible. is this router faulty? please help.

  0      
  0      
#1
Options
1 Accepted Solution
Re:Archer C50 5Ghz network not showing-Solution
2020-08-14 06:31:51 - last edited 2020-08-14 06:31:56

@Arunraj 

 

Hello,

 

Please show us the hardware version of your C50 underneath the device, is it an EU version or US version? Please also ensure its firmware is up-to-date as per the hardware.

 

If no devices can detect the 5G signal, please try to change the 5G channel to different ones and confirm.

 

BTW, if your C50 is an EU version, it only supports band 1 (channel 36//40/44) for the 5GHz, which is designed to comply with that of CE regulation. Please confirm if your android smartphone also supports 5G band 1.

 

Good day.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
Recommended Solution
  0  
  0  
#2
Options
1 Reply
Re:Archer C50 5Ghz network not showing-Solution
2020-08-14 06:31:51 - last edited 2020-08-14 06:31:56

@Arunraj 

 

Hello,

 

Please show us the hardware version of your C50 underneath the device, is it an EU version or US version? Please also ensure its firmware is up-to-date as per the hardware.

 

If no devices can detect the 5G signal, please try to change the 5G channel to different ones and confirm.

 

BTW, if your C50 is an EU version, it only supports band 1 (channel 36//40/44) for the 5GHz, which is designed to comply with that of CE regulation. Please confirm if your android smartphone also supports 5G band 1.

 

Good day.

If you found a post or response helpful, please click Helpful (arrow pointing upward icon). If you are the author of a topic, remember to mark a helpful reply as the "Recommended Solution" (star icon) so that others can benefit from it.
Recommended Solution
  0  
  0  
#2
Options

Information

Helpful: 0

Views: 1844

Replies: 1

Related Articles