Archer C6 2.4GHz latency, packet loss problems

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Archer C6 2.4GHz latency, packet loss problems

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Archer C6 2.4GHz latency, packet loss problems
Archer C6 2.4GHz latency, packet loss problems
2020-08-16 10:20:12
Model: Archer C6  
Hardware Version: V2
Firmware Version: 1.3.5

Hello everyone!

This is my first time testing network equipment. My home network layout is as shown below:

Did not check what firmware the Archers came with. Updated all to 1.3.4 due to the 2.4Ghz channel being stuck on 5. On 1.3.4, when all 3 2.4Ghz networks were online (with guest networks also online), I could induce packet losses and latency spikes for all devices connected to the network by loading the network using 1 device – just browsing through a news feed or social media from my phone really fast. The devices use the same SSID and password. From the monitoring device, it looked like this:

Wifi signals at the monitoring device looked like:

Disabling one of the networks resulted in a reduction of packet losses and latency spikes, but they were still present (here r0 and f0 are active, f1 disabled):

Just running 1 network, packet losses and latency problems were reduced further, but didn’t go away (only r0 active):

So I upgraded firmware for all three to 1.3.5. Stability improved dramatically and packet losses and latency spikes have gone down with the three networks active. However, if I go to the edge of the network and load it, there are spikes in packet losses and latency:

This is not normal behaviour right? How do I fix this? The devices are all brand new and still under warranty.

  0      
  0      
#1
Options
25 Reply
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-19 07:56:32 - last edited 2020-08-19 12:37:05

Update: Not only at the edge of the network. Packet losses on the monitoring device can be induced from anywhere in the network.

 

Someone please help with this. @Kevin_Z @TP-Link 

  0  
  0  
#2
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-19 08:36:34
Check out 1.3.7 Beta. Up to 1.2.1 the wifi worked fine, then only in Beta. I lost link to 1.3.7, you have to search on forum. I had much bigger problems with wifi at 5ghz
  0  
  0  
#3
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-19 08:50:51

@nemesis9 https://static.tp-link.com/2020/202007/20200723/ArcherC6v2_eu-up-ver1-3-7-P1%5b20200723-rel33309%5d.zip

 

Apparently they are working on a new firmware, it will be possible to disable onemesh, which causes problems for some users. I do not know if it's true.

  0  
  0  
#4
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-19 12:17:51 - last edited 2020-08-19 12:38:18

I would rather not flash beta firmware without getting a heads up from TP-Link. Would doing this void warranty?

 

Also, it is to be noted the devices are all at the same physical location right now for config and testing. They will be moved to different floors later. Will physical proximity affect signal quality even though the channels are well separated?

 

I'm curious, how do you broadcast a main WLAN, guest WLAN and a hidden OneMesh SSID from the same physical antenna?

 

I have not tested the 5GHz network yet as I dont have PCs with 5Ghz WLAN cards. Will do this soon.

 

OneMesh is pretty useless for me; an option to turn these hidden SSIDs is quite necessary. And ethernet backhaul would be a godsend if included. The firmware situation right now is a joke.

  0  
  0  
#5
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-21 03:27:41

@nemesis9 

 

Hello, thanks very much for all the detailed tests.

 

May I know what does it mean "if I go to the edge of the network and load it, there are spikes in packet losses and latency", do you mean you are testing the 2.4G network far away from the wireless? How about the RSSI at that time?

  0  
  0  
#6
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-21 07:38:55

@Kevin_Z 

 

I take a phone and a laptop (loading devices) to a place where the signal strength is low. 

 

Signal at my phone:

 

 

Signal at my laptop:

 

 

The monitoring device is at a location close to the router where the signal looks like:

 

 

Now when I load the network from the loading devices - play videos, browse feeds, I get packet losses in the connection between the monitoring device and the router:

 

 

This is not normal behaviour right? I expect low speeds at the loading devices but packet looses across the network are not supposed to happen right?

 

This is not completely limited to the low signal regions, happens occasionally well within the network.

  0  
  0  
#7
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-26 01:08:23

@nemesis9 

 

Hello, thanks for all the details.

 

Our engineer will email you, if you are willing to do further analysis, please check your inbox and respond.

                     

Thanks for your cooperation and support. Good day.

  0  
  0  
#8
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-29 11:40:24

 

@Kevin_Z  @TP-Link 

 

I'm in contact with him and will update things here once the issue is solved.

 

Update: Turnaround times are abyssmal. I have still not received any clarification regarding the issue. It has been 3 days and no reply.

 

Also, can you give me Speed vs RSSI data for Archer C6 - both 2.4 GHz and 5 GHz for verification?

  0  
  0  
#11
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-30 05:57:24

@nemesis9 

 

HI may I please know which software you have used to identify packet loss issue .? ty

  0  
  0  
#12
Options
Re:Archer C6 2.4GHz latency, packet loss problems
2020-08-30 06:02:15

@oldman22 Pingplotter

  0  
  0  
#13
Options

Information

Helpful: 0

Views: 5569

Replies: 25