Low speed on 2.4ghz

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.

Low speed on 2.4ghz

This thread has been locked for further replies. You can start a new thread to share your ideas or ask questions.
Low speed on 2.4ghz
Low speed on 2.4ghz
2020-10-20 18:35:00 - last edited 2020-11-20 05:54:19
Model: Archer A6  
Hardware Version: V3
Firmware Version: 1.0.2 Build 20200807 rel.59334(5553)

Hii, i just received my Archer A6 router today, 

Before that I was using Tenda N150 as my primary router, which is 2.4ghz

My internet plan is 100mbps, out of which i got 90-93mbps on wifi,directly in front of the router or 65 mbps + on a floor below. 

I bought A6 to cover my whole home assuming speed would be same on 2.4ghz (factoring in the distancing ftom the router it will be low obviously) , but on 2.4ghz band on the A6, I get only 40-50mbps even if i stand just in front of the router. 5ghz is fine with 97 98mbps but that has a low range. 

I would be fine even if i got 75+ on the 2.4Ghz band,is my router faulty or this model works this way? Should I get it replaced? 

I have the US version of A6

I am on the latest firmware available. 

  0      
  0      
#1
Options
1 Accepted Solution
Re:Low speed on 2.4ghz -Solution
2020-11-19 13:56:49 - last edited 2020-11-20 05:54:19

@Vasudev I solved it, turn smart connect off, set the channel width on 2.4Ghz to 40mhz. U can use the same name for both networks, but it will break again if u turn smart connect on since it resets Network settings to auto. Setting the same name works kinda like smart connect but your phone does the switching not the router, so when you get out of 5ghz range it connects to 2.4Ghz automatically, but when u come into 5ghz range again, u need to turn wifi off n on on ur phone to reconnect to 5ghz,since it keeps connected to 2.4ghz. 

 

TP link shld solve this through a firmware update, the auto option shld switch to 40ghz on its own

Recommended Solution
  3  
  3  
#3
Options
7 Reply
Re:Low speed on 2.4ghz
2020-11-19 05:30:16

@Ken_Kaneki Even I am facing this exact same issue on my Archer A6 V3 with the firmware 1.0.2 Build 20200807 rel.59334. I really hope TP-Link releases a fix for it. 

  0  
  0  
#2
Options
Re:Low speed on 2.4ghz -Solution
2020-11-19 13:56:49 - last edited 2020-11-20 05:54:19

@Vasudev I solved it, turn smart connect off, set the channel width on 2.4Ghz to 40mhz. U can use the same name for both networks, but it will break again if u turn smart connect on since it resets Network settings to auto. Setting the same name works kinda like smart connect but your phone does the switching not the router, so when you get out of 5ghz range it connects to 2.4Ghz automatically, but when u come into 5ghz range again, u need to turn wifi off n on on ur phone to reconnect to 5ghz,since it keeps connected to 2.4ghz. 

 

TP link shld solve this through a firmware update, the auto option shld switch to 40ghz on its own

Recommended Solution
  3  
  3  
#3
Options
Re:Low speed on 2.4ghz
2020-11-19 16:57:00

@Ken_Kaneki Yess. It got fixed. But with my earlier router the shift from 20Mhz to 40Mhz happens automatically whereas in Archer A6, it is always in 20Mhz if put in Auto mode unless it is manually changed to 40Mhz. Also, one thing I noticed in 40Mhz is that even though the speed increases, when the distance from the router increases it is leading to high packet loss and network quality degradation. TP-Link should really work on the firmware or they are gonna end up loosing customers. Due to frequent network interruptions I had to return my C6 and get A6 V3 but still this too has a lot of bugs in firmware. 

  0  
  0  
#4
Options
Re:Low speed on 2.4ghz
2020-11-20 05:56:09

@Ken_Kaneki 

 

Hello, thank you both for sharing valued information with the community.

 

It's glad to know that the issue is currently resolved by disabling the Smart Connect on the A6 and choose manually 40MHz for the 2.4GHz network, we will soon report this to the engineers and ask them to evaluate then improve it.

 

Thanks a lot.

  1  
  1  
#5
Options
Re:Low speed on 2.4ghz
2020-11-21 11:22:56 - last edited 2020-11-21 11:24:34

@Kevin_Z When in 40Mhz, even if the devices are moved away by a few metres, there is a high packet loss. Also please release a firmware with an option to disable the Onemesh. Also, while booting, it takes a long time for the Pppoe to get connected. It almost takes 6 mins for the Internet light to turn green from orange. 

  0  
  0  
#6
Options
Re:Low speed on 2.4ghz
2020-11-23 06:03:29

@Vasudev 

 

Thanks for suggesting, there will be an official firmware to disable the Onemesh on the C6 router, please kindly wait and pay your attention on your router firmware as well as on the official website.

  0  
  0  
#7
Options
Re:Low speed on 2.4ghz
2020-11-23 06:06:20

@Kevin_Z Not C6. I'm talking about Archer A6 V3 (US). Current three things need to be fixed :

1. The band does not change to 40Mhz on 2.4ghz automatically when put in Auto Mode. So the link speed is only 72mbps when put in Auto. 

 

2. There should be an option to disable Onemesh. 

 

3. The Pppoe connection takes a lot of time to establish. It takes around 6 mins for the Internet light to turn green from orange. 

  0  
  0  
#8
Options

Information

Helpful: 0

Views: 1405

Replies: 7

Related Articles