Deco M5 Slow Download Speed on web beowsers

Deco M5 Slow Download Speed on web beowsers
Deco M5 Slow Download Speed on web beowsers
2020-10-28 17:44:32 - last edited 2020-10-29 06:21:38
Model: Deco M5
Hardware Version: V3
Firmware Version: 1.4.9 Build 20200924 Rel. 60170

So i recently went from a normal WiFi router to this mesh system, i've been downloading alot of files and it takes forever to download a mere 9mb file.
It took 10 minutes to download a 9MB file with a speed off 10-15kbps, when i tested the speed in speedtest.net, i got 70mbps download and 100mbps upload.

Tried downloadiing with Chrome, Microsoft Edge and Opera.

0
0
#1
Options
1 Accepted Solution
Re:Deco M5 Slow Download Speed on web beowsers-Solution
2020-10-29 06:21:34 - last edited 2020-10-29 06:21:38

@Ioqid 

 

Hello, thanks for reaching out. Please help confirm the below details, and we will try to figure it out:

1. What is the current network topology/layout? How many Deco M5s do you have in total? How are they connected?
2. When you downloaded a file from the computer, was it connected to the 5GHz or 2.4GHz? Please check the wireless link speed on it. There might be a difference between the speed tested on the Deco app and the actual speed tested on a client, you may refer to the below link for more details:
https://www.tp-link.com/support/faq/1865/
3. Please connect the same computer to the ISP modem directly and test the download speed you can get from it to do a simple comparison.

4. Please refer to the below troubleshooting to check the QoS settings on the Deco app and ensure it is on the Standard mode:
https://www.tp-link.com/en/support/faq/2429/#case%201 (Case 1)

5. If this doesn't work, please try with different cat6 or cat7 cables between the modem and Deco, then check how it goes.

Recommended Solution
0
0
#2
Options
1 Reply
Re:Deco M5 Slow Download Speed on web beowsers-Solution
2020-10-29 06:21:34 - last edited 2020-10-29 06:21:38

@Ioqid 

 

Hello, thanks for reaching out. Please help confirm the below details, and we will try to figure it out:

1. What is the current network topology/layout? How many Deco M5s do you have in total? How are they connected?
2. When you downloaded a file from the computer, was it connected to the 5GHz or 2.4GHz? Please check the wireless link speed on it. There might be a difference between the speed tested on the Deco app and the actual speed tested on a client, you may refer to the below link for more details:
https://www.tp-link.com/support/faq/1865/
3. Please connect the same computer to the ISP modem directly and test the download speed you can get from it to do a simple comparison.

4. Please refer to the below troubleshooting to check the QoS settings on the Deco app and ensure it is on the Standard mode:
https://www.tp-link.com/en/support/faq/2429/#case%201 (Case 1)

5. If this doesn't work, please try with different cat6 or cat7 cables between the modem and Deco, then check how it goes.

Recommended Solution
0
0
#2
Options
Related Articles