TP-Link Archer T2U Nano AC600 adapter - No light and not detected

TP-Link Archer T2U Nano AC600 adapter - No light and not detected
TP-Link Archer T2U Nano AC600 adapter - No light and not detected
2020-11-06 12:52:27 - last edited 2020-11-12 05:53:23
Model:Adapter
Hardware Version:
Firmware Version:

I bought TP-Link Archer T2U Nano AC600 Wireless USB Adapter one month back. It was working fine and all good.

Suddenly one day now it is showing no flashing light as earlier and also it is not detected by windows 10.

 

I tried installing the drivers again but once it starts installation it tries to detects adapter but windows now can not find the adapter.

 

Also no light is showing in the adapter now , it seems hardware porblem.

 

Any suggestions for fix? or it needs to be replaced?

0
0
#1
Options
1 Accepted Solution
Re:TP-Link Archer T2U Nano AC600 adapter - No light and not detected-Solution
2020-11-12 05:53:18 - last edited 2020-11-12 05:53:23

@Anadi 

Good day,

Thank you very much for your time and patience.

Sorry for the delay.

May I know where are you located?

Could you please check if there is any adapter under the device manager, such as https://www.tp-link.com/support/faq/284/ ?

Have you tried another USB port and please also try to update the BIOS to be the latest one;

If possible, could you please test the adapter on another computer before the final warranty service?

 

Thanks a lot.

Recommended Solution
0
0
#2
Options
5 Reply
Re:TP-Link Archer T2U Nano AC600 adapter - No light and not detected-Solution
2020-11-12 05:53:18 - last edited 2020-11-12 05:53:23

@Anadi 

Good day,

Thank you very much for your time and patience.

Sorry for the delay.

May I know where are you located?

Could you please check if there is any adapter under the device manager, such as https://www.tp-link.com/support/faq/284/ ?

Have you tried another USB port and please also try to update the BIOS to be the latest one;

If possible, could you please test the adapter on another computer before the final warranty service?

 

Thanks a lot.

Recommended Solution
0
0
#2
Options
Re:TP-Link Archer T2U Nano AC600 adapter - No light and not detected
2020-11-26 05:20:57

Hello,

 

Just an update ..the adapter was faulty . I sent it to service center and they have agreed to replace the same. 

 

Thanks,

Anadi

0
0
#3
Options
Re:TP-Link Archer T2U Nano AC600 adapter - No light and not detected
2020-11-26 08:07:45

@Anadi 

 

Thank you very much for your kind update. I hope you will receive the replacement soon, good day.

0
0
#4
Options
Re:TP-Link Archer T2U Nano AC600 adapter - No light and not detected
2021-01-24 12:49:49
I have exactly the same problem. Was working fine, now no light tried all steps above and still no joy or light/detection in device manager. Tried 2 machines also. Im in the UK, how do I get this replaced under warranty?
0
0
#5
Options
Re:TP-Link Archer T2U Nano AC600 adapter - No light and not detected
2021-01-26 08:10:54

@mtwo 

 

Hello, if the adapter cannot be detected by any PC in any port, please request a replacement as per the local warranty policy:

https://www.tp-link.com/support/faq/2602/

0
0
#6
Options