Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update

Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2020-12-16 11:17:13 - last edited 2021-01-13 07:59:43
Model: Deco M5
Hardware Version: V3
Firmware Version: 1.5.1 Build 20201022 Rel.66804

I just updated the firmware for my Deco M5 V3 to the latest firmware and ever since it's had a lot of difficulty connecting to the main Deco unit. With the previous firmware this has been working seamlessly for the past 6 months. I tried setting it to Access Point mode and had the same issues. 

I've also noticed that the internet speed it transmits to my room is now much slower than before. Is this a problem with the internet provider or do I need to completely reset my entire mesh network to fix it? 

Thanks! 

0
0
#1
Options
7 Replies
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2020-12-20 21:11:48

@heyyoumattyu 

keen to follow this thread or see if TP-Link have an answer. i have exact same issue, i have 3 M5 units in the house. updated to 1.5.1 build 20201022 and since then throughput speeds have ground to a halt

rebooted several times and still same issue

0
0
#2
Options
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2020-12-22 11:01:26 - last edited 2020-12-22 11:12:44

@heyyoumattyu 

Good day,

Could you please help me check the following information:

1. Would the satellite Decos become red when they failed to connect the main Deco?

2. How are these 3 Decos connected to each other?---it would be highly appreciated that you could provide us a diagram of the Decos and the distance in between?

3. Have you tried to reset the whole system and set up again to see if that helped?

Thank you very much.

0
0
#3
Options
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2021-01-05 08:42:57 - last edited 2021-01-05 08:43:56

@TP-Link 

1. Would the satellite Decos become red when they failed to connect the main Deco?
Yes, the satellite Deco turns red every 5 minutes or so which didn't use to be a problem. I've swapped Decos to see if a specific unit was the issue but same problem happens especially in peak usage. It doesn't happen at all at night. 
 

2. How are these 3 Decos connected to each other?---it would be highly appreciated that you could provide us a diagram of the Decos and the distance in between?
Main Deco is connected to the router. 1st Satellite Deco is about 5 meters away but with a wall blocking it. 2nd Satellite Deco is 1 floor up but only about 7 meters away from the Main Deco. It has been connected that way for the past 6 months without issue. It only started after the latest update which I did last December 2020.  

Here's more or less a diagram: 

 

3. Have you tried to reset the whole system and set up again to see if that helped?
Yes I've tried to reset every Deco and the entire system but the speeds and the range haven't returned to their original settings.

0
0
#4
Options
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2021-01-12 21:09:03

@heyyoumattyu Hello - did you manage to resolve this problem?  I am having exactly the same problem after exactly the same firmware update.  The setup of my decos is also very similar to yours.

 

Thanks.

0
0
#5
Options
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2021-01-12 21:54:27

@James723 

hey I resolved my issue with reinstalling the firmware via the web browser and not via the app

2
2
#6
Options
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2021-01-13 07:09:58

@James723 
So far the problem seems to have resolved itself. The major thing I did (and I'm not completely sure if it helped) was to reduce all metal / Bluetooth-emitting devices between the main Deco and the Deco in my room. They might have been interfering with the signal somehow. 

I also did a website-based firmware update though so maybe that helped as well. 

2
2
#7
Options
Re:Deco M5 V3 keeps disconnecting from the main Deco after Firmware 1.5.1 update
2 weeks ago

 

Hi all, how to reinstall the latest firmware when i try to download from website the version available is lower than what i have updated via app?

0
0
#8
Options