Archer Nano T2U not locating 5Ghz, several drivers, and speed issues

Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
2020-12-20 14:57:40 - last edited 2021-01-02 09:30:55
Hardware Version: V1
Firmware Version: unknown

Hello!

 

I have a very similar issue as this post: https://community.tp-link.com/en/home/forum/topic/196864

 

I Have TP LINK ARCHER T2U NANO V1.0

I use a router TP LINK ARCHER C20(ES) V5.0 with dual band

I Use Windows 10 (attaching picture of msinfo32) 

So I think, something is happening with the drivers. Are there new drivers or something to do?

 

Thanks in advance!

 

My ISP provides me with ~100Mbps symetrical (following is connection trough ethernet cable)

 

Default windows drivers

Work for 2.4ghz, but not recognize 5Ghz networks. And give me following speeds

 

The drivers from https://www.tp-link.com/en/support/download/archer-t2u-nano/#Driver 

Work for 2.4ghz, but not recognize 5Ghz networks. And give me following speeds (very similar)

 

The driver from https://static.tp-link.com/2019/201911/20191128/T2Uv3_windows_Driverfils.zip 

Work for 2.4ghz, but not recognize 5Ghz networks. And give me following speeds (A bit better)

 

The drivers from https://static.tp-link.com/2020/202006/20200601/00015960-RTLWlanU_WindowsDriver_1030.38.0712.2019_Drv_3.00.0032.L.zip

Work for 2.4ghz, but not recognize 5Ghz networks. And give me following speeds (very similar)

 

Driver from https://static-community.tp-link.com/attach/17/7/2020/529f77cf6d834fb3abe20a7001346b5e.cab

Finally Sees Ghz Connections, but it gives me following speeds:

At 2.4Ghz

 

And at 5Ghz

 

 

 

0
0
#1
Options
1 Accepted Solution
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues-Solution
2021-01-02 09:30:29 - last edited 2021-01-02 09:30:55

@Kevin_Z 

 

Well, I just found a Solution. 

 

 

1) I downloaded the driver at https://www.realtek.com/en/component/zoo/category/rtl8812au-software

which is intended for RTL8812AU instead of RTL8811AU which in theory is T2U. However this package contains several settings for different devices.

 

2) I unziped the contents of the file to RTLWlanU_WindowsDriver_1030.25.0701.2017_DUA_Drv_3.00.0019.L

 

3) With help of windows device manager, I went to update manually 

 

 

 

 

4) Choose the path RTWLANU_Driver\Win10X64 within the unziped folder

 

 

5) It displays a list of supported devices by the same driver Including some asus devices. And within that list I choose REALTEC 8811CU

 

6) Let windows install. And voila... Now I can see my 5GHZ wifi and the speed test is satisfactory.

 

 

 

Well, my personal research ends here. Hope it helps someone else, and for the technical team at TPLINK, maybe should double check the distributed driver for the device since it seems to be incorrect, being 8811CU OR 8812AU instead of 8811AU.

 

Thanks!

Recommended Solution
3
3
#4
Options
6 Reply
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
2020-12-30 07:36:05

@EmilioSan 

 

Please check on the network adapters and see how many drivers have you installed for this adapter, if there are different drivers, remove all of them and install it from the Windows. Go to Device Manager -> Right Click the Adapter (It should be in yellow ! mark if you removed all the drivers) -> Update Driver -> Browse my computer for driver software -> Let me pick from a list of available drivers on my computer -> Install the "driver provided by Microsoft" (newest one depends on the version of Windows 10). Once the installation is successful and with no errors, then confirm again if the connection is stable.

 

Try to change different 5G wireless channels and channel width on the Archer C20, then confirm.

 

We suggest you install the latest public driver on the Windows 10:

https://static.tp-link.com/2020/202006/20200601/00015960-RTLWlanU_WindowsDriver_1030.38.0712.2019_Drv_3.00.0032.L.zip

 

 

0
0
#2
Options
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
2021-01-02 08:11:36

@Kevin_Z Hello!

Thank you for your kind response!

 

Actually Already tried with that driver, its the default one, and the one im using right now. But still, doesn't receive any 5Ghz SSID :( 

 

I Already changed between 20, 40, and 80 Hz on the C20, without success.

 

 

 

0
0
#3
Options
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues-Solution
2021-01-02 09:30:29 - last edited 2021-01-02 09:30:55

@Kevin_Z 

 

Well, I just found a Solution. 

 

 

1) I downloaded the driver at https://www.realtek.com/en/component/zoo/category/rtl8812au-software

which is intended for RTL8812AU instead of RTL8811AU which in theory is T2U. However this package contains several settings for different devices.

 

2) I unziped the contents of the file to RTLWlanU_WindowsDriver_1030.25.0701.2017_DUA_Drv_3.00.0019.L

 

3) With help of windows device manager, I went to update manually 

 

 

 

 

4) Choose the path RTWLANU_Driver\Win10X64 within the unziped folder

 

 

5) It displays a list of supported devices by the same driver Including some asus devices. And within that list I choose REALTEC 8811CU

 

6) Let windows install. And voila... Now I can see my 5GHZ wifi and the speed test is satisfactory.

 

 

 

Well, my personal research ends here. Hope it helps someone else, and for the technical team at TPLINK, maybe should double check the distributed driver for the device since it seems to be incorrect, being 8811CU OR 8812AU instead of 8811AU.

 

Thanks!

Recommended Solution
3
3
#4
Options
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
2021-01-04 11:41:31

@EmilioSan 

 

Great job. yes

 

Glad to know it resolved by installing the driver for RTL8812AU manually, we will report this to the engineers and ask them to investigate further.

 

Thank you very much for the valued finding and sharing. Good day~

1
1
#5
Options
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
2021-01-18 19:57:49

@EmilioSan thanks for the input.

 

This worked for me as well and now 5GHz network is detected by my system.

 

I'd previously updated my Windows 10 version to the latest release (20H2) and the 5GHz was not yet visible, but with these drivers I'm on it.

 

I'd even started this topic https://community.tp-link.com/en/home/forum/topic/218912 sometime ago, but I didn't receive any effective solution.

 

OTOH, I also tested other drivers included in the packege (e. g. RTL8814AU) and worked also fine. I was  wondering whether this last driver would be more suitable as the numbering is higher.

 

Hopefully TP-Link specialists make the appropriate adjustements and deliver an improved driver.

 

Thanks again and regards,

 

Fyano787

0
0
#6
Options
Re:Archer Nano T2U not locating 5Ghz, several drivers, and speed issues
2021-01-22 11:09:58

@Franz787 

 

Sure, we have reported this to the engineers, they will look into this. Thanks for the valued info, we appreciate it.

0
0
#7
Options